Gehe zu Seite: Erste Letzte |nächste|

LC-PRO-35B-MPHD gepatchte Firmware

+A -A
Autor
Beitrag
XdreaM
Ist häufiger hier
#1 erstellt: 19. Jul 2009, 19:33
Nachdem die Box anscheinend immer mal wieder neu bootet und deshalb FTP- und Samba-Server jedesmal neu von Hand gestartet werden mussten, dachte ich mir, es wäre nicht schlecht, dies per Script beim Booten automatisch zu erledigen.

Also mit dem "Firmware Hacking Tool" aus dem "MDHWord-Forum" das Firmware-Image V1.2b entpackt, Änderungen vorgenommen und neues Firmware-Image erstellt.

Dies ist also keine offizielle Firmware des Herstellers! Benutzung auf eigene Gefähr...

Die gepatchte Firmware kann hier runtergeladen werden.

Firmware instalieren:
  1. Die Datei "LC-PRO-35B-MPHD_V1_1b_01" entpacken. Darin sind die 2 Ordner "Firmware" und "system" enthalten.
  2. Die 4 Dateien (install_a, video_firmware.bin, install.flash.img und arial.ttf) aus dem Ordner "Firmware" auf einen leeren USB-Stick kopieren.
  3. Netzstecker des Mediaplayers ziehen.
  4. USB-Stick in den Mediaplayer stecken.
  5. Die Taste "Play/Stop" an der Front des Mediaplayers drücken und gedrückt halten.
  6. Netzstecker wieder einstecken.
  7. "Play/Stop"-Taste nach ca. 10 Sekunden loslassen. Firmwareupdate wird durchgeführt. Dies dauert ca. 2 Minuten. Danach startet der Mediaplayer neu.
  8. Nach dem Firmwareupdate müssen Menüsprache, die Uhrzeit, und die Netzwerkkonfiguration neu eingestellt werden.


Samba installieren (Option):
  1. In den Netzwerkeinstellungen des LC-PRO-35B-MPHD nachschauen, welche IP-Adresse vergeben/eingestellt wurde. Die IP-Adresse notieren.
  2. Die Datei "ip" in dem entpackten Ordner "system/samba/" mit einem linuxkompatiblen Editor (z.B. Notepad++) öffnen.
  3. Hier müssen nun die IP-Adresse des LC-PRO-35B-MPHD und der Name der eigenen Windows-Arbeitsgruppe eingetragen werden.
  4. Datei speichern.
  5. Den Ordner "system" mit allem Inhalt, in das Hauptverzeichnis der FAT32-Partition (HDD1) des LC-PRO-35B-MPHD kopieren.
  6. Netzstecker des LC-PRO-35B-MPHD kurz ausstecken, um den Mediaplayer neu zu booten.


Änderungen in gepatchter Firmware V1.2b.01 gegenüber der originalen V1.2b:
  • FTP-Server dauerhaft installiert (login: root, pw: keines).
  • Vorbereitung für einen Samba-Server (muss noch auf FAT32-Partition installiert werden, weil der nicht mehr in die Firmware reinpasste).
  • NTFS-Partition nun auch über das Netzwerk beschreibbar.
  • Einige Texte im deutschen Menü geändert/korrigiert.
John21
Ist häufiger hier
#2 erstellt: 01. Aug 2009, 13:56
Bei kackt er bei der WLAN Konfiguration immer ab.
Weisst du was das sein könnte?
XdreaM
Ist häufiger hier
#3 erstellt: 01. Aug 2009, 14:23
WLAN hatte ich mal testweise am laufen. Jedoch war da die Geschwindigkeit noch mieser als beim LAN - dann habe ich das gleich wieder gelassen.

Wenn ich mich recht erinnere, waren bei WLAN zwei Dinge wichtig:
1. Die LAN-Verbindung muss deaktiviert sein.
2. Eine Fixe-IP wollte er bei mir auch nicht nehmen. Also eine über DHCP vergeben lassen.

Dann sollte es eigentlich klappen...
John21
Ist häufiger hier
#4 erstellt: 01. Aug 2009, 15:06
Leider brauche ich eine feste IP-Vergabe sonst läuft nichts mehr bei uns im Haus. Was ich auch frestgestellt habe, das bei deiner FW die Reaktionszeiten bei der Fernbedienung sehr sehr hoch sind (bis zu 2-3 sek.)

Kannst du mir eine Anleitung geben wie ich Samba und FTP so daraufbekomme (am besten mit Autostart). Ich bin in Linux nicht so bewandert (aber auch kein totaler noob!).

Aber ansonsten echt gute arbeit von dir.
DANKE!!!!
XdreaM
Ist häufiger hier
#5 erstellt: 01. Aug 2009, 15:16
Langsamere Reaktionszeiten der FB habe ich bei mir nicht festgestellt

Ein Tool für FTP und Samba "von Hand" gibt es hier.

Jedoch muss man da die Server ab und zu wieder von Hand starten, weil die eben nicht im Start-Script eingetragen sind - und die Box wohl ab und zu mal komplett neu bootet.
John21
Ist häufiger hier
#6 erstellt: 01. Aug 2009, 15:43
Hast du nicht ne Ahnung wie man so ein Startscrpit erstellt? Und wo es rein muss?
XdreaM
Ist häufiger hier
#7 erstellt: 01. Aug 2009, 15:59
Das Problem ist, das Startscript ist schreibgeschützt. Ist also nicht so ohne weiteres zu ändern. Bei jedem Neubooten wird es außerdem mit dem Originalen aus dem Flash überschrieben.

Man kann es also nur ändern, wenn man die Firmware entpackt, das Startscript ändert, die Firmware wieder packt und die Box neu Flasht. Aber dann hast Du im Prinzip das gleiche, wie bei meiner gepatchten Firmware

Aber noch mal zu der langsamen FB, hast Du mal den Netzstecker gezogen und die Box komplett neu gestartet?

Ich glaube nämlich so einen Fall hatte ich mal ganz am Anfang mit der originalen FW. Da hat auch stängig die rote HD-LED geflackert und alles ging in Zeitlupe. Ein Neuboot brachte Abhilfe.


[Beitrag von XdreaM am 01. Aug 2009, 16:00 bearbeitet]
John21
Ist häufiger hier
#8 erstellt: 02. Aug 2009, 13:36
Das mit dem Neubooten hat geklappt. FB läuft jetzt flüssig.
Muss ich in der IP-Datei für den Samba-Server jede IP ändern, oder nur die erste wo IP=192.168.178.55 steht?

Was mir noch aufgefallen ist das mein Dateisystem auf der Platte NTFS ist. Das wird wohl nicht funzen oder?


[Beitrag von John21 am 02. Aug 2009, 13:38 bearbeitet]
XdreaM
Ist häufiger hier
#9 erstellt: 02. Aug 2009, 13:38
Nur die erste.
John21
Ist häufiger hier
#10 erstellt: 02. Aug 2009, 13:39
Wird das auch mit NTFS funzen? Wohl eher nicht oder?
Reicht das vielleicht wenn ich mir ne kleine FAT32 Partition auf der Platte mache?


[Beitrag von John21 am 02. Aug 2009, 13:47 bearbeitet]
XdreaM
Ist häufiger hier
#11 erstellt: 02. Aug 2009, 13:49
Wie meinst Du das mit NTFS?

Normal formatiert die Firmware die erste Partition als FAT32 (HDD1) und die zweite als NTFS (HDD2).

Der system-Ordner muss halt auf die erste Partition (HDD1). Ob das auch funktioniert, wenn Du die (nachträglich?) als NTFS formatiert hast, weiß ich nicht...
John21
Ist häufiger hier
#12 erstellt: 02. Aug 2009, 13:54
Das Problem ist das ich nur eine Partition habe. Ich hatte die Platte vorher in einem anderen Mediaplayer, hab sie also nicht im dem Gehaüse formatiert!
XdreaM
Ist häufiger hier
#13 erstellt: 02. Aug 2009, 14:01
Achso... Na dann musst Du das einfach mal probieren.

Ich hatte nur einmal kurz versucht, den Samba-Server auf meiner 2. Partition (NTFS) zu installieren. Das hatte aber irgendwie nicht geklappt. Habe dann jedoch auch nicht mehr weiter geschaut, an was das lag.
John21
Ist häufiger hier
#14 erstellt: 09. Aug 2009, 13:30
Hi,

habe jetzt alles drauf:

Auf HDD1 (FAT32) ist jetzt Samba drauf. Anpingen kann ich den Server auch nur ich kann darauf nicht zugreifen.
Irgendwelche tipps? Hänge hinter ner Frzt!Box 7270? Muss ich da irgendwas einstellen?
John21
Ist häufiger hier
#15 erstellt: 09. Aug 2009, 13:50
Falscher Alarm!!

ich habs jetzt, keine Ahung woran es lag?!?
Einfach alles nochmal neu drauf und es läuft.
Kannst du mir vielleicht sagen was du für Upload und Download-Werte via FTP und Samba hast??
XdreaM
Ist häufiger hier
#16 erstellt: 09. Aug 2009, 17:36
Insgesamt gesehen ist die LAN-Geschwindigkeit recht bescheiden. Liegt wohl hauptsächlich am verbauten Chipsatz im Player. Andere Player mit gleichem Chipsatz bringen ja anscheinend auch ähnliche Werte...

Hier meine gemessenen Werte (jeweils der Durchschnitt beim Übertragen einer 700MB Datei):

Notebook (Vista) => WLAN(54MBit) => Router => LAN(100MBit) => LC-PRO-35B-MPHD:

FTP:
FAT32 Upload: ca. 1300 kB/s
FAT32 Download: ca. 400 kB/s
NTFS Upload: ca. 500 kB/s
NTFS Download: ca. 400 kB/s

Samba:
FAT32 Upload: ca. 1800 kB/s
FAT32 Download: ca. 250 kB/s
NTFS Upload: ca. 1000 kB/s
NTFS Download: ca. 150 kB/s


PC (XP) => LAN(100MBit) => Router => LAN(100MBit) => LC-PRO-35B-MPHD:

FTP:
FAT32 Upload: ca. 1800 kB/s
FAT32 Download: ca. 400 kB/s
NTFS Upload: ca. 300 kB/s
NTFS Download: ca. 700 kB/s

Samba:
FAT32 Upload: ca. 2100 kB/s
FAT32 Download: ca. 300 kB/s
NTFS Upload: ca. 1350 kB/s
NTFS Download: ca. 250 kB/s
Bruder_O
Neuling
#17 erstellt: 19. Sep 2009, 00:18
Hallo XdreaM,

ist eine feine Sache, dein Firmware Patch. Allerdings verhält sich meine Installation nicht so zuverlässig. Habe mehrfach FW Patch und samba eingerichtet mit verschiedenen Ergebnissen. Mal wurden beide, mal nur HDD1 in der Netzwerkumgebung angezeigt. Bei der Suche nach Rechnern im Netzwerk fand ich dann die Arbeitsgruppe "Andy", doch gab es hier ein Problem mit Lese-/Schreibzugriff. Schließlich wollte ich das Firmware Hacking Tool mal selbst versuchen und stiess gleich auf das erste Problem: Welches Device (model) muss ausgewählt werden?
XdreaM
Ist häufiger hier
#18 erstellt: 19. Sep 2009, 10:23
Ich nehme im Firmware Hacking Tool immer den "Ellion HMR-700A".

Warum bei Dir der Samba nicht immer richtig funktioniert weiß ich nicht. Aber wenn die Arbeitsgruppe "Andy" auftaucht, sieht es so aus, dass das "ip" Skript nicht richtig funktioniert...

Mit diesem Skript ersetze ich den Arbeitsgruppennamen und die IP in verschiedenen Dateien. Kannst ja auch mal versuchen die Datei "system/samba/ip" zu löschen und die Einträge in den folgenden Dateien von Hand zu machen:

Deine IP -> "system/samba/nmbd/hosts"
Deine IP -> "system/samba/smbd/lmhosts"
Deine IP -> "system/samba/smbd/samba_my_ip"
Deine Arbeitsgruppe -> "system/samba/smbd/smb.conf"
Bruder_O
Neuling
#19 erstellt: 23. Sep 2009, 23:38
Habe die Konfiguration wie vorgeschlagen geändert. Wenn ich nach einem Rechner im Netz suche, finde ich den Player auch in meiner Arbeitsgruppe. In der Netzwerkumgebung wird er mir allerdings wieder nicht angezeigt. Merkwürdige Sache...
Egal, letztich kann ich auf alle Bereiche zugreifen, auch wenn's nicht so komfortabel ist.
Noch eine andere Frage: würde gerne den Webserver nutzen, der unter /tmp/www erreichbar ist. Weißt Du, wo man den Standardpfad anpassen kann? habe es mit einem Link auf hdd1 versucht, vorher dass www-Verzeichnis dorthin kopiert und das Original umbenannt. Beim nächsten Reboot war das alte www verzeichnis wieder am alten Ort, mein Link weg. Hast Du evt. einen Tip?
Besten Dank in jedem Fall!
XdreaM
Ist häufiger hier
#20 erstellt: 24. Sep 2009, 18:55
Der Pfad des Webservers wird in der /etc/inetd.conf festgelegt. Diese Datei ist allerdings schreibgeschützt. Daher muss die Änderung in der Firmware gemacht werden.

Habe den Pfad mal in einer neuen Firmware in /usr/local/etc/hdd/volumes/HDD1/system/www geändert.

Download
Bruder_O
Neuling
#21 erstellt: 03. Okt 2009, 00:37
Jo, funzt - vielen Dank!
Ist ja irgendwie nicht zu glauben, dass da ein Web Server zu Verfügung gestellt wird, und dann kann man standardmäßig keine Web-Seiten einstellen...
Aber schön zu wissen, dass es Leute wie Dich gibt, die eben mal schnell eine Lösung parat haben. Hat mich gefreut.
Falls Dir noch irgendwelche Verbesserung dieser Firm Ware einfallen - immer rüber damit!
cypher23
Neuling
#22 erstellt: 08. Okt 2009, 21:55
Hallo,
ich bin am verzweifeln, hab mehrmals die Firmware und Samba-dateien installiert, habs mit Ftp und Usb-stick probiert, hab wie vorgeschlagen die Datein vom Samba per hand geändert -> ich krieg das ding einfach nicht unter Windoof sichtbar.

Pingen - geht!
FTP - geht!
Samba, im IE wird die Testseite angezeit - geht!
Netzwerkumgebung - fehlanzeige, geht NICHT!

Gibts da was zu beachten?
Hab Vista Home Premium SP2, verbindung per WiFi.
Die anderen Geräte werden angezeigt und funktionieren auch nur das Teil net

(Ist mir gerade aufgefallen, WiFi scheint nur vorne zu funktionieren, hinten hängt sich das ding auf...)

Gruß
XdreaM
Ist häufiger hier
#23 erstellt: 08. Okt 2009, 22:24
Zum Testen, ob der Samba läuft, kannst Du ja mal probieren, ein Netzlaufwerk per Kommandozeile einzurichten:

net use m: \\LC-PRO-35B-MPHD\HDD1
cypher23
Neuling
#24 erstellt: 09. Okt 2009, 11:31
net use da war doch was....
natürlich hatt ich glatt vergessen

So, hab mir ein Kabel ausgeliehen, FW und Samba neu installiert, Einstellungen gemacht:

Kabel (DHCP bzw. Feste IP - funktioniert beides):
Pingen geht!
FTP geht!
IE Testseite geht!
Net Use - jup, das geht auch! (aber nur mit IP, nicht mit dem Namen)

Krieg trotzdem KEINE Anzeige unter Netzwerk

WiFi (Auto bzw. Manuelle config):
Pingen geht!
FTP geht!
IE Testseite geht!
Net Use - geht NICHT! (weder mit IP oder Namen)
liegt wohl am mitgelieferten USB-Stick, besorg mir da mal testweise was anderes.

irgend eine Idee?


edit:
Hab mir eine Maschine mit win2k geborgt. Geht damit auch nicht. Liegt also nicht an Vista

edit:
Bin jetzt total verwirrt!
Hab die 4 dateien per Hand editiert (Name auf HOMEMEDIA / IP 192.xxxx geändert). Jetzt kann ich per "net use" unter den alten namen LC-PRO.... oder der IP laufwerke verbinden aber nicht unter HOMEM... - trotzdem keine anzeige im Windowsnetzwerk!


[Beitrag von cypher23 am 09. Okt 2009, 16:09 bearbeitet]
rpr
Inventar
#25 erstellt: 09. Okt 2009, 16:57
Hast du einen Editor mit Linux kompatibem Textencoding verwendet (ist, glaube ich, utf8).
XdreaM
Ist häufiger hier
#26 erstellt: 09. Okt 2009, 17:07

cypher23 schrieb:

Hab die 4 dateien per Hand editiert (Name auf HOMEMEDIA / IP 192.xxxx geändert). Jetzt kann ich per "net use" unter den alten namen LC-PRO.... oder der IP laufwerke verbinden aber nicht unter HOMEM... - trotzdem keine anzeige im Windowsnetzwerk! :?


Auch nicht vergessen, nach jeder Änderung die Box neu booten! Nicht nur über die Fernbedienung oder den Power-Kopf auf "Standby" schalten. Also entweder Netzstecker ziehen oder "reboot" über Telnet.
cypher23
Neuling
#27 erstellt: 09. Okt 2009, 23:12
editor - hab notepad++ benutzt (wie empfohlen)
Reboot - hab die box per "ein-/ausschalter" runter gefahren dann den "netzstecker" gezogen kurz gewartet dann wieder eingesteckt.

Ich komm nicht dahinter, wieso mit der Änderung im "IP-File" nur die IP mit net use funktioniert aber der Name nicht erkannt wird.
Nachdem alle Dateien händisch (IP und Name) geändert wurden, geht net use mit ip und der alte Name LC-Pro... der neue Name erkennt er trotzdem nicht ????
cypher23
Neuling
#28 erstellt: 09. Okt 2009, 23:40
ES geht
Ja wirklich

Hab die Platte formatiert, FW und Samba neu installiert und wollte für heute aufgeben. Hab noch die neue Fritzbox angeschlossen, eingerichtet und wollte das Netzwerk testen und siehe da, die Box ist sichtbar!
Alles geht

Hab den alten Router angeschlossen - geht nicht
Ich kann es echt nicht glauben.
Das hatte ich noch nie, der Router scheint was gegen Samba zu haben

Naja, jetzt gehts und ich bin Froh

Danke nochmal für die Hilfe.
ranger2000
Stammgast
#29 erstellt: 13. Nov 2009, 13:58
Hallo XdreaM!

Besten Dank für die "neue" Firmware!

Nun funktioniert auch das Netzwerk
Ich hatte die Hoffnung schon fast aufgegeben.

Nun habe ich da noch 1-2 Fragen.

1. Zum Samba
In der IP Datei sollte man ja die IP des Mediaplayers eingeben und die Arbeitsgruppe.
Muss man dies nur dort wo steht:
# Hier die IP-Adresse des LC-PRO-35b-MP-HD und
# den Namen der Windows-Arbeitsgruppe eingeben!

oder auch in den ganzen Zeilen darunter anpassen ?

Dann nochwas ..In der vorletzten Zeile steht:
sedstring="s/192.168.69.55/$IP/g;s/ANDY/$ARBEITSGRUPPE/g"

"Andy" <<< soll das so bleiben oder muss ich das anpassen?


2.Der Webserver
Was kann ich mit ihm machen, und vor allem wie ?

Vielleicht habe ich ja Glück und Du schaust nochmal in diesen thread und hast die Zeit mir weitrzuhelfen ....
Ich würde ich freuen !

Gruss
ranger
XdreaM
Ist häufiger hier
#30 erstellt: 13. Nov 2009, 18:01
Hi ranger,

Deine IP und den Arbeitsgruppennamen musst Du nur oben (Zeile 7 und 8) in dem ip-script eintragen. Den Rest alles so lassen, wie es ist.

Naja, über den Webserver kannst Du z.B. HTML-Seiten, die Du auf den Player lädst, über einen Browser anschauen. Macht jetzt vielleicht für viele Anwender kaum einen Sinn. Für manche kann jedoch so ein eigener, "kostenloser" Mini-Webserver ganz interessant sein.
ranger2000
Stammgast
#31 erstellt: 13. Nov 2009, 20:24
Hallo XdreaM!

Danke für die schnelle Antwort

Der Webserver ist für mich dann wirklich nicht so wichtig dann:)

Gruss
ranger
Fons1
Neuling
#32 erstellt: 19. Nov 2009, 14:42
Danke vielmals für die tolle Firmware. Endlich kann ich die Kiste richtig nutzen. Schade, dass es LC-Power nicht schafft eine vernünftige Firmware ab Werk einzuspielen.
XdreaM
Ist häufiger hier
#33 erstellt: 28. Nov 2009, 20:15
Habe mal wieder etwas gebastelt...

V1.2b_05

- Neuer Bootscreen
ACHTUNG: Wird der neue Bootscreen geflasht, kann der originale Bootscreen nicht wieder hergestellt werden! Soll der neue Bootscreen nicht installiert werden, einfach die Datei "logo_pal.bmp" nicht auf den USB-Stick kopieren.

- Änderungen der Oberfläche
• Alle Texte und Symbole, die grün waren sind nun blau.
• Farbe der Ladeanzeige (drehende Pfeile) von rosa auf blau geändert.
• Farbe der Lautstärkeanzeige von gelb auf blau geändert.
• Screensaver-Grafik geändert.
• Sonstige kleinere Änderungen an der Oberfläche.

- Verzögerung der Filmvorschau eingebaut
Scrollt man mit der Fernbedienung durch die Filmliste, startet die Vorschau nicht mehr (meist ja ungewollt...) sofort, sondern erst nach ca. 3s. Kleiner Nachteil dabei: Der Film kann auch erst gestartet werden, nachdem die Vorschau begonnen hat.

- Nach dem Flashen, kommt nun nicht mehr automatisch der Setup-Screen
Also nicht vergessen Eure IP wieder einzustellen. Nach dem ersten Start hat die Box die IP 192.168.69.55.

Download Firmware V1.2b_05


[Beitrag von XdreaM am 29. Nov 2009, 00:53 bearbeitet]
Ruffi
Neuling
#34 erstellt: 16. Dez 2009, 15:27
hi
ich bin grad neu hier daher erst einmal hallo ^^

habe mir auch grade kürzlich das mediagehäuse zugelegt.

nachdem das dann x mal abgestürzt ist hab ich erstmal die neue FW raufgemcht und dann ging das.
also dann meine platte rein da und getestet ... läuft alles.
mit dem netzwerk hab ich mich noch nicht weiter beschäftigt.

ich kann auch mkv abspielen von der internen HD nur leider ist das video entweder von rucklern übersäht oder es entseht eine ganz fiese blockbildung.
das ist doof ^^

also meine frage @XdreaM.
du hast ja nu schon einiges mit dem FW-Editor oder Hack gemacht. ist es auch möglich auf diese weise einen neuen codec oder eine leistungssteigerung für mkvs zu integrieren?

und nebenbei .... es ist mir egal ob jemand der meinung ist : dass sollte man lieber lassen die hardware ist dafür nich gut oder sonst was. ich will das ausprobieren und mich selbst davon überzeugen

ach und nochwas ^^ ich finde den FW-Hack nicht ... könnte mir bitte jemand nen link geben oda das bei rapidshare neu uploaden oder so ... wäre voll nett

mfg Ruffi


[Beitrag von Ruffi am 16. Dez 2009, 15:31 bearbeitet]
ranger2000
Stammgast
#35 erstellt: 16. Dez 2009, 16:02
Soo ich habe nun seit einigen Tagen auch die neue FW von XdreaM auf meiner box und bin wirklich sehr zufrieden!
Das verzögerte abspielen der datein beim durchzappen des hdd inhaltes finde ich klasse!
Netzwerk funktioniert auch soweit top!

also nochmal ein riesen DANKESCHÖN an XdreaM !!!!
ohne dich wären wir wohl ganzschön aufgeschmissen, denn der support von LC ist ja nicht der Beste!

@ Ruffi

Willkommen im Forum:)

Du kannst also mkv von der internen hdd abspielen ?
Sowas ist mir recht neu.
Normal geht das nur über das netzwerk mit dem streaming tool.
leider haste da dann auch ruckler drin, zumindest bei 1080p material kommt es oft zu puffer unterbrechungen.

Was für mkv files hast du abgespielt ? also hd material, 720 /1080p ?
Würde mich echt mal interessieren.


gruss
ranger


[Beitrag von ranger2000 am 16. Dez 2009, 16:03 bearbeitet]
Ruffi
Neuling
#36 erstellt: 16. Dez 2009, 16:17
das kann ich dir jetzt grad leider garnicht so sagen bin noch aufa arbeit....

bin gegen 18h zu hause dann poste ich mal die infos....

es war aber eine xvid kompression mit mp3 audio ...
was ich dir noch sagen kann ist wenn du zeit und lust hast,
dass es die serie the vision of escaflowne war von serienjunkies. da sind mehrere ups davon... weiß nich ob man den link hier posten sollte also nur die seite steht auch in der überschrift MKV wenn du nachschauen willst ... ansonsten poste ich das heut abend nochmal
XdreaM
Ist häufiger hier
#37 erstellt: 16. Dez 2009, 21:09

Ruffi schrieb:
ist es auch möglich auf diese weise einen neuen codec oder eine leistungssteigerung für mkvs zu integrieren?

ich finde den FW-Hack nicht ... könnte mir bitte jemand nen link geben oda das bei rapidshare neu uploaden oder so ... wäre voll nett


Andere Codecs zu implementieren geht meiner Meinung nach leider nicht. Der Prozessor ist für ein Software-Decoder eben viel zu schwach. Und einen Hardware-Decoder da irgendwie "reinzubasteln" ist quasi auch nicht realisierbar.

Einen Link zum Firmware Hacking Tool findest Du hier.
Ruffi
Neuling
#38 erstellt: 16. Dez 2009, 21:26
hey danke für den link ... habs nu auch endlich geschafft das video von der platte zu kopieren -.-

also das ist echt eine zumutung ... gestern ging das noch dachte ich und dann heute ich ran da wollt das video von der platte aufn stick kopieren. der mediaplayer ist mir 5 mal abgestürzt und die übertragung von 280MB hat fast 20 minuten gedauert.

dann fing das menü noch übelst an rumzuruckeln ... schön war das nicht. bekomm schon angst dass das nen fehlkauf war

und noch was ... was fürn prozessor isn da drinne

naja hier die daten zum MKV-video was ich abgespielt hab

Complete name : I:\The Vision of Escaflowne E02 Das M�dchen vom Mond der Illusionen.mkv
Format : Matroska
File size : 279 MiB
Duration : 23mn 8s
Overall bit rate : 1 684 Kbps
Encoded date : UTC 2005-02-02 17:08:10
Writing application : mkvmerge v1.0 ('Soul Food To Go') built on Nov 17 2004 15:06:35
Writing library : libebml v0.7.3 + libmatroska v0.7.4


Format : MPEG-4 Visual
Format profile : Streaming Video@L1
Format settings, BVOP : Yes
Format settings, QPel : Yes
Format settings, GMC : 3 warppoints
Format settings, Matrix : Default (H.263)
Codec ID : XVID
Codec ID/Hint : XviD
Duration : 23mn 8s
Bit rate : 1 409 Kbps
Width : 704 pixels
Height : 528 pixels
Display aspect ratio : 4/3
Frame rate : 25.000 fps
Resolution : 24 bits
Colorimetry : 4:2:0
Scan type : Progressive
Bits/(Pixel*Frame) : 0.152
Stream size : 233 MiB (84%)
Title : MainVideo
Writing library : XviD 1.0.3 (UTC 2004-12-20)


[Beitrag von Ruffi am 16. Dez 2009, 21:33 bearbeitet]
XdreaM
Ist häufiger hier
#39 erstellt: 16. Dez 2009, 22:03

Ruffi schrieb:
was fürn prozessor isn da drinne


/ # cat /proc/cpuinfo
system type : Realtek Venus
cpu model : MIPS 4KEc V6.12
BogoMIPS : 202.34

/ # cat /proc/meminfo
MemTotal: 56836 kB
MemFree: 12628 kB
Ruffi
Neuling
#40 erstellt: 17. Dez 2009, 15:41
hättest du denn ne ahnung, wie man da neue codecs reinbaut oder welchen man nehmen müsste um mkv unterstützen zu können ?
ich mein prozessorleistung hin oder her ^^ einige würden dann mit sicherheit laufen ( einige videos )
XdreaM
Ist häufiger hier
#41 erstellt: 18. Dez 2009, 17:11
Mit Codecs kenne ich mich nicht aus. Jedenfalls wären dazu Änderungen (am leider nicht verfügbaren) Quelltext der Firmware notwendig.

Und selbst wenn man da einen Softwarecodec reinbasteln könnte, wäre die Prozessorleitung viel(!!!) zu gering für ein mkv-Decoding.
ranger2000
Stammgast
#42 erstellt: 18. Dez 2009, 17:57
@ruffi

also ich sehe das wie XdreaM !

die Box gibt es schon über 1 Jahr .. hab sie selbst schon 14 Monate.
Zudem ist der selbe Chipsatz auch in einigen anderen Mediaplayern verbaut.

Wenn es da die möglichkeit gäbe mkv abzuspielen, indem man nen codec einbaut, dann wäre dies schon längst bekannt.

Es gibt da draussen soviele "bastler" die ahnung von der materie haben und wenn die bisher nix gebracht haben, dann glaub ich kaum das du als "neuling" mit der box Wunder vollbringen klannst die bisher keiner geschafft hat.

Also nicht falsch verstehen .. nix gegen dich, aber denk mal wenn du mkv abpielen willst hast du die falsche box!

dann kauf dir lieber zB. die neue WD Live .. .habe ich als Zweitgerät für 1080p sachen.
Serien schaue ich zb auch nur mit dem LC Gerät weil das WD Teil nicht so eine freie Ordnernavigation erlaubt.
rpr
Inventar
#43 erstellt: 18. Dez 2009, 18:40
In Ruffis fall liegt es allerdings nicht am Codec (xvid) sondern am Container (mkv).
Praktisch bin ich der selben Meinung wie die Vorposter - statt auf ein unwahrscheinliches aber mögliches Update, das xvid im mkv ermöglicht, zu warten, ist es besser, entweder den Player zu wechseln oder die Filme in einem anderen Container neu zu packen.
Ruffi
Neuling
#44 erstellt: 18. Dez 2009, 22:54
nun gut dann will ich mal nachgeben ^^ ... das ding zurückbringen ist jetzt doof weil der preisverfall zu groß wäre ...
hab mich auch schon mit dem gedanken angefreundet das alles in nen anderen container zupacken.

wenn irgendwann das geld mal wieder stimmt hol ich mir gleich was richtiges. aber ansonsten is das ding ja nicht schlecht. nur mit na großen platte drinne ist es nicht das schnellste aber das passt.

bedank mich trotzdem und danke für deine firmewareups sind top
daki1978
Neuling
#45 erstellt: 22. Dez 2009, 23:06
Hi freunde...

gibt es die möglichkeit, die firmware so umzubauen, dass man mit dem gerät auch dvd brennen kann?

z.b. dvd lw an USB hängen, evtl. zum abspielen von DVD

aufnahmen auf dvd brennen, usw
XdreaM
Ist häufiger hier
#46 erstellt: 24. Dez 2009, 17:32
Ich sag's mal so, theoretisch wäre es zwar sicher möglich DVDs über einen USB-Anschluss des Mediaplayers zu brennen.

Jedoch wird sich da wohl niemand finden, der Dir das programmiert, weil der Aufwand hierfür ganz einfach viel zu hoch ist.
daki1978
Neuling
#47 erstellt: 25. Dez 2009, 14:32
ok. dann danke ich dir mal...

hmm... wie wäre es mit einem modul, dass man IPTV odfer ähnliche Videoinhalte über das Web gucken kann?

like youtube oder so...

ist das möglich?
XdreaM
Ist häufiger hier
#48 erstellt: 25. Dez 2009, 16:54
Auch hier gilt eigentlich wieder das gleiche: Theoretisch machbar ja, praktisch umsetzbar leider kaum...

Ich versuche mal zu erklären, warum es so schwierig ist, die Firmware des Mediaplayer, mit eigenen Programmteilen zu erweitern:

Problem 1:
Der Quelltext der Firmware des LC-PRO-35B-MPHD ist nicht verfügbar. Der Hersteller, bzw. Händler LC-Power gibt die Firmware auch nicht heraus. Hat Sie wahrscheinlich auch nicht mal selber, da die Software wohl irgendwo in Fernost entwickelt wird.

Das Problem mit dem nicht vorhandnen Quelltext kann man zwar umgehen, indem man eine Firmware, mit verfügbarem Quelltext, eines ähnlichen Mediaplayers nimmt. Die Firmware des Ellion HMR-351H, läuft nach ein paar Änderungen nämlich auch auf dem LC-PRO-35B-MPHD (zumindest teilweise).

Problem 2:
Umfang der Firmware… Der Quelltext von der Hauptapplikation des Ellion HMR-351H, besteht aus über 7.000 Dateien, verteilt in 700 Ordnern! Das sind (ganz grob geschätzt) über 350.000 Zeilen Quelltext, geschrieben in C.

Wenn man nun irgendwas eigenes (wie z.B. DVD brennen, IPTV oder Youtube schauen) in die Firmware einbauen will, muss man erst mal den vorhandnen Quelltext verstehen können, um überhaupt irgendwas ändern oder erweitern zu können. Das ist bei dem Umfang der Software nun mal keine Kleinigkeit.

Problem 3:
Die neuen Funktionen müssten von irgendjemanden ja dann auch erst mal programmiert werden, bzw. vorhandene Quelltexte an die Firmware des Mediaplayers angepasst werden.

Problem 4:
Der geänderte, neue Quelltext muss dann neu compiliert werden, damit die Applikation überhaupt auf dem Mediaplayer läuft. Es gibt zwar schon eine gute Beschreibung, wie man das macht. Das ist aber doch nicht ganz so einfach, wie es sich auf den ersten Blick vielleicht anhört…

Problem 5:
Der Flashspeicher des LC-PRO-35B-MPHD ist schon mit der aktuellen Firmware fast randvoll. D.h. eine erweiterte Firmware müsste wohl auf die HD ausgelagert werden. Die HD-Partitionen werden aber momentan selber erst von der Hauptapplikation (DvdPlayer) gemountet. Also sind auch hier wieder weitere Änderungen im Linuxsystem notwendig.


Zusammengefasst:
Machbar ist zwar fast alles, aber eben nur mit sehr, sehr, sehr großem Aufwand…
Bright_star
Neuling
#49 erstellt: 03. Jan 2010, 21:42
Gutes neujahr alle aus Holland. Ich bin neu hier und hab auch ein LC-PRO-35B-MPHD seit 2 monate und wolte mahl meine ergebnisse erzählen.

Am anfang wolte mein LC eine neue Samsung F3 1TB HDD nich gut erkennen aber das war ein S-ATA2 interface hardware fehler an HDD und nach umtausch fur ein neue Seagate Barracuda 0.5TB lauft es gut.

@ XdreaM dankeschön für V1.2b_05 !

Das klein Webserver freigabe finde Ich fabelhaft. Ich mache u.a. foto's rauf und kan die selber an fernseher und freunde könne es via http://meinIP/ sehen. Ich ofne dan port 80 im Linksys router.
Ich hofne wohl das es ausen HDD1/system/www/ dicht ist.
Man benotigt dann kein pc laufen zu lassen, nur das LC.
Was ich aber Beobachtet habe ist das die HDD nie in sleep mode geht wann POWER eigeschalted bleibt.

Ich arbeite mit festen IP's, 100Mbit, Linksys BEFVP41,P4 PC-XP, Total Commander 7.02a.

Kan von LC aus mein freigegeben PC verzeichnisse alle sehen und daraus kopieren und spielen.

Von PC aus:

/tmp/usbmounts/sda1 sehe ich usb stick vorne
/mnt/usbmounts/sdf1 sehe ich usb stick hinten

HDD1 FAT32: 2100 KB up / 2300 KB down
HDD2 NTFS : 750 KB up / 2300 KB down

KiloBytes mittelwerten gehen etwas schneller als bei XdreaM, nur NTFS up bleibt hinten. SAMBA gebrauch ich nicht, kenn mich nicht so aus mit linux.

Meistens brecht die FTP verbindung gleich nach ein grosses File upload ab. Sieht aus wie ein TIMEOUT schön fertig ist und BFTPD nach transfer gleich aufhängt. Passiert auch mal im mitte eines transfer, aber mit Total Commander kan man dann FTP gross file weiter uploaden ohne jedes mahl die GB's von anfang zu machen.

Das BFTPD aufhangen sieht aus ob passiert ofter bei FAT32 upload und beschäftiges netz.

Der NTFS/FAT32 habe ich 50%/50% eingesteld aber wann das NTFS upload nicht schneller geht währe es besser NTFS nur 10-20% gross zu machen nür für > 2GB video files.

Ich hab mal kurz port 21 im Linksys offen gesteld, dann liegt aber die ganze FTP://meinIP/ root verzeignis offen im inet. Es währe wohl schön neben denn HTTP auch die FTP server mit Passwörter und Verzeichnisse zu beschranken. Kann man einfach selbst alles hosten. So wird aus LC-PRO-35B-MPHD ein super multi geräht !

1) Muss dann aber /etc/ftp/bftpd.cnfg mit hack geandert werden in firmware weil das jetzt nicht uberschrieben werden kann ?

/etc/ftp/bftpd meldet V1.3 aber jetzt V2.6 hat viele verbesserungen.http://bftpd.sourceforge.net/news.html#032150

2) Ist dass alte BFTPD zu erzätzen oder gibt es die gleiche probleme wie genannt von XdreaM ?

3) Ist die Firmware updater ein teil von firmware selber ?
Weil ich mich scheue mit die firmware rund zu basteln und der LC mir dann mal gar nicht mehr geht.
XdreaM
Ist häufiger hier
#50 erstellt: 04. Jan 2010, 22:07
Hallo Bright_star,


Bright_star schrieb:

Ich hofne wohl das es ausen HDD1/system/www/ dicht ist.

Ich denke mal, zumindest für alle normalen User ist es dicht.


Bright_star schrieb:

Was ich aber Beobachtet habe ist das die HDD nie in sleep mode geht wann POWER eigeschalted bleibt.

Ein Sleepmode für die HDD wird wohl vom Betriebssystem nicht unterstützt.


Bright_star schrieb:

/etc/ftp/bftpd meldet V1.3 aber jetzt V2.6 hat viele verbesserungen.
2) Ist dass alte BFTPD zu erzätzen?

Ich habe mal versucht die V2.6 zu kompilieren, jedoch funktioniert das (noch) nicht. Das Programm wird zwar ohne Fehlermeldung erstellt, läuft aber leider nicht auf dem Mediaplayer. Da kenne ich mich mit Linux und kompilieren zu wenig aus...


Bright_star schrieb:

3) Ist die Firmware updater ein teil von firmware selber ?
Weil ich mich scheue mit die firmware rund zu basteln und der LC mir dann mal gar nicht mehr geht.

Der Firmwareupdater wird vom Firmware-Hacking-Tool nicht geändert.


Bright_star schrieb:

Ich hab mal kurz port 21 im Linksys offen gesteld, dann liegt aber die ganze FTP://meinIP/ root verzeignis offen im inet. Es währe wohl schön neben denn HTTP auch die FTP server mit Passwörter und Verzeichnisse zu beschranken.

1) Muss dann aber /etc/ftp/bftpd.conf mit hack geandert werden in firmware weil das jetzt nicht uberschrieben werden kann ?


Das ist richtig, beim FTP-Zugang über "root" liegt auch das ganze root-Verzeichnis offen.

Die Datei /etc/ftp/bftpd.conf ist schreibgeschützt und kann so nicht geändert werden. Daher habe ich die bftpd.conf mal nach usr/local/etc verschoben, dort kann die Datei geändert werden.

Download Firmware V1.2b_06

FTP-User mit Passwort und beschränktem Zugriff anlegen:
Die Datei /usr/local/etc/passwd öffnen und mit dem neuen User ergänzen. Z.B.

test:vr7sH1FcJFZKM:0:0:root:/tmp/hddmedia/HDD1/system/ftp:/bin/sh

legt den User "test" mit dem Passwort "test" an. Der User hat nur Zugriff auf das Verzeichnis "/tmp/hddmedia/HDD1/system/ftp".

Das Passwort muss verschlüsselt (vr7sH1FcJFZKM = test) gespeichert werden! Passwörter kann man hier verschlüsseln lassen.

Dem User "root" den Zugriff sperren:
Die Datei /usr/local/etc/bftpd.conf öffnen. Beim User root die Zeile ANONYMOUS_USER="yes" löschen, oder mit "#" auskommentieren.


[Beitrag von XdreaM am 04. Jan 2010, 22:09 bearbeitet]
Bright_star
Neuling
#51 erstellt: 05. Jan 2010, 01:35
XdreaM du bist ja super Mann !
Ich schaue erst jetzt im Forum aber mach morgen weiteren test.
Suche:
Gehe zu Seite: Erste Letzte |nächste|
Das könnte Dich auch interessieren:
LC-PRO-35B-MTV Firmware Update
hanskes am 26.01.2010  –  Letzte Antwort am 27.01.2010  –  2 Beiträge
Neue Firmware für Noxon 2
RoadZilla am 25.12.2007  –  Letzte Antwort am 19.11.2008  –  3 Beiträge
LC-PRO-35B-MPHD Webserver / MKV
Xaveen am 17.09.2009  –  Letzte Antwort am 18.09.2009  –  3 Beiträge
Noxon Firmware
Atoll116 am 11.04.2012  –  Letzte Antwort am 12.04.2012  –  4 Beiträge
Neuste Firmware?
gianni123 am 17.08.2013  –  Letzte Antwort am 19.08.2013  –  3 Beiträge
WDTV Firmware + Cover
tiCal am 13.08.2009  –  Letzte Antwort am 18.09.2010  –  12 Beiträge
WD TV Live Firmware
sorbas-1 am 08.09.2011  –  Letzte Antwort am 08.09.2011  –  5 Beiträge
EMTEC Q800 S800 neue Firmware 519
marling am 13.01.2009  –  Letzte Antwort am 19.01.2010  –  19 Beiträge
iRadio Firmware 6905 Favoriten
am 25.01.2009  –  Letzte Antwort am 26.01.2009  –  4 Beiträge
Betreff: Mediaplayer/Recorder LC-PRO-35B-MPHD
Nicetolife am 08.11.2008  –  Letzte Antwort am 23.11.2010  –  34 Beiträge

Anzeige

Aktuelle Aktion

Partner Widget schließen

  • beyerdynamic Logo
  • DALI Logo
  • SAMSUNG Logo
  • TCL Logo

Forumsstatistik Widget schließen

  • Registrierte Mitglieder846.869 ( Heute: 15 )
  • Neuestes MitgliedBea*
  • Gesamtzahl an Themen1.412.656
  • Gesamtzahl an Beiträgen18.893.489

Hersteller in diesem Thread Widget schließen