Sie sind bereits Community-Mitglied? Dann loggen Sie sich hier ein!

Auto-Login
Passwort vergessen?


Gehe zu Seite: Erste Letzte |nächste|

Samsung LED TV, DLNA, IB-, Taurus-, ALDI-NAS, Linux PC, MediaTomb und Serviio

+A -A
Autor
Beitrag
liab
Inventar
#1 erstellt: 28. Jul 2010, 06:38
Nachdem ich im Netz lange nach Lösungen gegen die Meldung "Dateiformat wird nicht unterstützt" gesucht hatte,
hier meine erfolgreiche Lösung mit MediaTomb. Getestet bei der Taurus-LAN (baugleich IB-NAS4220-B),
IB-NAS4220-B und PC mit kubuntu 10.04, Samsung UE46C6800.

Einbau in die Taurus, Vorteil spielt fast alle Formate:

1. mediatomb-static-0.11.0-r1-linux-uclibc-armv4 runterladen, http://downloads.sourceforge.net/med...c-armv4.tar.gz
2. Entpacken im PC
3. Mediaserver der Taurus aktivieren. Er hat dann die Ordner public/mediaserver/music und videos
4. Mit ssh in die Taurus gehen, ssh muß evt. vorher aktiviert werden:
sudo ssh root@192.168.0.212
dann
cd /
5. Den Ordner mediatomb auf der Taurus in das Verzeichnis public kopieren
6. Die Datei public/mediatomb/usr/bin/mediatomb in mediaserver umbenennen
7. Auf die Ausführrechte von mediatomb.sh und und public/mediatomb/usr/bin/mediaserver
achten!
8. Die Datei mediatomb.sh editieren
9. Vor dem Eintrag "LAUNCHDIR=`pwd`" den Befehl "cd /mnt/ide1/public/mediatomb" eintragen
10. Bei $LAUNCHDIR... mediatomb durch mediaserver ersetzen:
$LAUNCHDIR/usr/bin/mediaserver -m $LAUNCHDIR -f config
11. Auf der ssh Konsole nach /usr/hddapp/sbin navigieren
12. Orginal mediaserver retten mit:
mv mediaserver mediaserver-org, mit ls kontrollieren
13. Link nach mediatomb.sh anlegen:
ln -sf /mnt/ide1/public/mediatomb/mediatomb.sh /usr/hddapp/sbin/mediaserver
Mit ls -l den Link überprüfen. Jetzt wird bei der Taurus anstelle des originalen
"mediaserver" "mediatomb" gestartet.

14. Nach dem ersten Start von mediatomb (heißt jetzt mediaserver), bildet sich in public/mediatomb/config die Datei config.xml.
Die Eingabe ps in der ssh Konsole muß jetzt etwa so aussehen:
5958 root 524 S /bin/sh /usr/hddapp/sbin/mediaserver
5962 root 2424 S /mnt/ide1/public/mediatomb/usr/bin/mediaserver -m /mnt/ide1/pu

Jetzt kommt für Samsung LED-TV der allerwichtigste Schritt, sonst kommt die Meldung "nicht unterstütztes Dateiformat"!

config.xml editieren und hier yes statt no, sonst gehen bei der FB Eingabe Pause und Tasten < > nicht:

<protocolInfo extend="yes"/>

dies vor </server> (armv4 Version) bzw. <extended-runtime-options> (PC Version) einfügen:

<custom-http-headers>
<add header="transferMode.dlna.org: Streaming"/>
<add header="contentFeatures.dlna.org: DLNA.ORG_OP=01"/>
</custom-http-headers>

Anmerkung: Im Netz findet man hinter DLNA.ORG_OP=01 eine lange Zahlenkette. Bei mir ist die nicht erforderlich.

und bei <mappings> zusätzliche Formate eintragen. Bei mir sind das bisher:
<map from="mp2t" to="video/mpeg"/>
<map from="ts" to="video/mpeg"/>
<map from="mpg" to="video/mpeg"/>
<map from="avi" to="video/mpeg"/>
<map from="mkv" to="video/mpeg"/>

Jetzt noch mit dem mediatomb web-server die Dateien freigeben, damit die Daten in der Datenbank mediatomb.db aktuallisiert werden.
mit dem Webinterface unter Database die Dateieinträge überprüfen. Da sollte bei Class: object.item.videoItem
und bei Mimetype: video/mpeg stehen. Jetzt schluckt mein Samsung fast alles. Wenn bei Mimetyp was anderes steht,
diesen Dateityp einmappen, z.B. <map from="xyz" to="video/mpeg"/>.

Nach diesem Muster geht Mediatomb jetzt bei mir auch auf einem Linux PC und auf der IB-NAS4220-B, bei dieser nimmt man
statt Mediaserver Twonky Media.

Beim PC geht die ubuntu Version und auch die von http://mediatomb.cc/, muß man allerdings noch kompilieren.


[Beitrag von liab am 28. Jul 2010, 20:27 bearbeitet]
liab
Inventar
#2 erstellt: 29. Jul 2010, 03:15
Hier noch eine wichtige Änderung der config.xml für MediaTomb auf dem PC!

MediaTomb spielt jetzt auch auf dem Samsung TV flv-Dateien via vlc Transcode sauber ab.

<custom-http-headers>
<add header="transferMode.dlna.org: Streaming"/>
<add header="contentFeatures.dlna.org: DLNA.ORG_OP=00"/>, nicht 01 - transcode flv geht sonst nicht!
</custom-http-headers>

und bei <mappings> ändern:
<map from="flv" to="video/x-flv"/> in <map from="flv" to="video/flv"/>, sonst kommt "Videocodec nicht unterstützt"

<transcoding enabled="yes">

<transcode mimetype="video/flv" using="vlcmpeg"/>

<profile name="vlcmpeg" enabled="yes" type="external">

Getestet mit UE46C6800 und kubuntu lucid. Mit dieser Installation von MediaTomb spielt auch Patriot BoxOffice flv-Dateien.


[Beitrag von liab am 29. Jul 2010, 03:40 bearbeitet]
Snorre_der_Wikinger
Ist häufiger hier
#3 erstellt: 29. Jul 2010, 10:30
Hallo liab,

mit "Tasten < >" meinst du die Vor- und Zurückspulen Tasten?

Kannst Du Spulen?

Wenn ja probier ich mal die neueste MediaTomb Version auf meine Puppy Linux Station zu kompilieren.

So long
Snorre der Wikinger
liab
Inventar
#4 erstellt: 29. Jul 2010, 13:13
Ja, meine ich. Auf der FB funktionieren Die Tasten "links", "Eingabe", "rechts, "Pause", "Play" und "Stop".

Aber, Spulen geht bei mediatomb auf den PC recht ordentlich, aber auf dem NAS sehr stockend, ist unbrauchbar. NAS ist wohl zu langsam.
Spulen geht nicht bei Transcodierung (flv).

Bei mediatomb auf dem PC funktionieren auch zu anderen Servern gemountete Verzeichnisse einwandfrei. Beim Standard W7 geht das nicht, bei XP kann ich es mit dem Samsung Share Manager zwar einrichten, trotzdem geht es nicht.

Ich brauchte zum Compilieren von mediatomb noch diese Pakete:

sudo apt-get install libmysql++-dev
sudo apt-get install expat
sudo apt-get install lib64expat1
sudo apt-get install lib64expat1-dev
sudo apt-get install libexpat1
sudo apt-get install libexpat1-dev
sudo apt-get install libexpat1-udeb
sudo apt-get install libsqlite3-dev
sudo apt-get install libexif-dev


[Beitrag von liab am 29. Jul 2010, 13:20 bearbeitet]
liab
Inventar
#5 erstellt: 29. Jul 2010, 14:37
Jetzt habe ich aber doch eine Macke gefunden.

Bei <add header="contentFeatures.dlna.org: DLNA.ORG_OP=00"/> geht Spulen nicht mehr, dafür aber flv.

Bei <add header="contentFeatures.dlna.org: DLNA.ORG_OP=01"/> geht Spulen, aber flv nicht mehr.

Da weiß ich im Moment nur die Lösung, mediatomb je nach Bedarf mit unterschiedlicher config.xml zu starten.

Ich muß noch bemerken, dass einige flv-Dateien mit mediatomb auch ohne transcode abgespielt werden. Das sind die, die der Samsung auch von der usb-HD abspielt.

Ich habe aber viele die nicht von der usb-HD gespielt werden. Da muß wie beschrieben verfahren werden.


[Beitrag von liab am 29. Jul 2010, 17:28 bearbeitet]
HMZ
Neuling
#6 erstellt: 11. Aug 2010, 13:37
Funktioniert bei Dir auch die Pause-Taste an der FB, wenn Du Dir ein Video ansiehst, das von Mediatomb transcodiert wird? (Ich meine die "on-the-fly"-Transcodierung in Mediatomb.)

Gruß
Heiner
liab
Inventar
#7 erstellt: 11. Aug 2010, 15:03
Von meinem Nachbarn habe ich einige flv's zum Testen bekommen - ich kannte die garnicht. Da sind 3 Arten von flv dabei:

1. Kurze, die gehen beim Samsung auch über usb
2. Lange (über 500 MB), die gehen nicht über usb, aber über Meditomb incl. Spulen und Pause.
3. Lange, die gehen nicht über usb und nicht über Meditomb normal gestartet. Wenn ich aber den Wert "DLNA.ORG_OP=0" setze, gehen auch die über Mediatomb, dann aber ohne Spulen und ohne Pause.

Habe in einem Sony Board gelesen, dass das nach den DLNA-Vorgaben so gewollt ist (01 mit Spulen 00 ohne Spulen).


[Beitrag von liab am 11. Aug 2010, 15:05 bearbeitet]
HMZ
Neuling
#8 erstellt: 11. Aug 2010, 20:15
Hmmm, mit flv's habe ich bisher noch keine Erfahrung. Bei mir sind es die HQ-Aufnahmen von onlinetvrecorder.com (h264 avi's in PAL 16:9 anamorph). Die kann ich mir mit Mediatomb zwar schön und flüssig zu mpeg2 transcodieren, aber mit Pause ist da nichts.

Bei nicht transcodierten Videos hingegen fluppt das.

????
liab
Inventar
#9 erstellt: 11. Aug 2010, 21:37
Was hast Du in der config.xml unter <custom-http-headers> stehen?
HMZ
Neuling
#10 erstellt: 11. Aug 2010, 22:38
Das:

<custom-http-headers>
<add header="transferMode.dlna.org: Streaming" />
<add header="contentFeatures.dlna.org: DLNA.ORG_OP=01" />
</custom-http-headers>

Gruß
Heiner
liab
Inventar
#11 erstellt: 11. Aug 2010, 22:54
Das ist ok. Spult er denn und hat Pause, wenn nicht transcodiert wird?

Wie hast Du es überhaupt geschafft mit DLNA.ORG_OP=01 ordentlich zu transcodieren? Bei mir geht es nur mit OP=0, egal ob bei avi oder flv.

Bei 01 geht er zwar in den transcode Modus, aber es bleibt dunkel.


[Beitrag von liab am 12. Aug 2010, 04:09 bearbeitet]
HMZ
Neuling
#12 erstellt: 12. Aug 2010, 08:37
Zunächst mal vorab zur Info:

Ich betreibe Mediatomb auf einem PC mit Ubuntu 10.04 und streame damit zu meinem Samsung-TV.



Spult er denn und hat Pause, wenn nicht transcodiert wird?


Pause ja, Spulen nein.



Wie hast Du es überhaupt geschafft mit DLNA.ORG_OP=01 ordentlich zu transcodieren? Bei mir geht es nur mit OP=0, egal ob bei avi oder flv.


Ging bei mir mit diesen Einstellungen sofort. Die Einstellungen für die Konfiguration habe ich mir hier geholt.

Gruß
Heiner
liab
Inventar
#13 erstellt: 12. Aug 2010, 14:51
Hallo Heiner,

Du weißt, dass bei DLNA Pause auch mit Eingabe und Spulen mit den Tasten rechts und links geht?

Ich habe auch lucid aber mit kde Oberfläche. MediaTomb habe ich Version 0.12.1. Auf dem Ubuntu Server liegt eine Version älter.

Mit der "00" transcodiert er bei mir einwandfrei, spult aber nichts. Mit der "01" transcodiert er nicht, spult dafür aber.
Habe mir deshalb ein Startskript gemacht mit Auswahl der beiden Möglichkeiten.

http://s5.directupload.net/file/d/2249/rocaigi2_png.htm

Bei den zahlreichen Meldungen im Konsolenfenster beim Transcodieren sehe ich bei beiden Varianten keinen Unterschied, nur wird die eine nicht hell.

Gruß
liab


[Beitrag von liab am 12. Aug 2010, 14:56 bearbeitet]
HMZ
Neuling
#14 erstellt: 12. Aug 2010, 22:32
Hi Liab,


Du weißt, dass bei DLNA Pause auch mit Eingabe und Spulen mit den Tasten rechts und links geht?


Ja, das zeigt mir der Samsung bei nicht zu transcodierenden Videos sogar in einer Bildschimmeldung an!


MediaTomb habe ich Version 0.12.1. Auf dem Ubuntu Server liegt eine Version älter.


Hmm, müsste ich auch mal ausprobieren - ich hab' noch die 0.12.0. Gibt's für die 0.12.1 irgendwo eine deb, oder muss ich die selbst kompilieren?


Mit der "00" transcodiert er bei mir einwandfrei, spult aber nichts. Mit der "01" transcodiert er nicht, spult dafür aber.


Seltsam - bei mir ist das völlig wurscht, ob ich da "00" oder "01" eingebe - er transcodiert immer und macht nie Pause! Ich hatte aber anfangs auch Probleme beim Transcodieren, und zwar kamen die Videos immer nur sehr ruckelig und voller Aussetzer und Artefakte auf dem TV an. Zuerst dachte ich, meine DLAN-Verbindung sei schuld daran. Aber dann habe ich in mein aktiviertes Transcoding-Profil folgende Zeile eingefügt:

<use-chunked-encoding>no</use-chunked-encoding>

Seitdem kommen die Videos glasklar auf dem TV an - nur anhalten kann ich sie leider nicht. Vielleicht hilft das ja auch bei Deinem Problem???

Wenn ich übrigens von einem anderen PC aus, z.B. mit VLC, auf den Mediatomb zugreife, kann ich auch transcodierende Videos anhalten. Nur vom TV funktioniert's leider nicht.


Gruß
Heiner
liab
Inventar
#15 erstellt: 12. Aug 2010, 23:04
Hallo Heiner,

Dein Eintrag im transcode Profil ändert nichts bei mir. Mit meiner jetzigen Lösung kann ich auch leben. Spulen geht ja wenigsten im Normalfall.

Wäre natürlich bei transcode auch wichtig. Vorgestern hing ein transcodierter Film nach 80 Minuten. Hatte dann nur die Option, alles nochmal zu sehen, oder am PC zu Ende schauen - was ich tat.

Die muß man selbst kompilieren, wie das geht habe ich weiter oben beschrieben - ist ganz einfach.

Das Problem ist tatsächlich der Samsung. Zugriff von anderen Geräten auf MediaTomb geht einwandfrei.

Gruß
liab
liab
Inventar
#16 erstellt: 13. Aug 2010, 02:25
Hallo heiner,

habe eben mal die MT Version 0.12.0 probiert, ist bei mir dasselbe Ergebnis. Achtung, andere config Version!

MT Version 0.12.0: <config version="1"...
MT Version 0.12.1: <config version="2"...

Unsere Unterschiede werden wahrscheinlich durch den Samsung verursacht, ich habe den ue46c6800, mit Firmware ...13, aktuell ist ...16.

Man kann auch vlc aktiv (nicht als dummy) laufen lassen und dann am PC beim vlc spulen. Weiß aber leider nicht mehr wie das geht.

Hast Du auch immer bei jeder Ordneraktion am Samsung diese Fehlermeldung im Konsolenfenster:
ERROR: ActionRequest::update(): response is nil, code -115

Ich habe diese Nervensäge zwar in der action_request.cc weggemacht, wüßte aber trotzdem gerne, was sie bedeutet.

Gruß
liab


[Beitrag von liab am 13. Aug 2010, 03:57 bearbeitet]
liab
Inventar
#17 erstellt: 14. Aug 2010, 05:22
Habe den transcode mode geringfügig verbessert. Es geht jetzt Pause und Eingabe. Dazu muß in der Datei cds_resource_manager.cc die Zeile 468 von

extend = extend + D_OP + "=00;" +
nach
extend = extend + D_OP + "=01;" +
geändert werden.

Damit ist der Stand bei mir jetzt so:

Ohne transcode funktionieren Spulen und Pause, mit transcode leider nur Pause. Das ganze scheint auch abhängig vom TV-Modell zu sein.
Ob auch von der Firmware, weiß ich nicht.


[Beitrag von liab am 14. Aug 2010, 05:23 bearbeitet]
HMZ
Neuling
#18 erstellt: 14. Aug 2010, 20:40
Liab, lass Dich knutschen!!!

Genau das war's. Jetzt lassen sich auch bei mir transcodierende Videos pausieren. Spulen ist zwar immer noch nicht, ist aber auch nicht so wichtig wie Pause (Kind wird wach, Blase zwickt, Bier ist alle...)

Besten Dank!
Heiner
liab
Inventar
#19 erstellt: 14. Aug 2010, 22:23
Hallo Heiner,

das freut mich. Meine Kinder sind zwar aus dem Haus, aber Blase und Bier fordern einen dafür öfter.

Ich bin weiter am Problem dran, finde aber einfach im Netz keinen kompletten DLNA Befehlssatz. Auch die zwielichtige Rolle des Parameters DLNA.ORG_OP wird nirgends erklärt.

Vielleicht kannst Du noch Deinen Stand hier eintragen:

http://forum.ubuntuu...client/#post-2589611

etwa so, wie ich es gemacht habe. Dann hat man eine gute Übersicht über das was je nach Modell und Firmware möglich ist.
Ich werde mich hüten mein TV upzudaten, wer weiß, ob es dann noch so gut geht.

Einen schönen Sonntag
liab
liab
Inventar
#20 erstellt: 15. Aug 2010, 02:08
Statt vlc ist mencoder auch gut geeignet zum Trancodieren. Scheint stabiler zu sein und keine Klötzchen - ist aber nur der erste Eindruck.
Hat keinen Einfluß auf Pause und Spulen!

Das geht so:

sudo apt-get install mencoder

Dann in der config.xml zusätzlich ein mencoder Profil erstellen.

<transcode mimetype="video/xyz" using="mencodermpeg"/>

<profile name="mencodermpeg" enabled="yes" type="external">
<mimetype>video/mpeg</mimetype>
<accept-url>yes</accept-url>
<first-resource>yes</first-resource>
<accept-ogg-theora>yes</accept-ogg-theora>
<agent command="mencoder" arguments="%in -oac lavc -ovc lavc -of mpeg -lavcopts vcodec=mpeg2video:keyint=1:vbitrate=200000:vrc_maxrate=9000:vrc_buf_size=1835 -mpegopts muxrate=12000 -vf harddup -o %out"/>
<buffer size="14400000" chunk-size="512000" fill-size="120000"/>
</profile>

Nicht den gleichen Mimetyp bei vlc und mencoder eintragen. Mein Auswahlmenü startet jetzt MT, je nach Bedarf, mit drei verschiedenen config Dateien.


[Beitrag von liab am 15. Aug 2010, 02:14 bearbeitet]
HMZ
Neuling
#21 erstellt: 15. Aug 2010, 20:57

Vielleicht kannst Du noch Deinen Stand hier eintragen:

http://forum.ubuntuu...client/#post-2589611


Erledigt. Wusste gar nicht, dass es "bei mir zu Hause" auch 'nen Thread dazu gibt!


Das Transcodieren besorgt bei mir übrigens ffmpeg mit 'nem Wrapper-Script. Läuft schön stabil und flott.

Heiner


[Beitrag von HMZ am 16. Aug 2010, 10:59 bearbeitet]
IndianaX
Stammgast
#22 erstellt: 26. Aug 2010, 22:19
Ich hab die standard mediatomb installation wie in den ersten beiden treats modifiziert, aber mein PS63C7700 sieht den mediatomb nicht einmal mal :-/ Haben die etwas ihr Protokoll geändert?
Die Fritzbox wird erkannt, nur hab ich da nix drauf ^^
PS3 Media Server wird auch erkannt nur kann ich da nix starten, immer unbekanntes dateiformat.
liab
Inventar
#23 erstellt: 26. Aug 2010, 22:35
Hast Du im Web UI die Dateien freigegeben?

Starte Mediatomb mal auf einer Konsole und poste hier das Ergebnis. Muß so aussehen:

mediatomb

MediaTomb UPnP Server version 0.12.1 - http://mediatomb.cc/

===============================================================================
Copyright 2005-2010 Gena Batsyan, Sergey Bostandzhyan, Leonhard Wimmer.
MediaTomb is free software, covered by the GNU General Public License version 2

2010-08-26 22:30:56 INFO: Loading configuration from: /home/xxx/.mediatomb/config.xml
2010-08-26 22:30:56 INFO: Checking configuration...
2010-08-26 22:30:56 INFO: Setting filesystem import charset to UTF-8
2010-08-26 22:30:56 INFO: Setting metadata import charset to UTF-8
2010-08-26 22:30:56 INFO: Setting playlist charset to UTF-8
2010-08-26 22:30:57 INFO: Configuration check succeeded.
2010-08-26 22:30:57 INFO: Initialized port: 49152
2010-08-26 22:30:57 INFO: Server bound to: 192.168.0.2
2010-08-26 22:30:57 INFO: Adding HTTP header "transferMode.dlna.org: Streaming"
2010-08-26 22:30:57 INFO: Adding HTTP header "contentFeatures.dlna.org: DLNA.ORG_OP=01"
2010-08-26 22:30:58 INFO: MediaTomb Web UI can be reached by following this link:
2010-08-26 22:30:58 INFO: http://192.168.0.2:49152/


[Beitrag von liab am 26. Aug 2010, 22:40 bearbeitet]
IndianaX
Stammgast
#24 erstellt: 27. Aug 2010, 08:10
Danke das war der richtige Hinweis.

Ich hab immer mit dem lsof geschaut ob mediatomb läift:
# lsof -i -n | grep media
mediatomb 9761 mediatomb 6u IPv4 7789801 0t0 TCP *:49152 (LISTEN)
mediatomb 9761 mediatomb 7u IPv4 7789802 0t0 UDP 127.0.0.1:44928
mediatomb 9761 mediatomb 8u IPv4 7789803 0t0 UDP *:1900

Sieht ja auch gut aus aber im Logfile dann alles wie bei dir auser:
2010-08-27 07:56:41 INFO: Server bound to: 10.8.0.1

Was nicht mein LAN ist sonden ein VPN. Da kam mir dann die Idee das die Probleme mit der Implementierung von Broadcasts haben ... siehe da das Handbuch:

The server will bind to the given IP address, currently we can not bind to multiple interfaces so binding to 0.0.0.0 will not be possible.

Also dann fix die confic.xml um <intervace>eth0</interface> erweitert und nun sieht der Samsung mediatomb wieder.

Bei MKV's bekomme ich den "ERROR: ActionRequest::update(): response is nil, code -115" Fehler.
Am TV ist kurz der Ladekringel zu sehen und dann wieder die Dateiauswahl.
Quicktime bringt er nicht unterstütztes Dateiformat, denke da muß ich ein Transcoder einrichten.

AVI (DivX) und TS Laufen.


[Beitrag von IndianaX am 27. Aug 2010, 08:37 bearbeitet]
liab
Inventar
#25 erstellt: 27. Aug 2010, 15:36
Zu mkv lese bitte auch hier:
http://www.hifi-foru..._id=151&thread=14532

Die Meldung "ERROR: ActionRequest::update(): response is nil, code -115" hat wohl nichts mit mkv zu tun; die kommt bei mir immer bei Ordneraktionen beim Samsung.
Ich habe die bei der action_request.cc weggemacht:
// log_error("ActionRequest::update(): response is nil, code %d\n", errCode);

Denke daran, beim Transcode Modus DLNA.ORG_OP=0 zu nehmen.
IndianaX
Stammgast
#26 erstellt: 29. Aug 2010, 17:09
Hm, jetzt lief es eine weile und auf einmal sieht der Samsung den Server nicht einmal mehr ... verstehe ich nicht.

Hier mal meine Konfig:
http://knopaste.de/?NDI4MD
liab
Inventar
#27 erstellt: 29. Aug 2010, 18:21
Deine config sieht auf den 1. Blick ok aus.

MediaTomb wird fehlerfrei gestartet?
MediaTomb Web geht?
TV und PC kommen beide gleichzeitig ins Internet?

Wenn es dann nicht geht, kann es nur am LAN liegen. Mal beim ausgeschaltetem PC und evt. TV kurz die 220 V wegnehmen.
IndianaX
Stammgast
#28 erstellt: 29. Aug 2010, 19:29
Es liegt am PowerLan. Das scheint nicht immer die Broadcasts vom Mediatomb weiterzuleite :-(
Hab es eben direkt mit einem LAN-Kabel ausprobiert da ging es wieder.
liab
Inventar
#29 erstellt: 01. Sep 2010, 01:04
Da viele user mkv Dateien verwenden, hier mal diese Info:
Von den 8 Testvideos der Matroska Homepage spielt MediaTomb auf dem Taurus NAS (baugleich IB-NAS4220-B) die Testvideos 2, 3, 5, 7 (aber nur kurz) und 8.

Mediatomb auf dem PC spielt bis auf test4.mkv alle.


[Beitrag von liab am 01. Sep 2010, 01:20 bearbeitet]
akaGiz
Schaut ab und zu mal vorbei
#30 erstellt: 06. Okt 2010, 16:42

liab schrieb:
Da viele user mkv Dateien verwenden, hier mal diese Info:
Von den 8 Testvideos der Matroska Homepage spielt MediaTomb auf dem Taurus NAS (baugleich IB-NAS4220-B) die Testvideos 2, 3, 5, 7 (aber nur kurz) und 8.

Mediatomb auf dem PC spielt bis auf test4.mkv alle.


geht vll am thema vorbei, aber gibt es solch ein programm (mit vergleichbarer funktionalität) auch für ein windowsbasiertes OS?
liab
Inventar
#31 erstellt: 06. Okt 2010, 19:23
a.spengler
Stammgast
#32 erstellt: 12. Okt 2010, 09:35
Mal eine kurze Frage: ich nutze Mediatomb unter Linux und den Samsung UE40C7700 per WLAN.

Der TV findet den Mediatomb Server; beim Abspielen einer MP3 oder AVI Datei dagegen sagt er "Unbekanntes Dateiformat"?
kraemer_sg
Stammgast
#33 erstellt: 12. Okt 2010, 18:24

a.spengler schrieb:

Der TV findet den Mediatomb Server; beim Abspielen einer MP3 oder AVI Datei dagegen sagt er "Unbekanntes Dateiformat"?


Dann musst du die config anpassen. Siehe hier:

Ubuntu Forum

Kompletter Thread

Meine config
liab
Inventar
#34 erstellt: 12. Okt 2010, 19:53
@a.spengler

Dann fehlt in der config.xml
<custom-http-headers>
<add header="transferMode.dlna.org: Streaming"/>
<add header="contentFeatures.dlna.org: DLNA.ORG_OP=01"/>
</custom-http-headers>

Lese hier aufmerksam meine Beiträge, dann findest Du den richtigen Weg!
a.spengler
Stammgast
#35 erstellt: 12. Okt 2010, 21:34
Habt vielen Dank für Eure Tipps - jetzt geht es...
DoC_JoNeS
Schaut ab und zu mal vorbei
#36 erstellt: 18. Okt 2010, 14:11
Hallo an Alle,

habe die Config entsprechend der Vorgaben von liab eingstellt. Bei mir läuft Mediatomb auf einer RaidSonic 4220 NAS.

Streamen (ohne Transcoding) klappt über WLAN ziemlich gut (ausser HD-Material, dafür ist vermutlich der Durchsatz über die Entfernung zu gering).

Mein Problem ist nun das hier angesprochene Spulen bzw. springen innerhalb der Wiedergabe. Trotz der Einstellung "01".

Ich habe einen Samsung LE40C579. Wenn ich auf der Fernbedienung die Tasten "<" oder ">" drücke bleibt das Bild (und Ton) eine Weile (ca. 5 Sekunden) stehen und dann bin ich im Film genau 30 Sekunden später (bei einer AVI-Datei).

Ist das die einzige Möglichkeit zu spulen ??!??!? Oder liegt das an der miesen Performance der NAS oder des Netzes?

MfG

DoC
liab
Inventar
#37 erstellt: 18. Okt 2010, 14:50

DoC_JoNeS schrieb:
Ist das die einzige Möglichkeit zu spulen ??!??!? Oder liegt das an der miesen Performance der NAS oder des Netzes?

Leider ja, liegt auch an der Performance Deines Systems. Ist auf einem PC und mit LAN deutlich besser. Hängt aber auch vom Dateiformat ab. Ein 100 % perfektes Spulen ist über DLNA leider nicht möglich.

Hier mal der Link zu den Leuten, die mich auf die Idee brachten, MediaTomb auf eine NAS zu installieren, denen ich an dieser Stelle danke!
http://forum.nas-por...mb-quot-installieren
Chef_2
Neuling
#38 erstellt: 08. Nov 2010, 22:08
Hallo,

ich bin neu hier im Forum und habe schon ein unüberwindbares Problem mit meinem Samsung UE32C6800US

Es geht um DLNA

liab hat hier einen schönen Beitrag geschrieben, den mir zwar gefällt... bei mir jedoch ned Funktioniert (Da OpenSUSE 11.3)

Mediatomb habe ich bereits installiert...

Jedoch gibts bei mir diese Datei: mediatomb.sh nicht...

Ich denke auch, das ich das nicht 1 zu 1 übernehmen kann.

Wäre einer so lieb und würd mich das Problem lösen ?
Chef_2
Neuling
#39 erstellt: 08. Nov 2010, 23:03
So, bin nun mal so weit, das manche Videos geht...

Ich habe jedoch meine Orginale DVD´s in 1zu1 auf meine Festplatte kopiert...

Diese Dateien werden nicht mal im Fernsehgerät angezeigt...

Es handelt sich hier um

*.VOB

*.BUP

*.IFO
liab
Inventar
#40 erstellt: 09. Nov 2010, 05:07
Die Datei mediatomb.sh gibt es nur bei dem armv4-Paket für NAS. Auf OpenSuse dürfte mediatomb aber auch problemlos laufen.

DVD habe ich nicht getestet, da die ins Laufwerk kommen.
Vob-Dateien müßten aber gehen. Wenn nicht, dann fehlt in der config.xml der Dateityp.
windows76
Neuling
#41 erstellt: 25. Nov 2010, 17:31
Hallo liab,

ich bin gerade auf diesen Thread gestossen, nachdem ich dabei bin, mich mit Samsung bzw. Buffalo anzulegen. Ich bin auf dem ganzen Gebiet leider etwas unerfahren und hoffe, dass Du mir vielleicht eine Antwort geben kannst.

Ich habe einen Samsung UE55B7090 und eine Buffalo LinkStation Pro Duo. Angeschafft habe ich mir beides in der Hoffung Videos auf dem TV zu schauen, die auf der HDD liegen.

Grundsätzlich funktioniert das auch alles, eben bis auf Pause und Vor- bzw. Rücklauf.

Wie schon gesagt fehlt mir jetzt das Wissen für Mediatomb oder Linux und ich frage mich, wer hat hier Schuld, dass das nicht zusammen funktioniert wie es sollte.

Oder kann ich in meiner Festplatte irgendetwas einstellen, dass es funktioniert.

Für eine Antwort wäre ich Dir dankbar.

Grüße aus der schönen Pfalz ... Carsten
liab
Inventar
#42 erstellt: 26. Nov 2010, 00:18
windows76 fragt:
"und ich frage mich, wer hat hier Schuld"

Ist wie die Frage, wer war eher da, das Ei oder das Huhn. NAS, die DLNA von Natur aus zufriedenstellend können, habe ich meine Zweifel, daß es sie gibt - vielleicht von QNAP?

DLNA, DMR und HDMI wurde nicht von praxisnahen Ingenieuren gemacht, sondern von Vertretern der Medienbranche. Oberstes Ziel ist dort der Kopierschutz und Nutzungseinschränkungen durch den Urheber.

Will man einen halbwegs vernünfigen DLNA-Server oder NAS, kommt man an einem Mini- oder Pico PC mit Linux nicht vorbei.

DLNA wird aber nie so gut sein wie Samba oder das unschlagbare NFS. Nur sind leider z.Z. alle Hersteller, da sie der Medienbranche angehören, nicht gewillt uns zu geben, was wir gerne hätten. Schaut euch doch nur dieses lächerliche PVR an. Ich habe es - doch es ist klasse, wenn ich mal dringend...

Zum Glück kann so ein Mini PC mit mehreren TV Karten bis zu Abwinken aufnehmen.
windows76
Neuling
#43 erstellt: 26. Nov 2010, 11:35
Hallo liab,

danke für die Antwort, also kann ich das eigentlich vergessen, was ich vorhabe, solange ich mich nicht besser mit Linux auskenne.

Oder weisst du eine NAS von QNAP die das kann?
liab
Inventar
#44 erstellt: 20. Feb 2011, 00:33
Hier noch Nachträge für die config.xml des DLNA-Servers MediaTomb.

1. Deutsche Umlaute, damit es auch schön aussieht
<import hidden-files="no">
<filesystem-charset>UTF-8</filesystem-charset>
<metadata-charset>UTF-8</metadata-charset>
<scripting script-charset="UTF-8">

2. vob-, iso- und image Dateien
<map from="vob" to="video/mpeg"/>
<map from="iso" to="video/mpeg"/>
<map from="jpg" to="image/jpeg"/>, nur für die PC-Version erforderlich

Als Startscript auf dem NAS empfehle ich sowas, ein beliebiger Parameter killed mediatomb wieder.

#!/bin/sh
# if you want to launch this script from a different directory (for example
# from an another init script or similar, set the LAUNCHDIR variable below
# to the absolute path of the mediatomb.sh script
killall -9 mediatomb
if [ $1 != "" ] ; then
exit
fi
cd /mnt/md1/mediatomb
LAUNCHDIR=`pwd`
export MEDIATOMB_DATADIR="$LAUNCHDIR/usr/share/mediatomb"
export MEDIATOMB_MAGIC_FILE="usr/share/file/magic"
$LAUNCHDIR/usr/bin/mediatomb -m $LAUNCHDIR -f config &

Getestet auf IB-NAS4220 und baugleicher Taurus-LAN. Mit einem Script zur autom. telnet/ssh Anmeldung, läßt sich MediaTomb auf dem NAS vom PC aus bequem an- und ausschalten.
liab
Inventar
#45 erstellt: 27. Feb 2011, 06:33
Hier noch, wie verschiedene Sprachen über DLNA abgespielt werden können.
http://www.hifi-foru...ead=17182&postID=4#4
liab
Inventar
#46 erstellt: 03. Mrz 2011, 07:43
Das MediaTomb Forum liefert brauchbare Ideen mit MediaTomb zu spielen.

Man kann das Transkodieren von der config.xml in ein Sh Skript verlagern. Dann kann man über DLNA alles zum Samsung streamen, was sich Mediendatei nennt.

Zusammen mit dem tollen Programm VLC ist folgendes möglich:

- PC TV-Karte zum Samsung streamen
- T-Home vom PC zum Samsung streamen
- PC Desktop-Oberfläche zum Samsung streamen

Hier mal ein Beispiel, um ein TV-Programm von einer PC TV-Karte zum Samsung zu streamen. Wird am Samsung die Datei 1.tv gewählt, startet das Script. Es isoliert die 1 und startet vlc als dummy mit duplicate und mit Das Erste, das dann über DLNA rausgeschickt wird. Wählt man die Datei 2.tv, startet ZDF usw.

1. Im Filmverzeichnis Leerdateien mit den Namen 1.tv, 2.tv usw. anlegen.
2. In der config. xml den neuen mimetype <map from="tv" to="video/tv"/>
3. Bei transcoding <transcode mimetype="video/tv" using="tv-sh"/>
4. Transcodierprofil anlegen mit dem Befehl <agent command="/home/transcode.sh" arguments="%in %out"/>
5. Script transcode. sh erstellen

Hier mal mein Script zum Spielen.

#!/bin/bash
killall -9 vlc
vlctv()
{
BANDWIDTH="8"
MODULATION="16"
MUXER="ts"
exec /usr/bin/vlc -I dummy --ts-es-id-pid \
--program=${PROGRAM} dvb://adapter=${ADAP...IDTH}:srate=${SRATE} \
--sout "#duplicate{dst=std{access=file,mux=${MUXER},dst=${OUTPUT}}"
return
}

#Parameter aus der config.xml
INPUT="$1"
OUTPUT="$2"
#Programmnummer aus dem Pfad /INPUT) lesen
prg=$(echo $INPUT | cut -d "." -f1)
prgr=$(echo $prg | python -c "print raw_input()[::-1]")
pnr=$(echo $prgr | cut -c1)

#DVB-T NRW
ADAPTER="0"
if [ "$pnr" = 1 ] ; then
#ARD
PROGRAM="256"
FREQUENCY="706000000"
SRATE="4369"
else
if [ "$pnr" = 2 ] ; then
#zdf
PROGRAM="514"
FREQUENCY="514000000"
SRATE="545"
else
if [ "$pnr" = 3 ] ; then
#WDR
PROGRAM="262"
FREQUENCY="698000000"
SRATE="545"
else
if [ "$pnr" = 4 ] ; then
#3sat
PROGRAM="515"
FREQUENCY="514000000"
SRATE="561"
fi; fi; fi; fi
vlctv &
sleep 5

#Beispiel, wie der ausgelagerte mencoder gestartet wird
#mencoder ${INPUT} -oac lavc -ovc lavc -of mpeg -lavcopts vcodec=mpeg2video:keyint=1:vbitrate=200000:vrc_maxrate=9000:vrc_buf_size=1835 -mpegopts muxrate=12000 -vf harddup -o ${OUTPUT}
exit
liab
Inventar
#47 erstellt: 10. Mrz 2011, 06:14
Hier noch wie T-Home von einem PC oder der Desktop eines PC's über DLNA zum Samsung TV gesendet wird. Erst das leichte, T-Home.

Wie schon im vorigen Beitrag beschrieben Blinddateien anlegen, die im Script den nachfolgenden Befehl auslösen:

exec /usr/bin/vlc -I dummy --ts-es-id-pid rtp://@239.35.129.11:10000 --sout "#duplicate{dst=std{access=file,mux=${MUXER},dst=${OUTPUT}}"

Damit geht "Das Erste" in Richtung Samsung. Und jetzt die tricky Aktion, den PC-Desktop streamen.
Die Theorie ist recht einfach, screencast und ab mit der Videodatei in den DLNA Dschungel. Das funktioniert mit Superqualität,
nur leider wird die Datei immer nur bist zur Zeit des Startzeitpunktes abgespielt, in Wahrheit verlängert sich die Datei ja ständig.
Das merkt der Mediaplayer aber nicht und hört auf.

Da hilft nur der Transcodiermodus von MediaTomb, weil dabei die Datei "on the fly" mittels einer Nulldatei gestreamt wird.
Diese Nulldatei liegt in /tmp und hat Zufallsnamen dieser Art "mt_transcode_INWCSV". Mit vlc geht das super einfach.
Nur leider nimmt vlc bei screencasting den Ton nicht mit. Mit ffmpeg ginge es auch leicht, sogar mit Audio, nur leider akzeptiert
ffmpeg nur Dateien mit Endungen wie ts, mpg usw., Namen wie "mt_transcode_INWCSV" mag ffmpeg garnicht.
Nachtrag: Hatte die Source von MT entsprechend geändert, geht trotzdem nicht! Ffmpeg macht keinen screencast
in eine Nulldatei, das macht nur vlc mit dublicate.

Da hilft jetzt nur ein Mix aus ffmpeg (fürs screencasting) und vlc zum Streamen. Man startet also screencast mit:

ffmpeg -f alsa -ac 2 -i pulse -f x11grab -r 25 -s 1920x1080 -i :0.0 -acodec mp2 -vcodec mpeg2video -sameq -y /home/.../screen.ts

und legt in der config.xml so ein Transcoder Profil an:

<profile name="vlcscr" enabled="yes" type="external">
<mimetype>video/mpeg</mimetype>
<accept-url>yes</accept-url>
<first-resource>yes</first-resource>
<accept-ogg-theora>yes</accept-ogg-theora>
<agent command="vlc" arguments="-I dummy %in --sout #duplicate{dst=std{access=file,mux=ps,dst=%out}}"/>
<buffer size="14400000" chunk-size="512000" fill-size="120000"/>
</profile>

und spielt damit die Datei screen.ts ab. Diese wird ständig größer, da screencast ja noch läuft. Mit dem Abspielen muß man ca,
30 bis 40 Sekunden nach Aufnahmestart beginnen, da sonst der Stream vorzeitig abbricht. D.h. PC-Monitor und Samsung sind um über
30 Sekunden versetzt. Die Bildqualität ist wie über HDMI. Bei Videos sind leichte Ruckler zu bemerken, etwa wie früher bei Filmen,
die auf eine CD gepackt wurden.

Ich habe mich für die Scriptlösung entschieden, da damit über die FB automatisch ffmpeg (screencast) und vlc (streamen) gestartet
werden. Im Script sehen die Befehle dann so aus:

exec konsole -e ffmpeg -f alsa -ac 2 -i pulse -f x11grab -r 25 -s 1920x1080 -i :0.0 -acodec mp2 -vcodec mpeg2video -sameq -y ${INPUT1}.ts &

Jetzt eine 30 Sekunden Zeitverzögerung, alle 10 Sekunden benötigt MediaTomb exit 1, damit er nicht abbricht.
Mein Script ist zu lang für diese Stelle.

exec vlc -I dummy ${INPUT1}.ts --sout "#duplicate{dst=std{access=file,mux=ps,dst=${OUTPUT}}}"

INPUT1 ist die screencast Datei und OUTPUT die temporäre Datei von MediaTomb. Zu bemerken ist noch, daß die Tonspur
den Ton der Audioeingänge der Soundkarte aufzeichnet. Will man den Ton der TV-Karte haben, muß Audio out der Soundkarte
mit einem Audio in verbunden werden und der entsprechende Regler aktiviert werden.

Zu bemerken ist noch, daß es eigentlich Spielerei ist. Praktisch ist, daß damit über den Samsung alle PC's im Hause eigesehen werden können.
Der Monitor darf aus sein, der Bildschirmschoner muß aus sein.


[Beitrag von liab am 12. Mrz 2011, 06:25 bearbeitet]
letzter3
Neuling
#48 erstellt: 10. Mrz 2011, 19:11
Die oben genannten Änderungen zeigen bei mir leider keine Wirkung. Mir geht es vorerst nur um das streaming von avi's oder mpg's.

Mein System ist ein MandrivaLinux 10.2 64bit, MT in der Version 12.

Die config.xml:

<?xml version="1.0" encoding="UTF-8"?>
<config version="1" xmlns="http://mediatomb.cc/config/1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/1 http://mediatomb.cc/config/1.xsd\">
<server>
<ui enabled="yes" show-tooltips="yes">
<accounts enabled="no" session-timeout="30">
<account user="mediatomb" password="mediatomb"/>
</accounts>
</ui>
<name>MediaTomb</name>
<udn>uuid:228d88b9-1fb0-45c4-b225-be990e211e6c</udn>
<home>/etc/mediatomb</home>
<webroot>/usr/share/mediatomb/web</webroot>
<storage>
<sqlite3 enabled="yes">
<database-file>mediatomb.db</database-file>
</sqlite3>
</storage>
<protocolInfo extend="yes"/><!-- For PS3 support change to "yes" -->
<!--
Uncomment the lines below to get rid of jerky avi playback on the
DSM320 or to enable subtitles support on the DSM units
-->
<!--
<custom-http-headers>
<add header="X-User-Agent: redsonic"/>
<add header="transferMode.dlna.org: Streaming"/>
<add header="contentFeatures.dlna.org: DLNA.ORG_OP=01"/>
</custom-http-headers>

<manufacturerURL>redsonic.com</manufacturerURL>
<modelNumber>105</modelNumber>
-->
<!-- Uncomment the line below if you have a Telegent TG100 -->
<!--
<upnp-string-limit>101</upnp-string-limit>
-->
</server>
<import hidden-files="no">
<scripting script-charset="UTF-8">
<common-script>/usr/share/mediatomb/js/common.js</common-script>
<playlist-script>/usr/share/mediatomb/js/playlists.js</playlist-script>
<virtual-layout type="builtin">
<import-script>/usr/share/mediatomb/js/import.js</import-script>
</virtual-layout>
</scripting>
<mappings>
<extension-mimetype ignore-unknown="no">
<map from="mp2t" to="video/mpeg"/>
<map from="ts" to="video/mpeg"/>
<map from="mpg" to="video/mpeg"/>
<map from="avi" to="video/mpeg"/>
<map from="mkv" to="video/mpeg"/>
<map from="mp3" to="audio/mpeg"/>
<map from="ogg" to="application/ogg"/>
<map from="asf" to="video/x-ms-asf"/>
<map from="asx" to="video/x-ms-asf"/>
<map from="wma" to="audio/x-ms-wma"/>
<map from="wax" to="audio/x-ms-wax"/>
<map from="wmv" to="video/x-ms-wmv"/>
<map from="wvx" to="video/x-ms-wvx"/>
<map from="wm" to="video/x-ms-wm"/>
<map from="wmx" to="video/x-ms-wmx"/>
<map from="m3u" to="audio/x-mpegurl"/>
<map from="pls" to="audio/x-scpls"/>
<map from="flv" to="video/x-flv"/>
<!-- Uncomment the line below for PS3 divx support -->
<!-- <map from="avi" to="video/divx"/> -->
<!-- Uncomment the line below for D-Link DSM / ZyXEL DMA-1000 -->
<!-- <map from="avi" to="video/avi"/> -->
</extension-mimetype>
<mimetype-upnpclass>
<map from="audio/*" to="object.item.audioItem.musicTrack"/>
<map from="video/*" to="object.item.videoItem"/>
<map from="image/*" to="object.item.imageItem"/>
</mimetype-upnpclass>
<mimetype-contenttype>
<treat mimetype="audio/mpeg" as="mp3"/>
<treat mimetype="application/ogg" as="ogg"/>
<treat mimetype="audio/x-flac" as="flac"/>
<treat mimetype="image/jpeg" as="jpg"/>
<treat mimetype="audio/x-mpegurl" as="playlist"/>
<treat mimetype="audio/x-scpls" as="playlist"/>
<treat mimetype="audio/x-wav" as="pcm"/>
<treat mimetype="audio/L16" as="pcm"/>
<treat mimetype="video/x-msvideo" as="avi"/>
<treat mimetype="video/mp4" as="mp4"/>
<treat mimetype="audio/mp4" as="mp4"/>
</mimetype-contenttype>
</mappings>
<online-content>
<!-- Make sure to setup a transcoding profile for flv -->
<YouTube enabled="no" refresh="28800" update-at-start="no" purge-after="604800" racy-content="exclude">
<favorites user="mediatomb"/>
<standardfeed feed="most_viewed" time-range="today"/>
<playlists user="mediatomb"/>
<uploads user="mediatomb"/>
<standardfeed feed="recently_featured" time-range="today"/>
</YouTube>
</online-content>
</import>
<transcoding enabled="no">
<mimetype-profile-mappings>
<transcode mimetype="video/x-flv" using="vlcmpeg"/>
<transcode mimetype="application/ogg" using="vlcmpeg"/>
<transcode mimetype="application/ogg" using="oggflac2raw"/>
<transcode mimetype="audio/x-flac" using="oggflac2raw"/>
</mimetype-profile-mappings>
<profiles>
<profile name="oggflac2raw" enabled="no" type="external">
<mimetype>audio/L16</mimetype>
<accept-url>no</accept-url>
<first-resource>yes</first-resource>
<accept-ogg-theora>no</accept-ogg-theora>
<agent command="ogg123" arguments="-d raw -f %out %in"/>
<buffer size="1048576" chunk-size="131072" fill-size="262144"/>
</profile>
<profile name="vlcmpeg" enabled="no" type="external">
<mimetype>video/mpeg</mimetype>
<accept-url>yes</accept-url>
<first-resource>yes</first-resource>
<accept-ogg-theora>yes</accept-ogg-theora>
<agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
<buffer size="14400000" chunk-size="512000" fill-size="120000"/>
</profile>
</profiles>
</transcoding>
</config>


Der Samsung UE46C6700 zeigt den MT an und listet die freigegebenen Daten auf (Videos, mp3 und jpg), es kommt jedoch die allseits bekannte Meldung "nicht unterstütztes Format".

Das log sagt:


2011-03-10 16:42:03 INFO: Loading configuration from: /etc/mediatomb/config.xml
2011-03-10 16:42:03 INFO: Checking configuration...
2011-03-10 16:42:03 INFO: Setting filesystem import charset to UTF-8
2011-03-10 16:42:03 INFO: Setting metadata import charset to UTF-8
2011-03-10 16:42:03 INFO: Setting playlist charset to UTF-8
2011-03-10 16:42:03 INFO: Configuration check succeeded.
2011-03-10 16:42:03 INFO: Initialized port: 50500
2011-03-10 16:42:03 INFO: Server bound to: 192.168.0.12
2011-03-10 16:42:04 INFO: MediaTomb Web UI can be reached by following this link:
2011-03-10 16:42:04 INFO: [url]http://192.168.0.12:50500/
[/url]

Und jetzt der Zugriff vom TV auf die DLNA-Freigaben:


2011-03-10 16:43:16 ERROR: ActionRequest::update(): response is nil, code -115
2011-03-10 16:43:16 ERROR: ActionRequest::update(): response is nil, code -115
2011-03-10 16:43:21 ERROR: ActionRequest::update(): response is nil, code -115
2011-03-10 16:43:21 ERROR: ActionRequest::update(): response is nil, code -115
2011-03-10 16:43:28 ERROR: ActionRequest::update(): response is nil, code -115


Hab ich irgendwas vergessen?

Michael


[Beitrag von letzter3 am 10. Mrz 2011, 19:33 bearbeitet]
liab
Inventar
#49 erstellt: 10. Mrz 2011, 20:45
In der zweiten Zeile mal

<config version="2"......

In der Datenbank mal mit Edit den Mimetyp überprüfen, bei avi video/mpeg.

Hier meine Standardversion einer config.xml, xxx bitte anpassen:

<?xml version="1.0" encoding="UTF-8"?>
<config version="2" xmlns="http://mediatomb.cc/config/2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/2 http://mediatomb.cc/config/2.xsd\"><!--
Read /usr/share/doc/mediatomb-common/README.gz section 6 for more
information on creating and using config.xml configration files.
-->
<server>
<ui enabled="yes" show-tooltips="yes">
<accounts enabled="no" session-timeout="30">
<account user="mediatomb" password="mediatomb"/>
</accounts>
</ui>
<name>MediaTomb-xxx</name>
<udn>uuid:60bfd98c-fc79-4cd1-ba50-e596d17b87f7</udn>
<home>/home/xxx/.mediatomb</home>
<webroot>/usr/local/share/mediatomb/web</webroot>
<storage caching="yes">
<sqlite3 enabled="yes">
<database-file>mediatomb.db</database-file>
</sqlite3>
<mysql enabled="no">
<host>localhost</host>
<username>mediatomb</username>
<database>mediatomb</database>
</mysql>
</storage>
<protocolInfo extend="yes"/><!-- For PS3 support change to "yes" --><!--
Uncomment the lines below to get rid of jerky avi playback on the
DSM320 or to enable subtitles support on the DSM units
--><!--
<custom-http-headers>
<add header="X-User-Agent: redsonic"/>
</custom-http-headers>

<manufacturerURL>redsonic.com</manufacturerURL>
<modelNumber>105</modelNumber>
--><!-- Uncomment the line below if you have a Telegent TG100 --><!--
<upnp-string-limit>101</upnp-string-limit>
-->
<custom-http-headers>
<add header="transferMode.dlna.org: Streaming"/>
<add header="contentFeatures.dlna.org: DLNA.ORG_OP=01"/>
</custom-http-headers>
<extended-runtime-options>
<ffmpegthumbnailer enabled="no">
<thumbnail-size>128</thumbnail-size>
<seek-percentage>5</seek-percentage>
<filmstrip-overlay>yes</filmstrip-overlay>
<workaround-bugs>no</workaround-bugs>
</ffmpegthumbnailer>
<mark-played-items enabled="no" suppress-cds-updates="yes">
<string mode="prepend">*</string>
</mark-played-items>
</extended-runtime-options>
</server>
<import hidden-files="no">
<filesystem-charset>UTF-8</filesystem-charset>
<metadata-charset>UTF-8</metadata-charset>
<scripting script-charset="UTF-8">
<virtual-layout type="builtin"/>
</scripting>
<mappings>
<extension-mimetype ignore-unknown="no">
<map from="mp3" to="audio/mpeg"/>
<map from="ogg" to="application/ogg"/>
<map from="asf" to="video/x-ms-asf"/>
<map from="asx" to="video/x-ms-asf"/>
<map from="wma" to="audio/x-ms-wma"/>
<map from="wax" to="audio/x-ms-wax"/>
<map from="wmv" to="video/x-ms-wmv"/>
<map from="wvx" to="video/x-ms-wvx"/>
<map from="wm" to="video/x-ms-wm"/>
<map from="wmx" to="video/x-ms-wmx"/>
<map from="m3u" to="audio/x-mpegurl"/>
<map from="pls" to="audio/x-scpls"/>
<map from="flv" to="video/x-flv"/>
<map from="mkv" to="video/x-matroska"/>
<map from="mka" to="audio/x-matroska"/>
<map from="mp2t" to="video/mpeg"/>
<map from="ts" to="video/mpeg"/>
<map from="tse" to="video/tse"/>
<map from="tsf" to="video/tsf"/>
<map from="mpg" to="video/mpeg"/>
<map from="avi" to="video/mpeg"/>
<map from="mkv" to="video/mpeg"/>
<map from="mp4" to="video/mpeg"/>
<map from="m2t" to="video/mpeg"/>
<map from="vob" to="video/mpeg"/>
<map from="iso" to="video/mpeg"/>
<map from="jpg" to="image/jpeg"/>
<!-- Uncomment the line below for PS3 divx support -->
<!-- <map from="avi" to="video/divx"/> -->
<!-- Uncomment the line below for D-Link DSM / ZyXEL DMA-1000 -->
<!-- <map from="avi" to="video/avi"/> -->
</extension-mimetype>
<mimetype-upnpclass>
<map from="audio/*" to="object.item.audioItem.musicTrack"/>
<map from="video/*" to="object.item.videoItem"/>
<map from="image/*" to="object.item.imageItem"/>
<map from="application/ogg" to="object.item.audioItem.musicTrack"/>
</mimetype-upnpclass>
<mimetype-contenttype>
<treat mimetype="audio/mpeg" as="mp3"/>
<treat mimetype="application/ogg" as="ogg"/>
<treat mimetype="audio/x-flac" as="flac"/>
<treat mimetype="image/jpeg" as="jpg"/>
<treat mimetype="audio/x-mpegurl" as="playlist"/>
<treat mimetype="audio/x-scpls" as="playlist"/>
<treat mimetype="audio/x-wav" as="pcm"/>
<treat mimetype="audio/L16" as="pcm"/>
<treat mimetype="video/x-msvideo" as="avi"/>
<treat mimetype="video/mp4" as="mp4"/>
<treat mimetype="audio/mp4" as="mp4"/>
<treat mimetype="application/x-iso9660" as="dvd"/>
<treat mimetype="application/x-iso9660-image" as="dvd"/>
<treat mimetype="video/x-matroska" as="mkv"/>
<treat mimetype="audio/x-matroska" as="mka"/>
</mimetype-contenttype>
</mappings>
<online-content><!-- Make sure to setup a transcoding profile for flv -->
<YouTube enabled="no" refresh="28800" update-at-start="no" purge-after="604800" racy-content="exclude" format="flv" hd="no">
<favorites user="mediatomb"/>
<standardfeed feed="most_viewed" time-range="today"/>
<playlists user="mediatomb"/>
<uploads user="mediatomb"/>
<standardfeed feed="recently_featured" time-range="today"/>
</YouTube>
<Weborama enabled="no" refresh="28800" update-at-start="no">
<playlist name="Active" type="playlist" mood="active"/>
<playlist name="Metal" type="playlist">
<filter>
<genres>metal</genres>
</filter>
</playlist>
</Weborama>
<AppleTrailers enabled="no" refresh="43200" update-at-start="no" resolution="640"/>
</online-content>
</import>
<transcoding enabled="no">
<mimetype-profile-mappings>
<transcode mimetype="video/flv" using="vlcflv"/>
<transcode mimetype="video/flv" using="mencoderflv"/>
<transcode mimetype="video/tse" using="vlctse"/>
<transcode mimetype="video/tsf" using="vlctsf"/>
<transcode mimetype="video/tse" using="mencodertse"/>
<transcode mimetype="video/tsf" using="mencodertsf"/>
<transcode mimetype="application/ogg" using="vlcflv"/>
<transcode mimetype="application/ogg" using="mencoderflv"/>
<transcode mimetype="application/ogg" using="oggflac2raw"/>
<transcode mimetype="audio/x-flac" using="oggflac2raw"/>
</mimetype-profile-mappings>
<profiles>
<profile name="oggflac2raw" enabled="no" type="external">
<mimetype>audio/L16</mimetype>
<accept-url>no</accept-url>
<first-resource>yes</first-resource>
<accept-ogg-theora>no</accept-ogg-theora>
<agent command="ogg123" arguments="-d raw -o byteorder:big -f %out %in"/>
<buffer size="1048576" chunk-size="131072" fill-size="262144"/>
</profile>
<profile name="vlcflv" enabled="no" type="external">
<mimetype>video/mpeg</mimetype>
<accept-url>yes</accept-url>
<first-resource>yes</first-resource>
<accept-ogg-theora>yes</accept-ogg-theora>
<agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
<buffer size="14400000" chunk-size="512000" fill-size="120000"/>
</profile>
<profile name="vlctse" enabled="no" type="external">
<mimetype>video/mpeg</mimetype>
<accept-url>yes</accept-url>
<first-resource>yes</first-resource>
<accept-ogg-theora>yes</accept-ogg-theora>
<agent command="vlc" arguments="--audio-language English -I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
<buffer size="14400000" chunk-size="512000" fill-size="120000"/>
</profile>
<profile name="vlctsf" enabled="no" type="external">
<mimetype>video/mpeg</mimetype>
<accept-url>yes</accept-url>
<first-resource>yes</first-resource>
<accept-ogg-theora>yes</accept-ogg-theora>
<agent command="vlc" arguments="--audio-language Français -I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
<buffer size="14400000" chunk-size="512000" fill-size="120000"/>
</profile>
<profile name="mencoderflv" enabled="no" type="external">
<mimetype>video/mpeg</mimetype>
<accept-url>yes</accept-url>
<first-resource>yes</first-resource>
<accept-ogg-theora>yes</accept-ogg-theora>
<agent command="mencoder" arguments="%in -oac lavc -ovc lavc -of mpeg -lavcopts vcodec=mpeg2video:keyint=1:vbitrate=200000:vrc_maxrate=9000:vrc_buf_size=1835 -mpegopts muxrate=12000 -vf harddup -o %out"/>
<buffer size="14400000" chunk-size="512000" fill-size="120000"/>
</profile>
<profile name="mencodertse" enabled="no" type="external">
<mimetype>video/mpeg</mimetype>
<accept-url>yes</accept-url>
<first-resource>yes</first-resource>
<accept-ogg-theora>yes</accept-ogg-theora>
<agent command="mencoder" arguments="-alang eng %in -oac lavc -ovc lavc -of mpeg -lavcopts vcodec=mpeg2video:keyint=1:vbitrate=200000:vrc_maxrate=9000:vrc_buf_size=1835 -mpegopts muxrate=12000 -vf harddup -o %out"/>
<buffer size="14400000" chunk-size="512000" fill-size="120000"/>
</profile>
<profile name="mencodertsf" enabled="no" type="external">
<mimetype>video/mpeg</mimetype>
<accept-url>yes</accept-url>
<first-resource>yes</first-resource>
<accept-ogg-theora>yes</accept-ogg-theora>
<agent command="mencoder" arguments="-alang fre %in -oac lavc -ovc lavc -of mpeg -lavcopts vcodec=mpeg2video:keyint=1:vbitrate=200000:vrc_maxrate=9000:vrc_buf_size=1835 -mpegopts muxrate=12000 -vf harddup -o %out"/>
<buffer size="14400000" chunk-size="512000" fill-size="120000"/>
</profile>
</profiles>
</transcoding>
</config>

Viel Erfolg!
letzter3
Neuling
#50 erstellt: 10. Mrz 2011, 21:16

liab schrieb:
In der zweiten Zeile mal

<config version="2"......


Ich habe in Zeile 2 alle "1" durch"2" ersetzt bzw. einmal nur die erste "1"
Dann kommt nur:

[root@revo mediatomb]# service mediatomb stop
Beende Mediatomb: [ OK ]
[root@revo mediatomb]# leafpad config.xml
[root@revo mediatomb]# service mediatomb start
Wende Multicast-Einstellungen auf eth0 an...Starte Mediatomb: [FEHLER]
[root@revo mediatomb]#


Heißt, dass jetzt irgendwas an der config faul ist.
Änder ich die 2 wieder auf 1, startet mediatomb wieder.

Das log sagt:
2011-03-10 19:08:51 INFO: MediaTomb shutting down. Please wait...
2011-03-10 19:08:51 INFO: Server terminating
2011-03-10 19:09:25 INFO: Loading configuration from: /etc/mediatomb/config.xml
2011-03-10 19:09:25 INFO: Checking configuration...
2011-03-10 19:09:25 ERROR: Config version "2" does not yet exist!


Michael
letzter3
Neuling
#51 erstellt: 10. Mrz 2011, 21:20

liab schrieb:
...

In der Datenbank mal mit Edit den Mimetyp überprüfen, bei avi video/mpeg.


container
title:video
class:object.container
Suche:
Gehe zu Seite: Erste Letzte |nächste|
Das könnte Dich auch interessieren:
Unerklärliches Phänomen (Samsung TV, DLNA)
Samsung H6470 DLNA + NAS
Samsung DLNA ohne PC?
Samsung UE55D6500 und Mediatomb möglich?
Samsung UE40F6500 und DLNA
Samsung UE40D6510 mit Serviio
Filmdatei von NAS mit Samsung UE40D8090 ansehen
Samsung D Serie, (Aldi) Medion NAS-Server und MKV streamen?
.mkv Dateien abspielen, via Serviio
Serviio 0.6.2 und Samsung UE55ES8090

Anzeige

Aktuelle Aktion

Hersteller in diesem Thread Widget schließen

  • Samsung
  • Thomson
  • Play on
  • IBASSO
  • Zyxel
  • Yamaha
  • Lenco
  • Energy Sistem

Forumsstatistik Widget schließen

  • Registrierte Mitglieder794.703 ( Heute: 22 )
  • Neuestes Mitgliedmarcel11aabb
  • Gesamtzahl an Themen1.321.448
  • Gesamtzahl an Beiträgen17.257.490