Airplay verzögert

+A -A
Autor
Beitrag
das.produkt
Schaut ab und zu mal vorbei
#1 erstellt: 13. Nov 2012, 14:41
Ich betreibe via Airplay eine Multiroom Lösung. Mein ITunes sendet an diverse Airplay Empfänger (Airport Express) mit angeschlossenen Aktiv Boxen. Im Wohnzimmer allerdings hatte ich die Airport Express direkt am AVR angeschlossen. Die Musik wurde in allem Räumen ohne erkennbare Verzögerung gespielt.

Jetzt habe ich den Yamaha RX-473 gekauft, u.a. auch wegen Airplay und der Fähigkeit, daß er sich bei Bedarf automatisch einschaltet. Daher wurde die Airport Express Station im Wohnzimmer abgelöst und der Yamaha dient als direkter Empfänger. Das funktioniert soweit gut.

Allerdings habe ich jetzt eine Verzögerung in der Wiedergabe, dadurch habe ich an manchen Positionen in der Wohnung einen unschönen Nachhalleffekt.

Kann das jemand bestätigen, der wie auch ich mehrere Airport Empfänger verwendet? Gibt es evtl. eine Lösung hierfür?

Gruß
das.produkt
christof-kr
Ist häufiger hier
#2 erstellt: 14. Nov 2012, 09:27
Bin jetzt kein Experte was jetzt speziell AirPlay angeht, aber Folgendes muss man beachten: Bei AirPlay werden die Daten häppchenweise (in UDP-Paketen) übers Netz geschickt, da können schon mal die ersten Verzögerungen auftreten, je nach Netzlast. Ein WLAN macht's nicht besser. Zweiter wichtiger Punkt ist: Die Datenhäppchen müssen beim Empfänger gesammelt und zusammengeführt werden. Ich meine, dass AirPlay die Daten auch noch verschlüsselt, also muss der Empfänger sie auch noch entschlüsseln. Gewöhnlich haben die Empfänger einen Datenpuffer bestimmter Größe, damit "verspätete" Pakete nicht gleich zu einer Unterbrechung führen.

Bei einem nicht überlastetem Netzwerk wird selbiges keine hörbaren Latenzunterschiede hervorrufen. Und haben alle Empfänger identische Hardware, dann kann man davon ausgehen, dass die Empfangspuffer gleich groß sind und dass z.B. die Entschlüsselung bei jedem Empfänger genau so lange dauert. Wenn jetzt z.B. die YAMAHA-Entwickler der Meinung waren, einen leicht größeren Puffer zu verwenden, kann das schon mal z.B. 50ms Extra-Latenz reinbringen und schon hast du deinen Hall-Effekt.
das.produkt
Schaut ab und zu mal vorbei
#3 erstellt: 15. Nov 2012, 08:23
vielen Dank für die Antwort. Ich werde jetzt nochmal die ehemalige Airport Express Station aktivieren und am Yamaha anschließen und sehen, ob dann auch noch eine Verzögerung auftritt. Ansonsten werde ich den Support von Yamaha anschreiben.
DunklerStaub
Ist häufiger hier
#4 erstellt: 16. Nov 2012, 21:57
Bei AirPlay sind etwa 2-3 Sekunden Pufferung so vorgesehen, das ist Absicht. Damit wird Schwankungen in der Übertragungsgeschwindigkeit vorgebeugt. Es lässt sich auch nicht abstellen.

Sofern kurze Aussetzer toleriert werden können (Telefonieren) kann man bei Audio-Übertragung über ein Netz auf lange Puffer verzichten, ansonsten empfiehlt es sich über ein normales Netz immer etwas zu puffern (vor allem bei WLAN, weil hier häufig schlechte Raten und starke Schwankungen auftreten können). Die 2-3 Sekunden sind IMHO sehr konservativ, eine Sekunde hätte es in den meisten Fällen auch schon getan.

Geht hier um Wahrnehmung: was ist störender? Wenn ein Lied nen ticken später anfängt oder wenn es mittendrin kurz aussetzt? Man muss sich hier zwischen zwei Übeln entscheiden, und Aussetzer sind bei Musikgenuss ganz klar das grössere Übel :-)


[Beitrag von DunklerStaub am 16. Nov 2012, 21:58 bearbeitet]
das.produkt
Schaut ab und zu mal vorbei
#5 erstellt: 19. Nov 2012, 09:21
Habe nun mal die "alte" Airport Express am Yamaha angeschlossen und es ist ein Unterschied. Die Verzögerung ist noch hörbar, aber nicht so extrem.

Definitiv verzögert der Yamaha die eingebaute Airplay Ausgabe.

@ DunklerStaub
Ich benutze Airplay für Multiroom. Wenn ich bei uns z.B. im Flur stehe, höre ich die Musik aus verschiedenen Räumen. Seit dem ich jetzt den Yamaha mit Airplay einsetze, habe ich ein leichtes Echo. Der Yamaha gibt die Airplay Ausgabe nicht exakt zur gleichen Zeit aus wie meine anderen Airplay Ausgabegeräte (Airport Express Stationen mit angeschlossenen Aktiv Boxen).
DunklerStaub
Ist häufiger hier
#6 erstellt: 19. Nov 2012, 10:53
Hmmm, vielleicht ignoriert der Yamaha die Timing-Synchronisation? Grundsätzlich ist von AirPlay eine Zeit-Synchronisation für präzise Wiedergabe vorgesehen (siehe Unofficial AirPlay Protocol Specification). Da Timing aber generell tricky ist kann ich mir gut Vorstellen dass Yamaha das schlicht nicht implementiert hat. Wenn du nur zu einem Ziel abspielst isses ja auch schnurz. Das einzige was du machen kannst ist an den Yamaha-Support schreiben und beten, dass die das in einem Firmware-Update irgendwann mal korrigieren. Darauf wetten würde ich nicht


[Beitrag von DunklerStaub am 19. Nov 2012, 10:54 bearbeitet]
christof-kr
Ist häufiger hier
#7 erstellt: 19. Nov 2012, 11:58
Sehr interessanter Link. Dass AirPlay tatsächlich alle 3 Sekunden Pakete zum Timing abgleichen verwendet, wusste ich nicht. Kann sicherlich nicht schaden, dass YAMAHA weiß, dass es da ein Problem gibt. Dennoch denke ich, dass nur ein geringer Prozentsatz der AirPlay-Nutzer mehr als nur ein Gerät parallel betreiben (mit Überlapp), so dass das bei YAMAHA wohl eher niedrige Prio hat.
Ghockmann
Neuling
#8 erstellt: 16. Feb 2013, 12:52
Hi
Ich habe genau das gleiche Problem:
Yamaha 473, iMac. Und 2 AirPlay Lautsprecher (Philipps)
Alle Lautsprecher sind 100% in Sync. Nur der Yamaha hängt immer Hörbar im Echo hinterher.
AirPlay soll ja gerade ermöglichen mehrere Lautsprecher gleichzeitig zu betreiben. Aber Yamaha macht es nur bedingt möglich.
Ich hoffe auch sehr, dass die Leute dort entsprechend reagieren.
Habe gerade ein Update angeworfen. Vielleicht geht's ja schon? Schön wärs.
Grüsse

Update im zweiten Anlauf (!) installiert.
Leider keine Änderungen.
Und mir ist noch aufgefallen, dass sich der Yamaha bei jedem zu oder Abschalten eines AirPlay Lautsprechers ebenfalls kurz ab und dann gleich wieder anmeldet. Auch blöd und etwas nervig.
Aber für den Preis trotzdem noch ein toller AV-Received. (Über Amazon für unter 300€ geschossen)


[Beitrag von Ghockmann am 16. Feb 2013, 13:26 bearbeitet]
Pixelschupsa
Schaut ab und zu mal vorbei
#9 erstellt: 05. Jul 2014, 18:32
Besitze einen Yamaha RX S600 und einen IMac (2013).
habe auch eine Verzögerung von 2-3 Sekunden, wenn ich Musik über Itunes (Airplay) laufen lasse.
Einsteiger_
Inventar
#10 erstellt: 06. Jul 2014, 09:39
Hast du ein Bildschrim (OSD) Pin ?

Wenn ich z.b beim Apple TV die Pin abfrage ausschalte habe ich die verzögerung nicht.

Falls es sowas geben sollte, ist eine überlegung kann es nur vermuten.


[Beitrag von Einsteiger_ am 06. Jul 2014, 09:58 bearbeitet]
MarcusD.
Neuling
#11 erstellt: 08. Nov 2015, 19:58
Dasselbe Problem hier mit einem AppleTV oder mit einer AirportExpress und dem Marantz NR1403.
Einfachste Aktivboxen an die AirportExpress geklemmt und alles ist synchron.
Seltsam, was die AVRs da machen...
*homekino*
Hat sich gelöscht
#12 erstellt: 10. Nov 2015, 12:11
Habt ihr mal daran gedach, dass der DSP (Digitaler Sound Prozessor - verantwortlich für jegliche Tonbearbeitung) im AVR auch Zeit für Berechnungen benötigt und hier die erste Ursache zu suchen ist? Im Modus Direct sollte die geringste Verzögerung festzustellen sein.


[Beitrag von *homekino* am 10. Nov 2015, 12:13 bearbeitet]
Suche:
Das könnte Dich auch interessieren:
Airplay
Batista123 am 08.03.2015  –  Letzte Antwort am 15.03.2015  –  8 Beiträge
Airplay-Probleme bei RX-A3020
gnomos am 30.10.2012  –  Letzte Antwort am 03.11.2012  –  13 Beiträge
RX-V473 Airplay Itunes Lautstärke
BallistiX am 27.11.2012  –  Letzte Antwort am 05.12.2012  –  4 Beiträge
Yamaha RX 473 direkter Airplay-Internetstream
Carlii am 26.11.2012  –  Letzte Antwort am 30.11.2012  –  2 Beiträge
Airplay/Spotify am RX-V475
*Hobbit73* am 14.12.2014  –  Letzte Antwort am 22.12.2014  –  31 Beiträge
yamaha rx v 477 - airplay lautsprecher
#holgito# am 19.04.2016  –  Letzte Antwort am 20.04.2016  –  2 Beiträge
RX-V673 und Airplay
hotschi27 am 26.02.2013  –  Letzte Antwort am 26.02.2013  –  5 Beiträge
Airplay Aussetzer
_________________ am 21.02.2017  –  Letzte Antwort am 08.04.2017  –  11 Beiträge
Fragen zum RX-V473, u.a. AirPlay
tremonia09 am 01.04.2013  –  Letzte Antwort am 18.05.2013  –  12 Beiträge
Airplay Probleme beim RX-A820
Schatzsucher am 25.09.2012  –  Letzte Antwort am 20.05.2017  –  35 Beiträge

Anzeige

Aktuelle Aktion

Partner Widget schließen

  • beyerdynamic Logo
  • DALI Logo
  • SAMSUNG Logo
  • TCL Logo

Forumsstatistik Widget schließen

  • Registrierte Mitglieder828.941 ( Heute: 47 )
  • Neuestes MitgliedQjuzel
  • Gesamtzahl an Themen1.386.519
  • Gesamtzahl an Beiträgen18.407.625

Hersteller in diesem Thread Widget schließen