Externe USB-Soundkarte unter Linux

+A -A
Autor
Beitrag
FrankJH
Ist häufiger hier
#1 erstellt: 02. Feb 2014, 16:58
Hallo zusammen,

ich habe unter OpenSuse Linux 12.3 ein Problem mit dieser externen USB-Soundkarte von Conrad.

Nachdem ich den Linux-Treiber snd-usb-audio nachinstalliert habe, funktionierte die Soundkarte einwandfrei, sogar der optische Digitalausgang.

Wenn ich dann den Rechner neu starte, funktioniert's auf einmal nicht mehr.

Wenn ich dann allerdings ins YAST gehe und die Soundkarte neu konfiguriere, läuft der USB Sound auf einmal wieder.

Ich will jetzt nicht meine ganze Hardware auflisten, da ich glaube, daß es sich hierbei um ein Softwareproblem handelt.

Eigentlich sind meine Informationen auch ein wenig dürftig, aber ich verstehe nicht, warum die Soundkarte jedes Mal neu konfiguriert werden muß.

Hat jemand von Euch eine Idee, was da los sein könnte?

Oder soll ich damit mal in ein Linux-Forum gehen?

Viele Grüße, Frank
SleepyFloyd
Ist häufiger hier
#2 erstellt: 07. Feb 2014, 20:08
Zwei Möglichkeiten: Entweder ist die interne Soundkarte noch als Standart eingestellt und es muss einfach auf die Neue umgestellt werden. Geht entweder mit "pavucontrol" oder was Suse da auch immer für ein frontend nimmt.

Oder, was ich aber nicht glaube, es gibt einen Konflikt zwischen dem snd_usb_audio Modul und was auch immer vorher installiert war. Dazu müsste man das andere Modul mal blacklisten... aber, wie gesagt, eher unwahrscheinlich.
FrankJH
Ist häufiger hier
#3 erstellt: 08. Feb 2014, 00:27
Danke für die Antwort.

Finde ich gut, daß Du geantwortet hast.

Ich habe mal einen Screenshot des Yast-Dialogs gemacht:

Untitled

Rechts unten kann man mit "Others" "Set as the primary card angeben" - das habe ich auch gemacht.

Und dennoch: wenn ich dann auf "Edit" gehe und mit "Reset all" die Soundkarte neu konfiguriere, funktioniert es auf einmal wieder ... und was das Merkwürdige ist: mit Suse Linux 11.3 hat's funktiniert, nach dem Update auf 13.1 nicht mehr ... scheint mir, als ob da etwas in Vergesseheit gerät ...

Das andere Modul heißt "snd-hda-intel", und da habe ich bislang im Yast nicht herausgefunden, wie man's blacklistet (eigentlich ein schlimmer Anglizismus )

Fällt Dir noch etwas dazu ein? Ansonsten würde ich mal ein Linux-Forum anvisieren ...

Beste Grüße, Frank


[Beitrag von FrankJH am 08. Feb 2014, 00:37 bearbeitet]
SleepyFloyd
Ist häufiger hier
#4 erstellt: 08. Feb 2014, 11:52
Hmm... wenn Yast die Einstellungen vergisst und es in einer alten Version funtkioniert hat, dann würd ich sagen, dass da was im argen liegt und es kein Benutzerproblem ist.
Benutze weder KDE noch OpenSuse, deswegen kann ich da nicht weiter helfen. Wäre dann wohl wirklich besser, sich da im Forum mal umzuhören.

Das Blacklisten von Treibern ("Schwarzlisten" ist leider noch schlimmer...) wird dann wohl auch nichts bringen. Kann man mal ausprobieren, aber scheinbar liegt ja kein Konflikt vor, sondern nur die Vergesslichkeit von Yast. Nur der Vollständigkeit halber, ich würde es nicht machen:

Dazu (mit root-Rechten) unter /etc/modprobe.d eine Datei blacklist.conf erstellen oder ggfs. edieren und

blacklist snd_hta_intel

reinschreiben und neustarten. Aber vorsicht: Damit wird verhindert, dass der Treiber geladen wird. Die interne Soundkarte wird dann nicht mehr erkannt.

Bisschen ausführlicher dazu: http://wiki.ubuntuus...hindern-Blacklisting

Bessere Idee: Yast ignorieren und es mal "per Hand" probieren. Geht eigentlich ganz simple.

In'nem Terminal "alsamixer" aufrufen. "F2" drücken und "/proc/asound/cards" auswählen. In dieser Liste dann gucken, welche Nummer die USB Soundkarte hat.
Dann “asoundconf set-default-card 2“ eingeben, wobei "2" natürlich die jeweilige Nummer sein muss.

Sollte das immer noch nix helfen, Computer durch das geschlossene Fenster werfen und Haus anzünden...
FrankJH
Ist häufiger hier
#5 erstellt: 08. Feb 2014, 12:35
Nochmals Danke!

Ich werde mich mal durch Deinen Link und diesen hier zu ALSA durchkämpfen.


SleepyFloyd (Beitrag #4) schrieb:
Dann “asoundconf set-default-card 2“ eingeben, wobei "2" natürlich die jeweilige Nummer sein muss.


Meinst Du hier "alsaconf"?



Sollte das immer noch nix helfen, Computer durch das geschlossene Fenster werfen und Haus anzünden... ;)




Na ja, soweit wird's wohl nicht kommen ... und wenn ich nicht weiterkommen sollte, werde ich mal ins Linux-Forum posten. Brandeilig ist die Sache nicht.

Wünsche Dir ein schönes Wochenende.

Frank
SleepyFloyd
Ist häufiger hier
#6 erstellt: 08. Feb 2014, 13:06
"alsaconf" kann auch sein.
Hatte den Befehl schnell von hier abgeschrieben: http://ljnux.jwidmer.de/?p=5
Scheinbar haben sich die Bezeichnungen für die Programme geändert... sorry.

Der Link zum Archwiki sieht hilfreich aus. Is zumindest cleverer, als die Module per Blacklist direkt zu sperren. Wenn bei dir da ein "-2" eingetragen ist, würde es zumindest erklären, warum Yast die Einstellungen nicht übernimmt.
Suche:
Das könnte Dich auch interessieren:
Multimedia-Software für Linux
FrankJH am 27.03.2014  –  Letzte Antwort am 03.06.2014  –  19 Beiträge
Welche Linux-Distro für HiFi?
buayadarat am 23.02.2012  –  Letzte Antwort am 08.11.2013  –  22 Beiträge
Linux Mint
Graf_Hinkelstein am 12.04.2012  –  Letzte Antwort am 07.07.2012  –  46 Beiträge
Problem Mit Linux Ubuntu
test20 am 13.10.2013  –  Letzte Antwort am 04.11.2013  –  4 Beiträge
neuer laptop Linux
manny001 am 30.08.2010  –  Letzte Antwort am 31.08.2010  –  4 Beiträge
Linux vs. Windows
Welturlaub am 27.12.2011  –  Letzte Antwort am 27.04.2013  –  110 Beiträge
Windows 7 Freigabe Problem mit Android und Linux
Sammo82 am 24.08.2013  –  Letzte Antwort am 06.03.2014  –  3 Beiträge
Samsung SSD mit Linux: Firmware Update unter Windows möglich?
Tank-Like am 08.07.2016  –  Letzte Antwort am 10.07.2016  –  4 Beiträge
XP auf Netbook DeInstallieren und Linux Insstallieren
Lil_K' am 22.02.2011  –  Letzte Antwort am 28.02.2011  –  3 Beiträge
wie suse-linux von der platte entfernen ?
premiumhifi am 30.03.2010  –  Letzte Antwort am 31.03.2010  –  9 Beiträge
Foren Archiv
2014

Anzeige

Produkte in diesem Thread Widget schließen

Aktuelle Aktion

Partner Widget schließen

  • beyerdynamic Logo
  • DALI Logo
  • SAMSUNG Logo
  • TCL Logo

Forumsstatistik Widget schließen

  • Registrierte Mitglieder915.059 ( Heute: 19 )
  • Neuestes Mitgliedopo2sum
  • Gesamtzahl an Themen1.529.251
  • Gesamtzahl an Beiträgen21.099.280

Hersteller in diesem Thread Widget schließen