Sie sind bereits Community-Mitglied? Dann loggen Sie sich hier ein!

Auto-Login
Passwort vergessen?


mp3 - Zeitanzeige falsch und läuft zu schnell ab.

+A -A
Autor
Beitrag
chrizzer
Stammgast
#1 erstellt: 12. Okt 2012, 05:36
Hallo zusammen,

ich habe eine ganze Reihe CDs per Audiograbber in mp3 umgewandelt und per mp3tag alle nochmal mit Cover getaggt.
Die ganzen Dateien sind nun auf einer SD-Karte, die ich im Autoradio abspielen lasse.

Läuft alles soweit gut, nur dass ein Titel, der ca 4 min lang ist bei der Zeitanzeige mit beispielsweise 7:45 min angezeigt wird und die Zeit dann auch entsprechend schneller abläuft.
Der Titel läuft aber ganz normal ab.

An was kann das liegen?
Stuhlfänger
Stammgast
#2 erstellt: 12. Okt 2012, 09:59
An dem Codec. Hast Du Lame eingebunden?
chrizzer
Stammgast
#3 erstellt: 12. Okt 2012, 12:02
Ja, hab ich.

In Mp3 Tag habe ich die Methode
ID3V2.3 ISO-8859-1 ausgewählt, da beim Radio sonst die Albentitel und Künstlernamen "kryptisch" dargestellt wurden.
HiLogic
Inventar
#4 erstellt: 12. Okt 2012, 12:15
Meine Vermutung: Dein Autoradio ist Müll und kann mit variabler Bitrate nicht richtig umgehen.
Stuhlfänger
Stammgast
#5 erstellt: 12. Okt 2012, 12:30
Ich erinnere mich dunkel, daß es früher ab und an solche Probleme bei vbr gab, aber das Thema .mp3 ist inzwischen so ausgelutscht, daß man sich damit kaum noch beschäftigt, eben weil normalerweise alles funktioniert. Den Audiograbber gibt es seit über 10 Jahren, und obwohl er schon lange nicht mehr upgedated wurde, ist er immer noch aktuell.

Möglicherweise liegt es am Autoradio, daß die Infos irgendwie falsch interpretiert. Zeigen die Software-Player die Zeit richtig an? Wenn es nur wenige Titel sind, die Probleme machen, würde ich die nochmal neu erstellen, ggfs. mal mit einem anderen Programm.
chrizzer
Stammgast
#6 erstellt: 12. Okt 2012, 13:18
Ich hab die Karte mal noch am Radio eines Sharans getestet.
Bei den meisten Songs kommt statt der üblichen abgelaufenen-/ Restzeit Anzeige (bspw. 0:15/ -3:30) statt der Restzeit nur "VBR"

Ich selbst habe ein Krämer KR 747 (würde ich nicht gerade als Müll bezeichnen).

Vermute daher auch, dass es an der VBR-Codierung liegt.

Neu erstellen möchte ich die ganze Chause eher ungern - waren um die 250 CDs.
Kann man das auch anders korrigieren - also die mp3s selbst?
HiLogic
Inventar
#7 erstellt: 12. Okt 2012, 13:54

chrizzer schrieb:
Ich selbst habe ein Krämer KR 747 (würde ich nicht gerade als Müll bezeichnen).

Naja... Da es offentlich nicht mit VBR umgehen kann, obwohl VBR seit Beginn von MP3 zum Standard gehört, muß man diese Implementierung zwangsläufig als Müll bezeichnen.
Selbst billigste Aldi Geräte bekommen das heute problemlos hin.
Mein Autonavi hat damit auch keinerlei Probleme und bis zu diesem Thread dachte ich, dass das Thema allgemein längst vorbei ist...


chrizzer schrieb:
Kann man das auch anders korrigieren - also die mp3s selbst?

Die einzige Möglichkeit wäre, den MP3 Stream mit Foobar2000 zu rebuilden (ist eine Art Reperatur-Funktion für defekte MP3s).
Ansonsten: keine Chance. Welche LAME Version hast Du denn verwendet?
Es gab mal eine, die hatte dahingehend einen Bug.


[Beitrag von HiLogic am 12. Okt 2012, 13:57 bearbeitet]
Drexl
Inventar
#8 erstellt: 12. Okt 2012, 14:34

chrizzer schrieb:
Kann man das auch anders korrigieren - also die mp3s selbst?

Die Musik wird doch sauber abgespielt, also wo ist das Problem? Wozu brauchst Du im Auto eine sekundengenaue Musikanzeige? Die Augen sollen auf die Straße schauen und nicht am Navimonitor das Hochzählen der Sekunden betrachten.

Mir ist in meinem Wagen auch bei manchen MP3s eine Diskrepanz der angezeigten mit der reelen Spielzeit aufgefallen. Das "Problem" stufe ich aber als so geringfügig ein, daß sich eine weitere Fehlersuche nicht lohnt. Manche VBR werden richtig angezeigt, manche nicht. Bei mir ist es also kein generelles VBR-Problem.
Accuphase_Lover
Inventar
#9 erstellt: 13. Okt 2012, 08:41
Nicht umsonst verwende ich nur CBR !

Selbst mein - zugegebenermassen - schon älterer Pioneer Universal-DVD-Player beherrscht kein VBR - aber SACD und DVD-A.
Butti2
Stammgast
#10 erstellt: 13. Okt 2012, 10:12

chrizzer schrieb:
Kann man das auch anders korrigieren - also die mp3s selbst?

Keine Ahnung ob es weiterhilft, da ich noch nie vor diesem Problem stand. Auf HA wurde unter anderem MP3val empfohlen.

Grüße
ahbed.
Hat sich gelöscht
#11 erstellt: 18. Okt 2012, 09:58
Alle Jahre wieder mal ein Exot, der das immer noch nicht kann. Verblüffend.

Also ja, entweder ein Gerät verwenden, das MP3 unterstützt, oder die Dateien umwandeln. Die genannte "Fix VBR MP3 Header" und "Rebuild MP3 Stream" Funktionen von foobar oder MP3val könnten auch schon helfen, halte ich aber für unwahrscheinlich, wenn der Decoder deines Players Murks ist.

Ansonsten gibt es Tools wie MP3Packer, das bläst dir deine VBR auf eine CBR Datei auf, ohne neu zu encoden. Die Datei wird also größer ohne anders zu klingen. Du bekommst also ohne erneutes Transcoden eine CBR Datei. Ist halt Platzverschwendung...
Suche:
Das könnte Dich auch interessieren:
FLAC schnell umwandeln in MP3/AAC
CandleWaltz am 02.08.2009  –  Letzte Antwort am 25.12.2013  –  129 Beiträge
MP3's zu leise
günther397 am 04.01.2009  –  Letzte Antwort am 11.01.2009  –  29 Beiträge
mp3 programm
zierroff am 11.11.2005  –  Letzte Antwort am 11.11.2005  –  4 Beiträge
Meine Anlage spielt bei MP3 und Youtube nur Stereo ab
Corai am 01.10.2011  –  Letzte Antwort am 02.10.2011  –  4 Beiträge
MP3-Speicher
mikewazowski am 05.12.2005  –  Letzte Antwort am 05.12.2005  –  10 Beiträge
viele MP3 und M3U Dateien
bundy-76 am 30.07.2009  –  Letzte Antwort am 30.07.2009  –  3 Beiträge
flac und mp3 gleichzeitig verwalten
syncronizer am 11.03.2011  –  Letzte Antwort am 15.03.2011  –  7 Beiträge
Problem mit mp3 Player
In_Flames am 26.06.2005  –  Letzte Antwort am 27.06.2005  –  8 Beiträge
MP3 in CD konvertieren?
Shaker am 30.01.2010  –  Letzte Antwort am 30.01.2010  –  8 Beiträge
flac rauscht mp3 nicht
sicknote am 10.01.2013  –  Letzte Antwort am 13.01.2013  –  7 Beiträge
Foren Archiv
2012

Anzeige

Aktuelle Aktion

Top Hersteller in PC & Hifi Widget schließen

  • Logitech
  • Bose
  • Teufel
  • Edifier
  • Creative
  • Google
  • JBL
  • Behringer
  • Klipsch

Forumsstatistik Widget schließen

  • Registrierte Mitglieder806.744 ( Heute: 65 )
  • Neuestes MitgliedKaebbi
  • Gesamtzahl an Themen1.344.795
  • Gesamtzahl an Beiträgen17.655.008