Sie sind bereits Community-Mitglied? Dann loggen Sie sich hier ein!

Auto-Login
Passwort vergessen?


USB-Toslink-Konverter (Stick oder kleine Interface)

+A -A
Autor
Beitrag
cr
Moderator
#1 erstellt: 05. Jan 2013, 21:18
Auf die Schnelle habe ich zumindest nichts gefunden.
Gibts einen USB-Stick, der nichts macht, als auf der anderen Seite ein SPDIF-Signal auszugeben. Zumindest für Coax hatten wir so was mal wo im Forum, finde es aber nicht mehr (vielleicht kennt es wer), aber optisch wäre mir lieber.
Das Ding soll sonst gar nichts können, kein DA- oder gar AD-Wandler usw. Dafür soll es aber die SPDIF-Ausgabe bitidentisch hinkriegen, WASAPI und ev. ASIO unterstützen und auch die beiden Kanäle zueinander nicht um einen Frame verschieben (führt nämlich zu Höheneinbruch bei mittigen Signalen), wie es anscheinend das kleine Behringer udio-Interfaca UCA 202 macht.
Es soll zur Anbindung von Notebooks an einen DA-Wandler dienen.
Joe-Han
Inventar
#2 erstellt: 05. Jan 2013, 21:33
Ich habe dafür den M2Tech HiFace, er gibt aber über Coax aus. Es gibt Treiber für Kernelstreaming, funktioniert z.B. mit Foobar und Winamp.
Es gibt eine Cinch/RCA und eine BNC-Version, mittlerweile u.a. auch bei Amazon.
http://www.fairaudio.de/leserberichte/2010/m2-tech-hiface-usb-spdif-1.html
Könnte der sein, den du meinst. Wenn man an "Jitter" glaubt, ist die zusätzliche elektrisch-optisch-elektrisch Wandlung vermutlich eh unvorteilhaft.
Für USB-Toslink kenne ich aber auch nur billige USB-Soundkarten, wie die TerraTec AureonDualUSB. Dafür gibt es vermutlich keine Kernelstreamingtreiber.


[Beitrag von Joe-Han am 05. Jan 2013, 21:49 bearbeitet]
cr
Moderator
#3 erstellt: 05. Jan 2013, 22:01
Genau, das mit dem Coax war eh der HiFace........

Was ich noch gefunden habe, was Ähnliches in billiger:
http://www.pc-hifi-s...spdif-converter.html
HA Info NG USB-SPDIF Converter
ist auch Coax

der hat beides (Coax und Toslink)
HA-INFO U2 USB to SPDIF Converter

das hätte den idealen Formfaktor
http://www.ecoustics.com/bbs/messages/10381/610764.jpg

leider erfährt man nirgends wo was über die techn. Daten.
Werner_B.
Inventar
#4 erstellt: 05. Jan 2013, 22:50

cr schrieb:
das hätte den idealen Formfaktor
http://www.ecoustics.com/bbs/messages/10381/610764.jpg

leider erfährt man nirgends wo was über die techn. Daten.

Doch, schon, auf der Hersteller-Homepage, allerdings versteckt im Support / Knowledgebase: http://www.turtlebeach.com/support/entry/830517038/

Ansonsten kannst Du Dich hier mal umsehen: http://thewelltemperedcomputer.com/HW/USB_SPDIF.htm

Gruss, Werner B.


[Beitrag von Werner_B. am 05. Jan 2013, 23:03 bearbeitet]
cr
Moderator
#5 erstellt: 05. Jan 2013, 23:11
Danke für die Links, manche dieser Sachen sind ja echt abartig teuer

Die einfachste Sache, auch von der Bestellung her, wäre die Behringer UCA 202, wenn man nur wüßte, ob die immer noch ihren Bug hat (links/rechts um 1/44.100 sek zeitversetzt).
Werner_B.
Inventar
#6 erstellt: 05. Jan 2013, 23:43

cr schrieb:
... manche dieser Sachen sind ja echt abartig teuer

Ja. Hängt eben immer von der Grösse der Portokasse ab

Noch ein Hinweis: wähle möglichst ein Gerät, das mit den nativen Betriebssystemtreibern auskommt. Sonst geht es wie mit dem M-Audio Transit (das ggf. noch ein Kandidat gewesen wäre, aber nicht mehr neu verkauft wird): für neuere Betriebssysteme ab Win 7 gibt es keine Treiber mehr ...

Und noch einen: Audioquest schreibt, dass es Treiberprobleme gäbe in Win Vista und 8 (Microsoft arbeite daran), deshalb empfehlen sie für Audio WIn XP oder 7. Siehe hier in den FAQs: http://www.audioquest.com/usb_digital_analog_converter/faqs Da das etwas unspezifisch ist, muss das nicht für alle USB-Audio-Geräte zutreffen (vielleicht bestehen die Probleme nur für bestimmte Protokolle - Stichwort asynchron versus adaptiv ...).

Gruss, Werner B.


[Beitrag von Werner_B. am 05. Jan 2013, 23:46 bearbeitet]
Kumbbl
Inventar
#7 erstellt: 06. Jan 2013, 10:48

Werner_B. schrieb:

cr schrieb:
... manche dieser Sachen sind ja echt abartig teuer

Ja. Hängt eben immer von der Grösse der Portokasse ab

Noch ein Hinweis: wähle möglichst ein Gerät, das mit den nativen Betriebssystemtreibern auskommt.


dann ist aber unter windows ab 24/96 (exkl.) Schluß.... normalerweise reicht das zwar auch, aber manche würden halte gern auch 24/176.4 oder 24/192 übertragen können - und das geht unter Windows nur mit speziellen treibern....

prinzipiell stimm ich deinem Ratschlag schon auch zu, dann ist man immer auf der sicheren Seite, aber Hersteller, die für ihre Produkte Treiber für XP, Vista und 7 anbieten und diese über Jahre belegt updaten, dürften auch glaubhaft Support für weitere Betriebssystem-version bieten... und man kann es auch anders sehen: wenn ich mir schon einen reinen Audio-Wiedergabe-rechner einrichte, dann update ich doch auch das Betriebssystem nur sehr selten, wenn überhaupt.......
Werner_B.
Inventar
#8 erstellt: 06. Jan 2013, 17:21

Kumbbl schrieb:
dann ist aber unter windows ab 24/96 (exkl.) Schluß.... normalerweise reicht das zwar auch, aber manche würden halte gern auch 24/176.4 oder 24/192 übertragen können - und das geht unter Windows nur mit speziellen treibern....

Richtig, leider; bei DACs zumindest gibt es dazu brauchbare Lösungen: bis 24/96 mit nativen Treibern und für höhere Samplingraten stehen proprietäre Treiber bereit (z.B. Grace Design m903, Cambridge DAC Magic Plus).


Kumbbl schrieb:
prinzipiell stimm ich deinem Ratschlag schon auch zu, dann ist man immer auf der sicheren Seite, aber Hersteller, die für ihre Produkte Treiber für XP, Vista und 7 anbieten und diese über Jahre belegt updaten, dürften auch glaubhaft Support für weitere Betriebssystem-version bieten... und man kann es auch anders sehen: wenn ich mir schon einen reinen Audio-Wiedergabe-rechner einrichte, dann update ich doch auch das Betriebssystem nur sehr selten, wenn überhaupt.......

Na ja, siehe oben, das M-Audio Transit wird nicht mehr angeboten und schon entfällt der Support. Das wird auch mit anderen Geräten so passieren, die Hersteller werden allesamt keine "Ewigkeitsgarantie" geben wollen. Und mit XP ist zumindest vom Sicherheitsaspekt her, solange man sich im Internet bewegt oder externe Datenträger aus fremder Quelle einliest (wer kommt schon realistisch ohne das aus?), im April nächsten Jahres Schluss, der Support endet dann. Also Upgrade auf 7 oder 8 ... Da läuft dann das eine oder andere nicht mehr ... z.B. für meinen Scanner habe ich einen Tweak gefunden, um ihn unter 7 an's Laufen zu bringen - offiziell war für den mit Vista Schluss (ich hatte ihn ursprünglich unter XP - beide Treiber laufen ohne Tweak nicht unter 7).

Gruss, Werner B.


[Beitrag von Werner_B. am 06. Jan 2013, 17:21 bearbeitet]
j!more
Inventar
#9 erstellt: 06. Jan 2013, 17:39
Auch das HiFace kann mit entsprechenden Treibern 192/24.
Joe-Han
Inventar
#10 erstellt: 06. Jan 2013, 17:58
Ich hatte den Hiface Stick schon unter Windows 7 im Einsatz und jetzt unter Windows 8 läuft er auch mit den KS-Treibern. Eingangs wurde ja auch die Frage nach ASIO gestellt. Der Tipp
Noch ein Hinweis: wähle möglichst ein Gerät, das mit den nativen Betriebssystemtreibern auskommt
widerspricht dem schon etwas.
Wenn man Kernelstreaming nutzt, sollte der Audiostream zumindest unverfälscht ausgegeben werden - ansonsten geht's immer durch den Windows-Mixer.
Darüber hinaus wird der Stream angeblich über eigene Quarze getaktet; solche Feinheiten sind aber nur relevant, wenn man "Jitter"-Gläubiger ist.
cr
Moderator
#11 erstellt: 06. Jan 2013, 18:51
Für das Edirol ua1ex, das noch w2000 unterstützte und ich vor 5 oder 6 Jahren kaufte und das es seit 4 Jahren nicht mehr gibt, wurden noch w7 Asiotreiber angeboten.

Bei einem reinen Musiknotebook stellt sich aber das Problem in der Tat nicht, da kann man xp auch in 10 Jahren noch verwenden
XdeathrowX
Inventar
#12 erstellt: 06. Jan 2013, 18:55

Joe-Han schrieb:
Ich hatte den Hiface Stick schon unter Windows 7 im Einsatz und jetzt unter Windows 8 läuft er auch mit den KS-Treibern.

Was sind KS-Treiber?

cr schrieb:
Für das Edirol ua1ex, das noch w2000 unterstützte und ich vor 5 oder 6 Jahren kaufte und das es seit 4 Jahren nicht mehr gibt, wurden noch w7 Asiotreiber angeboten.

Bei Win7 brauchst du wegen des eingebauten Kernelstreams aka Directsound kein ASIO mehr.


[Beitrag von XdeathrowX am 06. Jan 2013, 18:57 bearbeitet]
j!more
Inventar
#13 erstellt: 07. Jan 2013, 07:57
@XdeathrowX

KS =Kernel Streaming, Kernel Streaming IST NICHT Direct Sound (was man gerne auch mit DS abkürzt). Du meintest wahrscheinlich WASAPI,
XdeathrowX
Inventar
#14 erstellt: 07. Jan 2013, 12:53
JA richtig sry
cr
Moderator
#15 erstellt: 07. Jan 2013, 13:36
WASAPI hilft aber denen nichts, die das Interface auch zum Aufnehmen verwenden und geringe Latenz brauchen. Insoferne ist es schon wünschenswert, dass die Hersteller ihre Treiber aktualisieren. Für meinen Fall wäre es egal, habe beides implementiert, verwende aber trotzdem weiterhin ASIO.
cr
Moderator
#16 erstellt: 28. Nov 2015, 18:03
Gibts inzwischen was Neues an (asynchronen) USB > SPDIF opt. Konvertern, wenn geht mit ASIO?

Außer der Behringer UCA um 35 Euro, die keine ASIO-Treiber hat, finde ich nach wie vor nichts wirklich Vernünftiges.

Vielmehr ist inzwischen bei vielen USB-Interfaces auch noch der SPDIF-Ausgang wegrationalisiert worden...

Der Fostex hpa3 hat auch einen opt. Ausgang, aber auch sonst alles Mögliche (KHV mit zu wenig Spannung und Cinch mit zu wenig Spannung)
http://www.thomann.de/de/fostex_hpa3.htm


[Beitrag von cr am 28. Nov 2015, 18:09 bearbeitet]
Hörschnecke
Inventar
#17 erstellt: 29. Nov 2015, 10:55

cr schrieb:

Gibts inzwischen was Neues an (asynchronen) USB > SPDIF opt. Konvertern, wenn geht mit ASIO?
Außer der Behringer UCA um 35 Euro, die keine ASIO-Treiber hat, finde ich nach wie vor nichts wirklich Vernünftiges.


Die Behringer UCA unterstützt allerdings keinen asynchronen Playback-Modus, wie man nach Deinen Angaben jetzt glauben könnte. Das Playback funktioniert bei ihr "nur" ADAPTIVE, sprich sie muss sich an den Takt vom PC über USB dynamisch anpassen.

Siehe UCA222:

cat /proc/asound/card1/stream0

BurrBrown from Texas Instruments USB AUDIO CODEC at usb-0000:00:1d.0-1.3, full : USB Audio

Playback:
Status: Stop
Interface 1
Altset 1
Format: S16_LE
Channels: 2
Endpoint: 2 OUT (ADAPTIVE)
Rates: 32000, 44100, 48000
Interface 1
Altset 2
Format: S16_LE
Channels: 1
Endpoint: 2 OUT (ADAPTIVE)
Rates: 32000, 44100, 48000
Interface 1
Altset 3
Format: S8
Channels: 2
Endpoint: 2 OUT (ADAPTIVE)
Rates: 32000, 44100, 48000
Interface 1
Altset 4
Format: S8
Channels: 1
Endpoint: 2 OUT (ADAPTIVE)
Rates: 32000, 44100, 48000
[...]

Sogenannte ASIO-Treiber für diese USB-Soundcard sind bei Linux übrigens nicht erforderlich, weil sich die Audiohardware direkt ohne Umwege vom Kernel ansprechen lässt.
.halverhahn
Stammgast
#18 erstellt: 04. Dez 2015, 10:59
Wie wäre es mit dem Delock 61961 für rund 12€ ( http://www.amazon.de/gp/product/B0084CGO88 )

Das Ding ist preiswert, kann bis 24bit/96kHz (44.1/48/96kHz), hat zusätzlich zum analogen Ausgang einen optischen digitalen Ausgang (SPDIF-TOSLINK), AC3 und DTS passthrough mit den VIA Treibern.

Wer unbedingt ASIO haben nöchte, was seit WindowsVista WASAPI nicht wirklich einen Vorteil hat, kann auch gerne das http://www.asio4all.com/ installieren.

.halverhahn
Hörschnecke
Inventar
#19 erstellt: 04. Dez 2015, 14:13
Yep, der günstige Delock 61961 Stick hat einen funktionierenden, optischen S/PDIF auch unter Linux (hier getestet mit Debian wheezy). Die 16bit/44.1kHz und 48kHz laufen darüber, wie man erwarten kann. Interessanterweise bekomme ich auch eine optische Übertragung hin, wenn ich den Delock mit 24bit/96kHz Audiomaterial speise. Ob die (optische) sync aber tatsächlich auch in 24/96 abgewickelt wird oder downsampled ist, kann ich (noch) nicht mit Bestimmtheit sagen. Es spricht aber einiges dafür, weil die Gegenstelle (Edirol UA-1G) kleine Schalter hat und damit auch auf 96 kHz Sample Rate und Rec Mode gesetzt war. Danke, .halverhahn, daß Du mir den Stick nochmal in Erinnerung gerufen hast.

PS: Ich habe es jetzt nochmal verifiziert, die optische Übertragung (TOSLINK) vom Delock 61961 erfolgt bei mir mit bis zu 24bit/96kHz. Seine Ausgangsspannung ist 0.8 Vrms @1kHz 0dBFS


[Beitrag von Hörschnecke am 04. Dez 2015, 16:35 bearbeitet]
cr
Moderator
#20 erstellt: 06. Dez 2015, 00:12
Wäre zwar für meinen Zweck egal. Aber laut Userkommentaren soll der Analogausgang dermaßen rauschen, dass dieser unbrauchbar ist. Da fragt man sich halt generell , ob der Hersteller ein funktionstüchtiges Gerät zusammenbringt. Auch beim Treiber soll es ja je nach Betriebssystem arg hapern. Unter solchen Umständen zahlt man wohl gern den kleinen Aufpreis zur Behringer UCA......
Hörschnecke
Inventar
#21 erstellt: 06. Dez 2015, 00:54

cr schrieb:
Wäre zwar für meinen Zweck egal. Aber laut Userkommentaren soll der Analogausgang dermaßen rauschen, dass dieser unbrauchbar ist.


... vielleicht haben diese User es ja auch nur laut Hörensagen weitergetragen, wie Du gerade ...
cr
Moderator
#22 erstellt: 06. Dez 2015, 02:54
Vielleicht aber auch nicht. Was durchaus wahrscheinlicher ist, da es sich um verifizierte Käufe handelt......
Wenn schon nicht mal die Kabel was taugen. So vernichtende Kritiken findet man ja nicht gerade oft:
http://www.amazon.de/DELOCK-Kabel-Displayport-mini/dp/B002U0YRFW


[Beitrag von cr am 06. Dez 2015, 02:57 bearbeitet]
Hörschnecke
Inventar
#23 erstellt: 06. Dez 2015, 11:55
Sicherlich liegt man mit dem Nachplappern von Mehrheitsmeinungen häufig richtig. Gelegentlich könnte man sich aber auch einmal selbst ein Bild von den Dingen machen. - Huch, da ist auch schon eins ...

noise-floor-Delock-61961

Das ist ein Schnappschuß des Rauschteppichs, wenn der Delock 61961 direkt an meinem Laptop steckend betrieben wird und sein analoger Ausgang mit 1 m Beipackstrippe von einer Focusrite 2i2 aufgezeichnet wird (Software Audionet CARMA 4, vorherige Kalibrierung).

Mag für manche völlig "unbrauchbar" sein und für andere brauchbar oder Hifi. Egal, es sollte ja um TOSLINK gehen.
cr
Moderator
#24 erstellt: 06. Dez 2015, 15:03
Vielleicht hat das Produkt halt eine große Streuung?
Oder es wurde im Zeitablauf was geändert etc...
Qualitätskontrolle besteht ja bei billigem Zeug schon lange keine mehr.
cr
Moderator
#25 erstellt: 07. Dez 2015, 03:17
Was ist vom ESI U24XL http://www.esi-audio.de/produkte/u24xl/
um wohlfeile 80 Euro zu halten?
Asio, SPDIF opt+koax out, (analog out 6,9 dB = 1,7V, geht auch ok)
Nachteile: wird wohl nie einen W10 Asio-Treiber geben, nur bis 48 kHz
Soweit ich weiß, kostete der Esi Dr-Dac Nano auch in etwa das Gleiche
.halverhahn
Stammgast
#26 erstellt: 07. Dez 2015, 14:21

cr (Beitrag #20) schrieb:
Wäre zwar für meinen Zweck egal. Aber laut Userkommentaren soll der Analogausgang dermaßen rauschen, dass dieser unbrauchbar ist. Da fragt man sich halt generell , ob der Hersteller ein funktionstüchtiges Gerät zusammenbringt. Auch beim Treiber soll es ja je nach Betriebssystem arg hapern. Unter solchen Umständen zahlt man wohl gern den kleinen Aufpreis zur Behringer UCA......


Ein paar infos direkt aus erster Hand: Ich habe zwei Delock 61961 in Gebrauch, die ich vor 2 bzw. 1 Jahr gekauft habe. Jeweils an einem Dell Latitude D630 und einem Latitude E6430 und über eine 7,5m lange billig 2,2mm TOSLINK-Verbindung an meinen AVR angeschlossen.
Der hauptsächliche Grund für die Anschaffung war, das ich nur optisches SPDIF benötigte. Der vorhandene Analogausgang und der Mikrofonanschluss liegen unbenutzt brach.

Audio mit 16/24bit, 44.1/48/96 kHz und AC3/DTS werden einwandfrei an den AVR übertragen, verifiziert am AVR mithilfe der samplerate Anzeige.

[Edit]
Ich benutze foobar2000 mit WASPI-Push auf das entsprechende SPDIF interface.
[/Edit]

Ein Adapter hat einen VIA VT1620A verbaut der andere einen VT1630A. Von der funktionalität sind die beiden Delock 61961 indentisch, da alle zusätzlichen optionen des VT1630 nicht genutzt werden - wie z.B. den Equalizer, SPDIF IN, 3D surround sound effect etc.

Beide funktionieren seit ihrer Anschaffung problemlos. Falls man kein AC3/DTS passthrough benötigt wird, funktionieren sie "out of the Box".
Der neuere Adapter mit dem VT1630, hatte auf der mitgelieferten CD den aktuellen Passthrough treiber. Der Treiber des VT630 kann problemlos auch für den VT1620 benutz werden und ist mit ein wenig suche auch im Netz zu finden.

Das einzige Problemchen das ich bei mir festgestellt habe ist, das der Delock den TOSLINK ausschaltet wenn keine Audioausgabe stattfindet. Liegt wieder ein Audiosignal an führt das dazu, das die ersten ca. 300ms des Audiosignals fehlen bevor der AVR etwas ausgibt.
Dies läßt sich in Foobar mithilfe eines DSP plugins beheben, das nur beim start z.B. 1000ms einführtfoo_dsp_pregap. Andere "HiFi" Mediaplayer haben auch eine entsprechende optionen bei der SPDIF ausgabe.
Da dieses Problem wohl nicht nur auf den Delock zutrifft, kann man ihm das nicht allzusehr ankreiden. Das ist vielmehr der verbauten Elektronik geschuldet und kann somit auch bei anderen Marken und Geräten auftreten.

Als TOSLINK-OUT Adapter macht der Delock 61961 genau das was er verspricht und das zu einem Schnäppchenpreis.


[Beitrag von .halverhahn am 07. Dez 2015, 16:19 bearbeitet]
smutbert
Stammgast
#27 erstellt: 07. Dez 2015, 14:35
Mit der U24XL bin ich sehr zufrieden (unter GNU/Linux, ich habe keine Idee wie es mit den diversen Treibern unter Windows aussieht). Spaßeshalber habe ich sogar einmal RMAA die Qualität der analogen Aus- und Eingänge mit Hilfe meiner Referenzsoundkarte getestet - die Ergebnisse habe ich zwar nicht aufgehoben, aber ich weiß noch, dass ich mit ihnen zufrieden war.

Ich bin mir zwar nicht sicher was von der automatischen Auswertung durch RMAA zu halten ist, aber wenn es dich brennend interessiert, würde ich den Test auch wiederholen - wäre kein allzu großer Aufwand.
Den Delock hatte ich zufällig auch bereits, dessen Werte waren in RMAA erwartungsgemäß deutlich schlechter, aber gehört habe ich davon nichts.

Mich würde ja auch interessieren ob sich dieser USB-"Sound/SPDIF Adapter" oder dieses nette Kästchen, das unter mehreren Namen verkauft zu werden scheint sich besser schlagen als der Stick von Delock.
.halverhahn
Stammgast
#28 erstellt: 07. Dez 2015, 16:07

smutbert (Beitrag #27) schrieb:
Mich würde ja auch interessieren ob sich dieser USB-"Sound/SPDIF Adapter"

Das ist technisch gesehen der das gleiche wie der Delock 61961, denn laut den Spezifikationen werkelt dort auch ein VIA VT1630A. Abgesehen davon das ich den VIA Treiber dort verlinkt habe Ob der Analogausgang "besser" ist kann ich nicht sagen. Aber ich vermute mal nicht, da dort wohl insgesammt die gleichen "Innereien" verbaut sind.


smutbert (Beitrag #27) schrieb:
Mich würde ja auch interessieren ob sich dieser [...] oder dieses nette Kästchen, das unter mehreren Namen verkauft zu werden scheint sich besser schlagen als der Stick von Delock.

Naja, hier vergleichen wir aber Äpfel mit Birnen.
Der kleine Delock 61961 und der Startech, kann Stereo Analog ausgabe und SPDIF/TOSLINK Out, dafür halt 24bit/96kHz TOSLINK-OUT fähig.
Der Delock 61803 kann Stereo Analog IN und 8 Kanal analog out, und SPDIF IN/OUT, dafür nur max. 48kHz (16bit/24?).

Andererseits geht es ja vom Threadstarter aus einen USB-TOSLINK adapter zu finden, somit sind meiner Meinung nach die Audioqualitäten und Anzahl der Analogausgänge irrelevant. Die Analogqualität der verschiedenen USB-Soundkarten wäre ein neuer Thread.

@CR: So dringend scheint es ja nicht mit dem USB-TOSLINK adapter zu sein, ist ja schon fast 3 Jahre her
Also einfach mal den Delock 61961 für €12 (oder Startech für €30) gekauft und ausprobiert. Macht sich sofort bezahlt und dann ist Aus mit der Suche. Falls er Deiner Meinung nach nichts taugt als USB-TOSLINK-Adapter, dann gibt es halt als Frustkompensation ein von mir.
smutbert
Stammgast
#29 erstellt: 07. Dez 2015, 17:14
Ja, dass der Startech-Adapter denselben Chip hat, ist mir entgengangen.

Den größeren Delock 61803 habe ich ins Spiel gebracht, weil er von den Grundfunktionen vergleichbar mit dem Interface von ESI ist, das CR ja selbst ins Spiel gebracht hat.
cr
Moderator
#30 erstellt: 07. Dez 2015, 17:53
Es war deshalb nicht so dringend, weil ich je immer noch den Edirol UA1EX verwende. Der schaltet sich jedenfalls nicht aus, wenn nichts kommt (liegt möglw. an Asio, dass das verhindert wird). Trotz möglicher Workarounds erscheint mir sowas schon lästig.
Liegt das Ausschalten aber nicht vielmehr an der unendlich blöden Windows-8.1-Energiesparerei, die bis vor kurzem auch sämtliche ext. Festplatten und USB-Stick permanent lahmgelegt hat (nein, das kann/konnte man nicht über das USB-Energiemanagement verhindern, inzwischen wurde das behoben, obs wirklich funktioniert, weiß ich nicht, habe immer noch w8.0, bei einem anderen Notebook mit 8.1 hatte ich nicht den Eindruck, dass sich was gebessert hat).

Wie schnell schaltet er sich ab, wenn kein Musiksignal kommt und macht er das auch, solange der Software-Player aktiv ist, aber nichts abspielt? Bzw. wenn man ihn über Wasapi betreibt..
Hörschnecke
Inventar
#31 erstellt: 07. Dez 2015, 19:25
@halverhahn
Mein System gibt leider den Chipsatz meines Delock 61961nicht aus, sondern nur dessen USB Vendor:Product ID "040d:3408". Hast Du die Möglichkeit, diese ID dem Chip VIA VT1620A oder VT1630A zuzuordnen? Würde mich einfach nur interessieren.

Eine Korrektur zu meinem letzten Beitrag muß ich leider noch machen, der Delock 61961 misst sich bei mir etwas höher zu 1.0 V(rms) @1kHz 0dBFS , sorry.

Ein VIA Codec ist übrigens auch im preiswerten Logilink UA0210 verbaut. Auch hier habe ich nur dessen USB-ID 040d:3417, ich tippe aber ganz stark, daß dies auch einer der beiden obengenannten Codecs ist. Er geht bei TOSLINK bis 24bit/96kHz, hat einen großen Drehknopf für den Line-Out und dort eine gemessene, maximale Spannung von 1.9 V(rms). Seine drei Status-LEDs für die Samplerate 44.1, 48 und 96 kHz können manchmal auch ganz praktisch sein. Auch bei dem Logilink geht übrigens der TOSLINK immer erst an, wenn ein Audiosignal von meinem System kommt (Linux). Ob es bei dessen Aktivierung zu einer Latenz oder einem Signalverlust kommt, habe ich selbst allerdings noch nicht nachgeprüft.


[Beitrag von Hörschnecke am 07. Dez 2015, 19:29 bearbeitet]
.halverhahn
Stammgast
#32 erstellt: 07. Dez 2015, 20:37
@CR
Der schaltet sich sich sofort aus sobald kein Audiosignal anliegt. Einfach zu erkennen da die TOSLINK-LED finster ist.

Apropos Edirol UA1EX: Vermutlich ist es nicht neues für Dich, auf der Roland Supportseite gibt es Treiber für das Teil bis Win 8.1 http://www.roland.com/products/ua-1ex/downloads/.

Warum willst Du eigentlich das UA1EX ersetzen?

@Hörschnecke
Der VT1620A meldet sich mit USB\VID_040D&PID_3408&REV_0061&MI_00, Seriennummer beginnt mit 13
Der VT1630A meldet sich mit USB\VID_040D&PID_3417&REV_0010&MI_00, Seriennummer beginnt mit 15
cr
Moderator
#33 erstellt: 07. Dez 2015, 21:05
Den Treiber 8.0/64 und 8.1/64 habe ich schon (w8.1 hatte ich ein halbes Jahr installiert, wegen Problemen dann wieder auf 8.0 zurück, ab nächstem Jahr muss ich dann eh wieder 8.1 nehmen, hoffe, die Probleme sind inzwischen beseitigt)
Ersetzen will ich es nicht, ich brauche nur bald ein zweites.
Hörschnecke
Inventar
#34 erstellt: 07. Dez 2015, 22:02

Ob es bei dessen Aktivierung zu einer Latenz oder einem Signalverlust kommt, habe ich selbst allerdings noch nicht nachgeprüft.


... aber jetzt mal näher untersucht:
Über einen TOSLINK habe ich in einer Schleife über die Logilink UA0210 ein Testsignal wiedergegeben und über die verbundene Edirol UA-1G wieder aufgenommen. Ein Vergleich zwischen Quelle und Aufnahme kann so die Latenzen und Datenverluste sichtbar machen. Und tut es auch:

TOSLINK-on-off-signal-loss-Logilink-UA0210

Der erste Track ist der originale Click-Track und man sieht in dieser Vergrößerung nur den erst Click-Ton.

Wenn die TOSLINK-LED vor dem Start der Loopback-Aufnahme bereits an ist und danach der Click-Track gestartet wird, dann wird das Signal unverändert mit ~8 ms Latenz aufgenommen (graue Kurve). Das ist die gewöhnliche - wenn auch recht gute - "Roundtrip-Latency", weil es Zeit kostet, über eine USB-Soundcard wiederzugeben und über die andere USB-Soundcard aufzunehmen. Provozieren ließ sich das "TOSLINK Lampe an", indem die Pause- und Record-Taste gleichzeitig in Audacity gedrückt wurden. Nach Lösen der Pause-Taste startete die Aufnahme und das Ergebnis ist der zweite Track (grau).

Der dritte Track zeigt einen Datenverlust der TOSLINK-Verbindung. Hier wurde einfach nur die Record-Taste gedrückt, was dazu führt, daß die TOSLINK-Lampe direkt zusammen mit der Signalübertragung angeht bzw. startet. In diesem Fall gingen einige Millisekunden des ersten Clicks verloren (~6 ms).

Das Einschalten des TOSLINK beim Start des Signals erzeugt zusätzlich noch eine gewisse Zufälligkeit, denn es kam auch vor, daß der erste Click z.B. gänzlich verschluckt wurde oder sogar stark veränderte Signale (!) aufgezeichnet wurden, bis sich das System stabilisieren konnte. Zufällig konnte in sehr seltenen Fällen der erste Click auch mal ohne Datenverlust aufgenommen werden.

Fazit: TOSLINK-LED und Audiosignal gleichzeitig einschalten ist böse! Der TOSLINK sollte möglichst von Beginn der Audiodatenübertragung AN sein, um solche Glitches zu vermeiden. In meinem Fall ist es der Codec VIA VT1630A, welcher das Verhalten gezeigt hat.
Hörschnecke
Inventar
#35 erstellt: 07. Dez 2015, 22:12

.halverhahn schrieb:

@Hörschnecke
Der VT1620A meldet sich mit USB\VID_040D&PID_3408&REV_0061&MI_00, Seriennummer beginnt mit 13
Der VT1630A meldet sich mit USB\VID_040D&PID_3417&REV_0010&MI_00, Seriennummer beginnt mit 15


Besten Dank, halverhahn, demnach habe ich den Delock mit VT1620A und die Logilink UA0210 mit VT1630A !



Der schaltet sich sich sofort aus sobald kein Audiosignal anliegt. Einfach zu erkennen da die TOSLINK-LED finster ist.


Ich bin mir nicht sicher, ob das so ganz exakt ist. Anscheined kann man den TOSLINK auch unabhängig von einem Nutzsignal aktiv bzw. Licht-an setzen. Wie weiter oben gezeigt, indem ich in einem Beispiel Pause + Record drücke. Dann ist der TOSLINK startklar, noch bevor das erste Nutzsignal kommt. Vielleicht wird zur Aktivierung aber auch eine Nullfolge oder ein anderes Dummy-Signal vorausgeschickt, bevor das eigentliche Nutzsignal gestartet wird.
.halverhahn
Stammgast
#36 erstellt: 08. Dez 2015, 12:28

Hörschnecke (Beitrag #35) schrieb:

.halverhahn schrieb:

Der schaltet sich sich sofort aus sobald kein Audiosignal anliegt. Einfach zu erkennen da die TOSLINK-LED finster ist.

Ich bin mir nicht sicher, ob das so ganz exakt ist. Anscheined kann man den TOSLINK auch unabhängig von einem Nutzsignal aktiv bzw. Licht-an setzen. Wie weiter oben gezeigt, indem ich in einem Beispiel Pause + Record drücke. Dann ist der TOSLINK startklar, noch bevor das erste Nutzsignal kommt. Vielleicht wird zur Aktivierung aber auch eine Nullfolge oder ein anderes Dummy-Signal vorausgeschickt, bevor das eigentliche Nutzsignal gestartet wird.


Das scheint wohl Applikationsabhängig zu sein ob der SPDIF aktiv gehalten wird. Bei foobar2000 schaltet sich der SPDIF sofort ab sobald das Audiosignal endet. Wie es der Start workaround vermuten läßt, werden Nullsamples an den Port gesendet bevor das eigentliche Nutzsignal folgt. Ich vermute das hat Designgründe, das der Port zuerst initialisiert werden muß - welcher Datentyp (PCM/AC3/DTS) und Samplerate (44.1/48/96). Laut SPDIF specs ist die Bitrate ist ja eh immer gleich 20bit bzw. optional 24bit, bei denen die niederen ungenutzten bits auf Null gesetzt sind.

Einzig ein Test ob tatsächlich 24bit übertragen werden wäre noch interessant. Doch ich vermute das das der Fall ist, den 24bit sind seit über 10 Jahre im Mainstream.

Meine Angabe einer Verzögerung ca. 300ms ist empirisch erfolgt. Da mein AVR Zeit benötigt um festzustellen an welchem SPDIF port ein Nutzsignal anliegt (Coax/Toslink) und welcher Datentyp es ist (PCM/AC3/DTS)
cr
Moderator
#37 erstellt: 08. Dez 2015, 15:05
Die UA1EX sendet immer ihr rotes Licht im SPDIF, sobald sie nur angesteckt ist, egal ob man Musik hört oder nicht.
Mit Foobar dürfte das wohl nichts zu tun haben (bleibt natürlich auf Sendung, auch wenn der Track aus ist)


[Beitrag von cr am 08. Dez 2015, 15:09 bearbeitet]
Hörschnecke
Inventar
#38 erstellt: 08. Dez 2015, 19:07

cr schrieb:

Die UA1EX sendet immer ihr rotes Licht im SPDIF, sobald sie nur angesteckt ist, egal ob man Musik hört oder nicht.


Bist Du sicher? Der Nachfolger Edirol UA-1G sendet sein rotes Licht nur, wenn auch ein TOSLINK-Kabel in seinem optical Out steckt. Ohne belegte Buchse ist seine LED immer aus.

Ansonsten verhält sich diese Hardware in der Tat anders, als die VIA basierten Audiointerfaces. Sobald die UA-1G in den USB-Port gesteckt wird und sich initialisiert hat, leuchtet die LED kräftig (bei eingestecktem TOSLINK-Kabel). Sobald man mit diesem Licht auch nur in die Nähe z.B. eines Fiio Taishan DAC kommt, synct dieser sofort und zeigt das mit seiner blauen Status-LED als "Locked" an. Die Edirol sendet also permanent ein syncbares S/PDIF-Signal, auch ohne eine entsprechende Applikation auf dem PC.

Die Logilink UA0210 macht das halt nicht unaufgefordert, sondern nur wenn eine Software auf dem PC sie dazu veranlasst. Beispiele hatten wir ja schon, sei es das Senden von Audiodaten, das Drücken von "Pause" während des Abspielens/Aufnehmens oder noch andere keep-alive Applikationen.
Hörschnecke
Inventar
#39 erstellt: 08. Dez 2015, 19:27

.halverhahn schrieb:

Einzig ein Test ob tatsächlich 24bit übertragen werden wäre noch interessant. Doch ich vermute das das der Fall ist, den 24bit sind seit über 10 Jahre im Mainstream.


Ich gehe eigentlich auch fest von 24bit aus, da z.B. der Delock Dongle mit Codec VT1620A explizit zwei alternative Sets mit 16bit und 24bit für 96000 Hz Samplerate zur Auswahl hat:


VIA Technologies Inc. VIA USB Dongle at usb-0000:00:1d.0-1.3, full speed : USB Audio

Playback:
  Status: Stop
  Interface 1
    Altset 1
    Format: S16_LE
    Channels: 2
    Endpoint: 1 OUT (ADAPTIVE)
    Rates: 48000, 44100, 16000, 8000
  Interface 1
    Altset 2
    Format: S24_3LE
    Channels: 2
    Endpoint: 1 OUT (ADAPTIVE)
    Rates: 48000, 44100, 16000, 8000
  Interface 1
    Altset 3
    Format: S16_LE
    Channels: 2
    Endpoint: 1 OUT (ADAPTIVE)
    Rates: 96000
  Interface 1
    Altset 4
    Format: S24_3LE
    Channels: 2
    Endpoint: 1 OUT (ADAPTIVE)
    Rates: 96000


Auch müssten sich bei abgespeckten 16bit statt 24bit gleich drei Glieder der Wiedergabekette anders verhalten, als erwartet: Audacity, welches definitiv 24bit/96kHz-Material erzeugt und an den Treiber gibt, der 24bit-fähige VIA-Chipsatz und meine optische Gegenstelle UA-1G, welche mit einem Schalter auf 96kHz festgenagelt ist und ebenfalls 24bit-fähig ist.
cr
Moderator
#40 erstellt: 08. Dez 2015, 20:29

Bist Du sicher? Der Nachfolger Edirol UA-1G sendet sein rotes Licht nur, wenn auch ein TOSLINK-Kabel in seinem optical Out steckt. Ohne belegte Buchse ist seine LED immer aus.


Das freie Ende des angeschlossenen Kabels leuchtet.
Da es sich um eine Kombi-Buchse handelt, sieht man nicht wirklich, ob es auch ohne Kabel leuchtet. Möglw. wird zw. Analog-Out (KH) und optisch auch mechanisch umgeschaltet. Kann ich nicht sagen.


Die Edirol sendet also permanent ein syncbares S/PDIF-Signal, auch ohne eine entsprechende Applikation auf dem PC.


Auch unter dem Windows Standardtreiber oder nur via Asio?


Würde mich jetzt interessieren, was die ESI U24xl macht? Kennt die niemand?


[Beitrag von cr am 08. Dez 2015, 20:33 bearbeitet]
Hörschnecke
Inventar
#41 erstellt: 08. Dez 2015, 21:00

cr schrieb:

Da es sich um eine Kombi-Buchse handelt, sieht man nicht wirklich, ob es auch ohne Kabel leuchtet.


Doch, klar, man braucht doch nur hineinzusehen, da es eine 3,5mm-Klinkenbuchse mit einer LED am Ende ist. Sie wird erst eingeschaltet, sobald eine Klinke drinsteckt.



Auch unter dem Windows Standardtreiber oder nur via Asio?


Hab ich nicht, musst Du jemand anderes fragen. Aber es reicht offenbar schon, wenn man sie an einen beliebigen USB-Bus hängt - schon gibt's S/PDIF-Festbeleuchtung. Getestet an einem USB-Port eines Fernsehers und an einem Laptop, der noch im Zustand des gestoppten Bootloaders (Grub) war. Ein USB-Ladegerät reicht allerdings nicht aus, dann versucht die UA-1G erfolglos einen USB-Bus zu detektieren, aber das scheitert und die USB-LED geht direkt wieder aus.


[Beitrag von Hörschnecke am 08. Dez 2015, 21:07 bearbeitet]
smutbert
Stammgast
#42 erstellt: 08. Dez 2015, 21:35

cr (Beitrag #40) schrieb:
[…]
Würde mich jetzt interessieren, was die ESI U24xl macht? Kennt die niemand?


Unter Linux, sogar bereits ohne geladene Hardwaretreiber, eigentlich genau genommen sogar schon bevor das Betriebssystem gestartet wird (solange noch das BIOS oder ein Bootmanager die volle Kontrolle hat), leuchtet der Toslink-Ausgang direkt nach dem Anstecken, egal ob in der Buchse etwas steckt oder nicht.


…aber hilft das Leuchten allein denn überhaupt etwas?
Damit das am Toslink-Ausgang angeschlossene Gerät auch nur ein stilles Signal erkennen kann, müsste das Licht doch in irgendeinem Takt ein- und ausgeschaltet werden? Und dieser Takt hängt doch doch von Samplerate und -tiefe ab oder sind meine Vorstellungen von S/PDIF komplett daneben?
cr
Moderator
#43 erstellt: 08. Dez 2015, 21:42
Gute Frage, es dürfte wohl einfach in der Default-Einstellung (oder der letzten verwendeten) senden.
Da du das Interface hast, gibt es irgendwas, das stört oder lästig ist?
smutbert
Stammgast
#44 erstellt: 08. Dez 2015, 22:15
Unter Linux gibt es nichts.

Dass ich bei Windows nicht so ganz mitreden kann, habe ich ja bereits geschrieben. Sollte ich Gelegenheit haben die ESI an einen Computer mit Windows (wenn dann wahrscheinlich XP) anzuschließen, gibt es dann etwas spezielles was ich noch ausprobieren soll?
Hörschnecke
Inventar
#45 erstellt: 08. Dez 2015, 22:17

smutbert schrieb:

…aber hilft das Leuchten allein denn überhaupt etwas?


Wieder bezogen auf die Edirol UA-1G erzeugt die Karte selbst das "S/PDIF-Leuchten", da das gesendete Licht, selbst wenn der versorgende PC noch im Boot-Menue ist, von einer S/PDIF-Gegenstelle gesynct werden kann (hier Fiio Taishan, Statusanzeige "Locked"). Die UA-1G dürfte keine Schwierigkeit haben, einen Default-Mode zu generieren, da die Samplerate fest per DIP-Schalter eingestellt ist.

Aber es gibt noch eine weitere Feinheit zu beachten! Es gibt zumindest beim Delock USB Dongle zwei Leuchtintensitäten! Eine "Sparflamme" sozusagen, die noch keine Sync erzeugt und bereits beim USB-Einstöpseln angeht. Und das grellrote Leuchten, das während der S/PDIF-Aktivität typisch ist. Ich nehme an, daß Du bei Deiner ESI U24 XL das helle Leuchten gesehen hast, wie es auch dem Grundzustand der Edirol Geräte entspricht ...
smutbert
Stammgast
#46 erstellt: 08. Dez 2015, 22:26
Interessant, das werde ich mir noch einmal genauer ansehen, beim Einstöpseln und während der Wiedergabe…
cr
Moderator
#47 erstellt: 09. Dez 2015, 02:44
Habe Antwort von ESI erhalten:

Es wird immer das Signal gesendet (Audioclock) und es gibt einen echten Asiotreiber.

Dann werde ich es wohl bestellen müssen , ist schön handlich, mit 89 Euro eh billig, und der analoge Ausgang dürfte auch ok sein (vielleicht braucht man ihn ja mal)
Außerdem hat es einen Geräte-USB (nicht die wackligen Mini-USB) und einen normalen SPDIF (nicht Klinken SPDIF, Consumer und AES-EBU)) und immerhin 1,7 Veff (dagegen ist die Edirol mit ihren 0,4V oder so leider unbrauchbar).
Allerdings geht sie nur bis 48 kHz, aber von hochauflösendem Material halte ich eh nix und meine künftige Frequenzweiche kann eh auch nur 44 und 48 kHz, also egal.

Vielleicht kommt noch ein Asio-Treiber w10, nachdem das Interface ja noch immer im Handel ist (die UA1EX gibts ja schon seit vielen Jahren nicht mehr, da wird nichts mehr kommen, denke ich mal)
cr
Moderator
#48 erstellt: 13. Dez 2015, 16:20
Galvanisches USB-Filter

Hier ein kompakter USB-Isolator, der 400 mA DC liefert.
Der müßte doch eigentlich funktionieren, um die Anlage vom PC zu trennen wie ein Lichtleiter, wenn man daran den USB-DAC ansteckt
wohlfeil um 35 Euro

https://electronics-shop.dk/isolated_usb_hub.htm?currency=EUR

Gibts inzw. auch von Delock, mit nur 320 mA, zB beim Reichelt
http://www.reichelt....psuma=Geizhals%20(AT)
cr
Moderator
#49 erstellt: 18. Dez 2015, 22:25
Man muss wirklich höllisch aufpassen, der Fostex hp a3 gibt zB USB Signale via Lichtleiter aus.
Aber, so eine kleine Anmerkung, immer als 24/96, womit es zB für mich völlig unbrauchbar wäre......
Hörschnecke
Inventar
#50 erstellt: 20. Dez 2015, 20:01
Zurück zur Frage des Eröffners:



Gibts einen USB-Stick, der nichts macht, als auf der anderen Seite ein SPDIF-Signal auszugeben?


Stick nicht ganz, aber auch nicht viel größer als dergleichen plattgewalzt :

PCM2704-USB-DAC

Kann ich nichts Schlechtes drüber berichten. Der Burr-Brown PCM2704 wandelt ohne Volume-Drop, ohne Interchannel-Phase-Error und der Toslink ist immer aktiv. Prüfung habe ich mit 16bit/44.1kHz durchgeführt. Er könnte bis 48 kHz:


Burr-Brown from TI USB Audio DAC at usb-0000:00:1d.0-1.3, full speed : USB Audio

Playback:
  Status: Stop
  Interface 1
    Altset 1
    Format: S16_LE
    Channels: 2
    Endpoint: 2 OUT (ADAPTIVE)
    Rates: 32000, 44100, 48000
  Interface 1
    Altset 2
    Format: S16_LE
    Channels: 1
    Endpoint: 2 OUT (ADAPTIVE)
    Rates: 32000, 44100, 48000


Für ~6 EUR bei *bay kein schlechter Kauf IMHO.


[Beitrag von Hörschnecke am 20. Dez 2015, 23:33 bearbeitet]
Suche:
Das könnte Dich auch interessieren:
DVBT USB Stick Laptop
phhere am 21.01.2006  –  Letzte Antwort am 22.01.2006  –  2 Beiträge
VGA -> SVideo/Component Konverter
der_Flo am 16.06.2009  –  Letzte Antwort am 18.06.2009  –  6 Beiträge
Soundkarte / USB-Audio-Interface
martinz am 06.06.2008  –  Letzte Antwort am 06.06.2008  –  5 Beiträge
USB-Soundkarte/Interface gesucht
gerdsen am 11.08.2009  –  Letzte Antwort am 20.09.2009  –  2 Beiträge
LPs digitalisieren - USB/Audio Interface
Sören_T. am 08.02.2014  –  Letzte Antwort am 28.02.2014  –  56 Beiträge
Stereo-Anlage + USB Stick
Phrator am 03.08.2011  –  Letzte Antwort am 04.08.2011  –  5 Beiträge
USB Werbe Stick
Settel22 am 16.09.2013  –  Letzte Antwort am 26.09.2013  –  7 Beiträge
sound interface mit usb oder firewire
jens1912 am 07.06.2007  –  Letzte Antwort am 08.06.2007  –  7 Beiträge
Highend Soundkarte oder USB-Firewire Interface gesucht ?
schottland am 31.10.2008  –  Letzte Antwort am 03.11.2008  –  5 Beiträge
Audio Interface
Matwei am 27.02.2008  –  Letzte Antwort am 02.03.2008  –  8 Beiträge

Anzeige

Produkte in diesem Thread Widget schließen

Aktuelle Aktion

Hersteller in diesem Thread Widget schließen

  • Pioneer
  • Smart

Forumsstatistik Widget schließen

  • Registrierte Mitglieder807.269 ( Heute: 123 )
  • Neuestes MitgliedRheingauner04
  • Gesamtzahl an Themen1.345.480
  • Gesamtzahl an Beiträgen17.666.274