Sie sind bereits Community-Mitglied? Dann loggen Sie sich hier ein!

Auto-Login
Passwort vergessen?


S/P-DIF unter Linux, Alsa

+A -A
Autor
Beitrag
mssm
Stammgast
#1 erstellt: 11. Mai 2010, 11:46
Hallo,

wie kann ich die Sample-Rate von S/P-DIF unter Linux ändern?

Es ist ein Onyx (pcm3052) Codec Chipsatz verbaut. Wenn ich die Vorstufe über SPDIF anschließe, gibt der Ausgang immer 48kHz aus, auch bei 44.1kHz Dateien. Laut Hardware-Spezifikation (15inchPowerBookG4) soll die Hardware alle nötigen Sampleraten können (44.1, 48 kHz und andere).
Ich weiß nicht, wie andere Betriebssysteme und Treiber damit umgehen. Ist dort die Samplerate schaltbar im Treiber?

Ich vermute mal, man kann bei manchen Modulen soetwas beim Laden mit modprobe mitgeben. Unter /usr/src/linux/Documentation/sound/alsa/ALSA-Configuration.txt kann ich aber nichts finden, auch nicht bei anderen Modulen.
Zur Not hab ich noch eine Terratec Dual USB zur Verfügung, wenn es nur damit möglich sein sollte.

Einzig mplayer gibt Auskunft über die Ausgaberate. Dort steht bei der Datei 44.1kHz und im Output 48kHz. Die Vorstufe lügt also nicht.
Doc-Brown
Stammgast
#2 erstellt: 11. Mai 2010, 18:50
In der
/etc/alsa/alsa.conf
gibt es eine Zeile mit
defaults.pcm.dmix.rate 48000
Dort dann den Wert 44100 eintragen.
Simple_Simon
Hat sich gelöscht
#3 erstellt: 13. Mai 2010, 19:30
Audacious bietet außerdem die Option, jegliche Veränderung des Signals, wenn möglich, zu umgehen.

Eigentlich sollte damit ein Upsampling ebenfalls unterbunden werden.


[Beitrag von Simple_Simon am 13. Mai 2010, 19:31 bearbeitet]
mssm
Stammgast
#4 erstellt: 07. Jun 2010, 13:21
Audacious hat die Optionen zum Resampling ausgegraut und deaktiviert.

Ich habe die Zeile sowohl in /etc/alsa/alsa.conf (gab es noch nicht, Distribution ist Gentoo) und ~/.asoundrc eingetragen. Das Ergebnis ist das gleiche:

$ /usr/bin/mplayer track_01.mp3
MPlayer SVN-r30554-4.3.4 (C) 2000-2010 MPlayer Team

Spiele track_01.mp3.
Audio only-Dateiformat erkannt!
Clip-Info:
Title: track_01
Artist: -
Album: -
Year: 2010
Comment:
Track: 1
Genre: Other
==========================================================================
Öffne Audiodecoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16be, 128.0 kbit/9.07% (ratio: 16000->176400)
Ausgewählter Audiocodec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [alsa] 48000Hz 2ch s16be (2 bytes per sample)
Video: kein Video
Starte Wiedergabe...
A: 4.9 (04.9) of 315.0 (05:15.0) 2.7%

MPlayer wurde durch Signal 2 im Modul play_audio unterbrochen.
A: 4.9 (04.8) of 315.0 (05:15.0) 2.7%
Beenden... (Ende)

Und die Vorstufe zeigt 48kHz.
Simple_Simon
Hat sich gelöscht
#5 erstellt: 07. Jun 2010, 13:33
Füge mal probehalber die Zeile

pcm.!default {
type plug
slave.pcm hw
}


in die ~/asoundrc ein. Das sollte den dmixer komplett deaktivieren. Wenn es das nicht ist müsste man sich mal informieren, ob der gstreamer, den Gentoo verwendet eventuell ein resampling vornimmt.

Ich kann aber nicht dafür garantieren, das das so funktioniert, da ich die Bitidendität meiner Musikausgabe nicht überprüfen kann.Ich wäre deswegen an dem Ergebnis, ob positiv oder negativ, interessiert.


[Beitrag von Simple_Simon am 07. Jun 2010, 13:35 bearbeitet]
mssm
Stammgast
#6 erstellt: 07. Jun 2010, 13:42

==========================================================================
Öffne Audiodecoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16be, 128.0 kbit/9.07% (ratio: 16000->176400)
Ausgewählter Audiocodec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
[AO_ALSA] Fehler beim Öffnen der Wiedergabe: Device or resource busy
[AO SDL] Samplerate: 44100Hz Kanäle: Stereo Format s16be
[AO SDL] Kann Audio nicht öffnen: No available audio device
Simple_Simon
Hat sich gelöscht
#7 erstellt: 08. Jun 2010, 17:53
Das sollte nicht kommen. Leider verwende ich eine andere Distribution als du und kenne mich auch sonst nicht genug aus um dir daszum Laufen zu bringen.


[Beitrag von Simple_Simon am 08. Jun 2010, 17:54 bearbeitet]
_gr33n_
Stammgast
#8 erstellt: 15. Jun 2010, 19:14
Hi
Ich habe bei mir die .asoundrc so erstellt wie es Simple_Simon vorgeschlagen hat.
Bei mir geht's

Audio only-Dateiformat erkannt!
==========================================================================
��ffne Audiodecoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, s16le, 950.2 kbit/67.33% (ratio: 118769->176400)
Ausgew��hlter Audiocodec: [ffflac] afm: ffmpeg (FFmpeg FLAC audio)
==========================================================================
AO: [alsa] 44100Hz 2ch s16le (2 bytes per sample)


ich benutze kein extra Alsa Paket sondern das was beim Kernel dabei ist.

sys-kernel/gentoo-sources-2.6.31-r6
media-video/mplayer-1.0_rc4_p20091026-r1

Kann es sein das du einen Sounderserver am laufen hast der das Device belegt?
Ansonsten poste mal deine ~/.mplayer/config
Wenn die Datei nicht existiert dann /etc/mplayer/mplayer.conf
weissglut
Stammgast
#9 erstellt: 06. Jan 2011, 13:38
Wie man dmix korrekt konfiguriert habe ich in diesem Thread erklärt: http://www.salixos.org/forum/viewtopic.php?f=24&t=984&p=7870
Außerdem würde ich nicht MPlayer zum Testen empfehlen.
Suche:
Das könnte Dich auch interessieren:
Linux - Terratec Aureon S/P-DIF-Ausgang
wurzelknecht am 13.03.2005  –  Letzte Antwort am 17.03.2005  –  5 Beiträge
Surround über S/P-DIF, was geht?
garbel am 24.12.2012  –  Letzte Antwort am 27.12.2012  –  6 Beiträge
Laptop S/P DIF-Buchse
Ad0r am 08.06.2010  –  Letzte Antwort am 08.06.2010  –  8 Beiträge
Alsa Problem mit Soundkarte
Markus_Panik am 12.06.2014  –  Letzte Antwort am 23.06.2014  –  13 Beiträge
3,5 Klinke auf S/P DIF?
hh_othmarschen am 03.08.2006  –  Letzte Antwort am 03.08.2006  –  2 Beiträge
Creative SB Extigy: S/P-DIF Digitaleingang verpfuscht Daten
wahnfried1883 am 16.08.2003  –  Letzte Antwort am 20.08.2003  –  8 Beiträge
Digitales Satelliten Radio über S/P-DIF aufnehmen
batman_1981 am 08.08.2005  –  Letzte Antwort am 09.08.2005  –  2 Beiträge
Soundblaster X-Fi: Rückkopplung über S/P-DIF IN /OUT
ThommyDD am 06.09.2007  –  Letzte Antwort am 19.09.2007  –  4 Beiträge
Onboard 7.1 über S/P DIF an AV Receiver
JannyP am 06.08.2008  –  Letzte Antwort am 07.08.2008  –  10 Beiträge
PC an 5.1 Anlage - S/P-DIF Verzögerung
Oinobareion am 15.10.2008  –  Letzte Antwort am 07.11.2008  –  7 Beiträge
Foren Archiv

Anzeige

Aktuelle Aktion

Top Hersteller in PC & Hifi Widget schließen

  • Logitech
  • Bose
  • Teufel
  • Edifier
  • Creative
  • Google
  • JBL
  • Behringer
  • Klipsch

Forumsstatistik Widget schließen

  • Registrierte Mitglieder806.828 ( Heute: 2 )
  • Neuestes Mitglieddima_1984
  • Gesamtzahl an Themen1.344.987
  • Gesamtzahl an Beiträgen17.657.984