Sie sind bereits Community-Mitglied? Dann loggen Sie sich hier ein!

Auto-Login
Passwort vergessen?


Probleme bei der Filmwiedergabe (PC)

+A -A
Autor
Beitrag
>scarface<
Ist häufiger hier
#1 erstellt: 03. Apr 2009, 16:09
Hallo,


Problem I:
Wenn ich mit dem Mediaplayer Classic HD-Inhalte wiedergebe, ruckelt auf meinem PC (Q6600, ati4850, an der Hardware sollte es also nicht liegen) auch bei 720i das Bild stark (laut Anzeige mit Fraps ~15 fps), obwohl die CPU kaum ausgelastet ist.
Mit dem DivX-Player aus dem DivX7 Paket ist die Wiedergabe problemlos möglich (Anzeige: 60 fps).
....aber:

Problem II:

Wenn ich Videodatein mit AC3-Tonspur mit dem MPC abspiele, kann ich wunderbar über SPDIF (Toslink) den Dolbysound an den Receiver (Onkyo TX-SR 604) ausgeben.
Beim DivX-Player verwende ich hierfür den AC3-Filter, mit diesem kann ich jedoch nur PCM ausgeben (klingt flach, fad, kraftlos - ein erstaunlich großer Unterschied, der definitiv nicht unter Voodoo fällt), wennn ich den AC3-Filter auf "Use SPDIF" umstelle, bekomme ich nur noch ein lautes krächzend-knacksendes Geräusch statt dem normalen Sound.


Wenn ich nun dem DivX-Player eine SPDIF-Ausgabe beibringen könnte oder dem MPC ein anständiges HD-Bild, dann wäre ich schon sehr dankbar.
Besser wäre natürlich eien Lösung für beide Probleme (mich wurmt soetwas immer...).


[Beitrag von >scarface< am 03. Apr 2009, 16:11 bearbeitet]
The-Clash
Ist häufiger hier
#2 erstellt: 03. Apr 2009, 17:48
mhh so probleme hatte ich noch nie mit dem MPC. benutzt du irgendwelche codec packete oder ähnliches?

hiermit kannst du übrigens codecs löschen.

und hiermit neue installieren.

bei mir hats so immer geklappt wenns probleme gab. wie siehts bei dir mit vlc aus? gibts da auch probleme? der hat hierbei den vorteil das er eigene codecs verwendet.

grüße , Ralf
>scarface<
Ist häufiger hier
#3 erstellt: 04. Apr 2009, 11:32

benutzt du irgendwelche codec packete oder ähnliches?

Nein, installiert habe ich nur den ac3-filter und das divX7-Paket (hat eigentlich bisher gereicht und müsste auch reichen...?!).

Ich werde es aber mal mit dem VLC probieren (habe ich bisher nicht genutzt, weil ich mit den anderen eigentlich wunderbar zurecht gekommen bin).
>scarface<
Ist häufiger hier
#4 erstellt: 04. Apr 2009, 21:37
Grrrr... Das ist doch zum Mäusemelken....

Problem III:
Jetzt habe ich mir den aktuellen VLC installiert (0.99) und mich an der inzwischen durchaus nutzbaren Oberfläche erfreut. VLC spielt auch HD-Inhalte flüssig ab (25 fps), aber ich habe, wenn ich die DTS-Tonspur über SPDIF (Modus waveout) ausgebe, alle paar Sekunden ganz kurze Tonaussetzer, die man nur bemerkt, wenn sie während einem längeren Ton auftreten - nervt aber dann trotzdem...
Wenn ich die SPDIF-Ausgabe deaktiviere, sind diese Aussetzer weg. Das Lichtleiterkabel hat keine Knicke oder starke Krümmungen - woran könnte das liegen?

(ich will doch nur ganz normal eine HD-Datei mit DTS-Tonspur wiedergeben...) *heul*
hoppelkopp
Stammgast
#5 erstellt: 04. Apr 2009, 22:25
Hallo,

deinen Frust kann ich gut verstehen. In VLC kann man sehr viele Einstellungen vornehmen. Dazu muss man im Einstellungsfenster unten links unter "Einstellungen zeigen" die Auswahl "Alle" aktivieren. Vielleicht hilft es, ein wenig mit den wirklich umfangreichen Optionen zu spielen.

Eine andere Möglichkeit wäre evtl. noch, die Bildwiederholrate im Grafiktreiber in Abhängigkeit vom abzuspielenden Filmmaterial zu verändern. Bei normalem PAL mit seinen 25 Halbbildern funktioniert eine Bildwiederholrate von 75Hz besser als die Standardeinstellung 60Hz. Wie das mit HD-Material aussieht, kann ich aber nicht sagen. Einen Versuch ist das aber vielleicht wert.

Gruß Jan
>scarface<
Ist häufiger hier
#6 erstellt: 04. Apr 2009, 22:42
@hoppelkopp:
Danke dir (mit den erweiterten Einstellungen werde ich mal spielen, auch wenn sich meine Hoffnungen eher in Grenzen halten - die beschriebenen Einstellungen für den VLC sollten eigentlich die richtigen sein).
Beim VLC wird das Bild ja auch richtig wiedergeben - da macht nur der Ton Probleme, der ja (eigentlich) gänzlich unberührt in den Receiver wandern sollte, insofern wird der Grafiktreiber hier wenig Einfluss haben, oder?
hoppelkopp
Stammgast
#7 erstellt: 05. Apr 2009, 08:51
Bild und Ton in Computerdateien sind ja keine von einander unabhängigen Signale. Meine Überlegung ist folgende: Wenn das Bild bei einer ungeeigneten Wiederholrate flüssig läuft, muss der Ton stocken. Andersherum sollte es ebenso sein.

Die Bildfrequenz zu ändern, ist m.E. die am einfachsten durchzuführende Maßnahme. Mir fällt nämlich auch nichts weiter ein, was dein Problem lösen könnte. Versuch macht kluch!

Gruß Jan
vstverstaerker
Moderator
#8 erstellt: 05. Apr 2009, 11:47

hoppelkopp schrieb:
Bild und Ton in Computerdateien sind ja keine von einander unabhängigen Signale. Meine Überlegung ist folgende: Wenn das Bild bei einer ungeeigneten Wiederholrate flüssig läuft, muss der Ton stocken. Andersherum sollte es ebenso sein.

Die Bildfrequenz zu ändern, ist m.E. die am einfachsten durchzuführende Maßnahme. Mir fällt nämlich auch nichts weiter ein, was dein Problem lösen könnte. Versuch macht kluch!

Gruß Jan


genau solche probleme (wenns denn daran liegt) löst zum beispiel powerstrip. das synchronisiert bild und ton, mehr kann ich dazu nicht sagen - hab es noch nie gebraucht
>scarface<
Ist häufiger hier
#9 erstellt: 05. Apr 2009, 15:57
Danke - ich werd' heut abend dann mal "forschen"...
>scarface<
Ist häufiger hier
#10 erstellt: 07. Apr 2009, 16:07
Hmmm... Mein Grafikkartentreiber meint, dass 60Hz die maximale Wiedergabefrequenz für meinen Monitor (Eizo S2231) wären und das Datenblatt ist damit einverstanden:
http://www.prad.de/new/monitore/test/2008/test-eizo-s2231w.html



Kann ich da so einfach eine 75Hz-Ausgabe erzwingen?
hoppelkopp
Stammgast
#11 erstellt: 07. Apr 2009, 16:11
Ist das ein Röhrenmonitor? Dann kann der vielleicht 50Hz. Ist ebenfalls ein Vielfaches von 25Hz.

Viele Grüße
Jan

Edit: Habe gerade den Link angeklickt. Der LCD sollte, analog angeschlossen, auch 50Hz können. Probier mal!


[Beitrag von hoppelkopp am 07. Apr 2009, 16:15 bearbeitet]
The-Clash
Ist häufiger hier
#12 erstellt: 07. Apr 2009, 19:02

DTS-Tonspur über SPDIF (Modus waveout)

du meinst das audio ausgabe modul richtig?
warum nicht standart das standart modul tut bvei mir gut seine dienste...

die bildfrequenz als grund für die ton aussetzer kann ich grad nicht so gnaz nachvollziehen.Das ich mir mal gar nicht vorstellen kann das vlc die bildausgabe an den monitor dahingehend anpasst... aber ich lasse mich auch gerne belehren wenn ich irren sollte.

womit testest du eigentlich? vllt liegt es ja an den files xD. Hatte auch schon files die überall andere fehler produzierten.

Grüße,Ralf

P.S. cooler monitor!
>scarface<
Ist häufiger hier
#13 erstellt: 07. Apr 2009, 20:19
@hoppelkopp:
Hmm... da immer umstöpseln ist auch ärgerlich (dauerhaft analog kommt eigentlich nicht in Frage) und so hohe Auflösungen analog geht auch nicht immer gut (teils unscharfes und fehlerhaftes Bild), hab das bei mir aber noch nicht ausprobiert.

@clash:

P.S. cooler monitor!

Der wurde eher für Fotos und Bildbearbeitung angeschafft, aber fürs Glotzen ist er auch fein.


womit testest du eigentlich?

Das waren mehrere HD-Filmdatein, mkv-Container in den x264 und divX-HD (H264) Videoströme und DTS/DTS-ES etc. Videoströme stecken. Da die Wiedergabe bei Umstellung auf PCM-Ausgabe mit VLC und divX-Player wunderbar funktioniert, glaube ich nicht, dass die Dateien einen Knacks haben.


du meinst das audio ausgabe modul richtig?
warum nicht standart das standart modul tut bvei mir gut seine dienste...

Bei mir nicht, da habe ich Soundschnippsel, die sich ~ 5x pro Sekunde wiederholen - war früher mit meiner Trustkarte genauso und da hatte der Programmierer der Fantreiber in seiner FAQ diesen Modus empfohlen. Funktioniert auch hier.

Liegt das vllt. an der Soundkarte?
Aktuell benutze ich die Onboard-Lösung meines Gigabyte GA-EP35-DS3, da meine tolle Trust-Karte mit dem cmedia-Treiber unter Vista64 leider nicht funktioniert (die systeminterne Stasi blockiert den nichtsignierten Treiber, der eigentlich wunderbar laufen würde).
Nicht unbedingt highend, so ein onboard-Ding, aber DTS ganz normal über SPDIF durchschicken sollte doch gehen?!


[Beitrag von >scarface< am 07. Apr 2009, 20:22 bearbeitet]
hoppelkopp
Stammgast
#14 erstellt: 07. Apr 2009, 21:05

>scarface< schrieb:
@hoppelkopp:
Hmm... da immer umstöpseln ist auch ärgerlich (dauerhaft analog kommt eigentlich nicht in Frage) und so hohe Auflösungen analog geht auch nicht immer gut (teils unscharfes und fehlerhaftes Bild), hab das bei mir aber noch nicht ausprobiert.

Schon klar, dass das keine Dauerlösung sein kann. Es geht hier nur um einen Test. Mir fällt sonts nichts mehr ein.

Viele Grüße
Jan
Suche:
Das könnte Dich auch interessieren:
Probleme bei Teufel Concept E350 an PC anschließen
Nobody91 am 20.01.2013  –  Letzte Antwort am 20.01.2013  –  2 Beiträge
LCD + PC über HDMI verbinden - Probleme
FC.Supporter. am 25.01.2008  –  Letzte Antwort am 06.02.2008  –  21 Beiträge
Probleme mit MP3s bei 5.1
Sveeny am 02.09.2005  –  Letzte Antwort am 03.09.2005  –  4 Beiträge
PC-Sound macht Probleme
homerhomer1 am 26.04.2013  –  Letzte Antwort am 09.06.2013  –  27 Beiträge
Probleme mit Pc-Surroundsystem
e-spider am 20.08.2004  –  Letzte Antwort am 29.08.2004  –  4 Beiträge
PC--->AV-Receiver Probleme
t.chrome am 18.11.2006  –  Letzte Antwort am 23.11.2006  –  4 Beiträge
Probleme mit den neuen Tonspurarten bei MediaPC
ronnyempire am 11.10.2007  –  Letzte Antwort am 11.10.2007  –  4 Beiträge
Probleme mit Audioanlage am PC
PrOcEsS am 22.05.2009  –  Letzte Antwort am 24.05.2009  –  6 Beiträge
Probleme/Streß mit meinem PC
der_spirit am 10.09.2005  –  Letzte Antwort am 10.09.2005  –  2 Beiträge
Probleme mit Livestream
david1978 am 01.06.2004  –  Letzte Antwort am 10.06.2004  –  3 Beiträge
Foren Archiv
2009

Anzeige

Produkte in diesem Thread Widget schließen

Aktuelle Aktion

Hersteller in diesem Thread Widget schließen

  • Pioneer

Forumsstatistik Widget schließen

  • Registrierte Mitglieder807.524 ( Heute: 29 )
  • Neuestes Mitglieddantis
  • Gesamtzahl an Themen1.345.700
  • Gesamtzahl an Beiträgen17.670.221