Sie sind bereits Community-Mitglied? Dann loggen Sie sich hier ein!

Auto-Login
Passwort vergessen?


Gehe zu Seite: Erste Letzte |nächste|

ASIO für Win7?

+A -A
Autor
Beitrag
8Quibhirfd8
Stammgast
#1 erstellt: 04. Mai 2014, 23:28
Hallo,

ich dachte das Thema gehört der Vergangenheit an. Ich habe jetzt schon über ein Jahr Win7, und so was wie ein Kernel-Mixer war da kein Thema mehr für mich.
Jetzt habe ich Win7 auf einem neuen Notebook neu installiert, und plötzlich haut mir der Lautstärkemixer in der Taskleiste dazwischen.
Oder liegt es am neuen D/A Wandler? Vorher war es der V-DAC, jetzt ist es der ASUS Xonar One. Meine Wave-und Mpegdateien spiele ich alle mit dem Zoom Player ab, das war auch schon vorher so.

Wie werde ich den Lautstärkemixer wieder los?

Gruß
*Nightwolf*
Inventar
#2 erstellt: 05. Mai 2014, 03:23
WASAPI
Slatibartfass
Inventar
#3 erstellt: 05. Mai 2014, 08:18
Den mitgelieferten Asio-Treiber der Xonar One installieren, sowie ggf. das benötigte Plug-In für den Player.
Der Bit-Perfect Modus der Xonar One, der bei mir das beste klangliche Ergebnis liefert, kann ohnehin nur mit dem Asio-Treiber
genutzt werden. Stand bei meiner Xonar One alles in der mitgelieferten Anleitung und funktioniert bei mir mit Foobar 2000 inkl. Asio-Plug-in einwandfrei.

Slati
TomGroove
Inventar
#4 erstellt: 05. Mai 2014, 10:15
benutzt ihr den ASIO driver auch bei Foobar...dachte dies waere nicht mehr noetig ? muss ich direkt mal testen fuer
meine neue Juli Karte.
cr
Moderator
#5 erstellt: 05. Mai 2014, 10:55
Ich benütze immer den Asiotreiber (auch bei Foobar), egal ob w7 oder w8 oder w8.1.
Wenn ihn der Hersteller schon mitliefert und bisher auch immer sofort aktualisiert hat (der für 8.0 ging zB nicht für 8.1), warum sollte ich dann Wasapi verwenden?
TomGroove
Inventar
#6 erstellt: 05. Mai 2014, 11:04
klar....habe aber den ASIO Plug fuer Foobar noch nicht installiert. Mal sehen, ob ich was hoere
darkforces
Schaut ab und zu mal vorbei
#7 erstellt: 05. Mai 2014, 12:28
WASAPI auf Push-Mode und gut ist. ASIO ist für die Wiedergabe überflüssig.
nenkars
Hat sich gelöscht
#8 erstellt: 05. Mai 2014, 12:33
Ich habe ASIO auch schon seit zig Jahren nicht mehr eingesetzt. KernelStreaming unter XP und WASAPI unter 7 laufen wunderbar, wozu soll ich mir mein System mit zusätzlichen unnötigen Treibern beladen?

Mich würde ja interessieren was genau das bedeuten sollte:

8Quibhirfd8 (Beitrag #1) schrieb:
Jetzt habe ich Win7 auf einem neuen Notebook neu installiert, und plötzlich haut mir der Lautstärkemixer in der Taskleiste dazwischen.

Was soll "dazwischenhauen" denn in diesem Zusammenhang bedeuten?
Dennis50300
Stammgast
#9 erstellt: 05. Mai 2014, 14:15

nenkars (Beitrag #8) schrieb:

Mich würde ja interessieren was genau das bedeuten sollte:

8Quibhirfd8 (Beitrag #1) schrieb:
Jetzt habe ich Win7 auf einem neuen Notebook neu installiert, und plötzlich haut mir der Lautstärkemixer in der Taskleiste dazwischen.

Was soll "dazwischenhauen" denn in diesem Zusammenhang bedeuten?


Naja sehr wahrscheinlich funktioniert ASIO nicht und alles über den ollen Windows-Mixer.

WASAPI macht ASIO in der tat unnötig und naja Kernel Streaming scheint abgesehen davon das es nicht einfach mal so mit jeglichen Soundkarten hinhaut auch Schnee von gestern (Für XP weil es da noch kein WASAPI gab)

ASIO ist eher für Aufnahme interessant, nicht für umsonst steht in der ASIO4ALL-Anleitung ja auch das die Reaktionszeit für's HiFi hören, völlig egal ist.
Da stellt man eher sogar die Reaktionszeit langsamer als schneller ein wenn man das benutzt/benutzen muss.

Das mit den Extratreibern ist allerdings quasi Quark, denn Treiber sollte so oder so installiert sein damit WASAPI auch vernünftig funktionieren kann, ob der Treiber nun ASIO unterstützt oder nicht ist dabei ja völlig egal. (Habe ne' X-Fi titanium bulk sowie mein Realtek HD OnBoard die beide treibertechnisch Asio unterstüzten, nur funktionieren tut es nicht im Ansatz)

Edit:
So eine Xonar (Essence) One lohnt sich auch nur wenn man unbedingt analog rausgehen will aus dem Rechner.
Ansonsten nur unnötig verschwendetes Geld, das Geld ich sah da gerade 300 bis 400€ bei Amazon, sollte man lieber in einen guten AVR stecken und nen Lichtwellenleiter

Da haste nen vernünftigen Kopfhörerverstärker drin und auch gleich noch potente Endstufen samt Raummodeneinmessung für gute Regalboxen oder gar gute, grosse Standboxen.
Wenn man nur Kopfhörer verwendet und nur am PC würde ich zu einer vernünftigen USB-Lösung greifen, also wo der Kopfhörer quasi das Sounddevice darstellt.

Gruss Dennis50300


[Beitrag von Dennis50300 am 05. Mai 2014, 14:20 bearbeitet]
cr
Moderator
#10 erstellt: 05. Mai 2014, 14:34
Asio4all ist ja sowieso nur ein Krücke, die man nicht braucht, wenn die Soundkarte einen herstellerspezifischen Asio-Treiber hat.
Hat die Soundkarte keinen Asiotreiber, würde ich auch nicht Asio4All installieren, sondern gleich Wasapi nehmen.


Das mit den Extratreibern ist allerdings quasi Quark, denn Treiber sollte so oder so installiert sein damit WASAPI auch vernünftig funktionieren kann, ob der Treiber nun ASIO unterstützt oder nicht ist dabei ja völlig egal

Genau, ob der 1MB große ASIO-Treiber noch installiert wird oder nicht, tut ja wohl niemandem weh. Da gibt es größere Probleme in der PC-Konfiguration.

Bei Foobar muss man zudem sowieso die Wasapi-Erweiterung extra installieren, wie auch die Asio-Erweiterung.
Slatibartfass
Inventar
#11 erstellt: 05. Mai 2014, 15:26
Die ASUS Xonar One hat einen herstellerspezifischen Asio-Treiber, der inklusive Plig-in die Aktivierung des Bit-Perfect Modus ermöglicht. Die Aktivierung zeigt sie sogar mit einer zusätzlichen LED an. Warum sollte man diesen Treiber nicht verwenden, zumal bei mir eine hörbare Klangoptimierung damit verbunden ist?
Mit Asio4all oder WASAPI war bei mir der Betrieb des Bit-Perfect Modus bei der Xonar One nicht möglich.

Slati
8Quibhirfd8
Stammgast
#12 erstellt: 05. Mai 2014, 18:06
Das mit dem dazwischenhauen des Windows Lautstärkemixers ist vielleicht etwas irreführend. Ich habe auf das Symbol in der Taskleiste geglickt, und gemerkt, das ich die Laustärke bei Abspielen von Wave-Dateien verändern kann, was ich aber nicht will, denn vorher über den V-DAC war das auch nicht.

Was die Installation des Xonar One Treibers angeht, weiß ich nicht genau was das alles soll. Funktioniert hat die Xonar auch ohne Installation, war aber nicht in der Systemsteuerung unter Sound aufzufinden, erst nach der Treiberinstallation. Ich habe einfach auf Audio Driver geglickt, und schon wurde alles automatisch installiert. Aufzufinden ist die Xonar jetzt auch unter Sound in der Systemsteuerung. Ob jetzt auch ASIO Treiber installiert sind weiß ich nicht. Wo sehe ich das?

ASIO Treiber habe ich auf der CD gefunden, unter Treiber-Win7-Software Treiber-DII.
Wenn ich Upsampling ausschalte zeigt mir die Xonar unter Bit-perfect 44.1 khz an. Ob das jetzt perfect ist weiß ich auch nicht. Was mich stört ist, das ich die Lautstärke über den Windows-Mixer regeln kann, was doch nicht sein sollte?
8Quibhirfd8
Stammgast
#13 erstellt: 05. Mai 2014, 18:37
Möchte noch am Rande dazufügen, das ich auch nirgends diese nervigen Windowstöne abschalten kann, was mich doch erst auf diesen Windowsmixer aufmerksam gemacht hat. Wenn ich den oben anhaue macht es ding dong, das ist doch echt nervig...
*Nightwolf*
Inventar
#14 erstellt: 05. Mai 2014, 18:41
"sound" in die Suche des Startmenüs eingeben und dann das ebenso genannte Tool öffnen. Dort auf die Registerkarte "Sounds" und bei "Soundschema " "keine Sounds" auswählen.


[Beitrag von *Nightwolf* am 05. Mai 2014, 18:41 bearbeitet]
8Quibhirfd8
Stammgast
#15 erstellt: 05. Mai 2014, 18:49
Und eben das ist es, bei Soundschema ist keine Sounds nicht einstellbar.

Das ist jetzt allerdings erst mal zweitrangig.
8Quibhirfd8
Stammgast
#16 erstellt: 05. Mai 2014, 18:54
Jetzt noch was anderes...ich habe Win7 erst vor kurzem installiert, und noch keine Windows Updates machen können, was auch schwierig ist, da ich im Moment nur einen USB-Surf Stick zur Verfügung habe, der sehr langsam ist, da sind keine Updates möglich. Liegt es an fehlenden Updates?
cr
Moderator
#17 erstellt: 05. Mai 2014, 19:46
"Anwendungen im exkluven Modus haben Priorität" ankreuzen, vielleicht.......
8Quibhirfd8
Stammgast
#18 erstellt: 05. Mai 2014, 20:05
Habe ich schon versucht, geht nicht. Der Windowsmixer wird voll farblich dargestellt, d.h. er ist aktiviert, mit allen seinen (negativen) Einstellmöglichkeiten. Vorher war der grau dargestellt, und es konnte sich nichts einstellen lassen.


[Beitrag von 8Quibhirfd8 am 05. Mai 2014, 20:07 bearbeitet]
nenkars
Hat sich gelöscht
#19 erstellt: 05. Mai 2014, 22:54
Der Windows Mixer in 7 ist überhaupt nicht aktiv, solange nur eine Quelle Audio abspielt. Wenn du Systemsounds abgestellt hast (und sein wir mal ehrlich, wann hört man denn schon mal eine Fehlermeldung im Hintergrund auf einem fehlerfrei eingerichteten System?), und ansonsten nur dein Audio Player Sound wiedergibt, dann hast du genau null Einwirkung vom Windows Mixer.

Dass hier immer noch diese Urban Legend vom alten bösen KMixer herumgeistert, ist mir schleierhaft. Es ist doch noch nicht einmal glaubhaft erwiesen, dass die Komponenten des neueren Audio Subsystems (inkl. "Mixer") überhaupt hörbar negative Auswirkungen auf den Klang haben, sofern sie überhaupt in Aktion treten. Die verwendeten Wortbreiten und Sampling Rates sind so hoch (wenn ich mich richtig erinnere arbeitet der Mixer mit 32 bit float und mindestens 192 kHz) und die verwendeten Algorithmen sind so ausgereift, dass die in der Praxis transparent sind.

Wegen einem aktivierten Lautstärkeregler muss man sich wirklich nicht verrückt machen, der zeigt nur an, dass das System ein Audio Interface sieht. Mehr nicht.

Diese Paranoia macht einem doch nur unnötig das Musik Hören schwerer.

Fehlende Updates ändern in Win 7 am Audio System übrigens auch nichts, was hier relevant wäre. Sofern der Rechner am Netz hängt, würde ich aber trotzdem dringend Updates empfehlen, aus völlig anderen Gründen...
8Quibhirfd8
Stammgast
#20 erstellt: 05. Mai 2014, 23:10
Na ja, habe ich mal so einsortiert, aber warum war der vorher auf dem alten Rechner und auch unter Win 7 nicht aktiv, und wer hat unter all den Maßnahmen, wie ASIO und WASAPI und was es alles noch gibt, trotzdem einen aktiven Windowsmixer?
nenkars
Hat sich gelöscht
#21 erstellt: 06. Mai 2014, 07:06
Jedes Audio Interface mit funktionierendem Treiber verhält sich unter Windows normalerweise eben so. Ist ja auch völlig richtig, stell dir doch mal den umgekehrten Fall vor. Ein durchschnittlicher Nutzer schließt sein neues Interface an, nur um zu sehen, dass in Windows nicht mal mehr der Lautstärkeregler funktioniert...? Das wäre ein Problem.

Und nochmal: Der Mixer wird nicht aktiv, solange du nur eine Quelle abspielst, was ja der Normalfall sein sollte. Ich verstehe immer noch nicht, woher die Angst eines "aktiven Mixers" kommt. Ein funktionierender Lautstärkeregler signalisiert noch lange nicht, dass der Mixer aktiv ist.
Slatibartfass
Inventar
#22 erstellt: 06. Mai 2014, 08:23

8Quibhirfd8 (Beitrag #12) schrieb:

Was die Installation des Xonar One Treibers angeht, weiß ich nicht genau was das alles soll. Funktioniert hat die Xonar auch ohne Installation, war aber nicht in der Systemsteuerung unter Sound aufzufinden, erst nach der Treiberinstallation. Ich habe einfach auf Audio Driver geglickt, und schon wurde alles automatisch installiert. Aufzufinden ist die Xonar jetzt auch unter Sound in der Systemsteuerung. Ob jetzt auch ASIO Treiber installiert sind weiß ich nicht. Wo sehe ich das?

ASIO Treiber habe ich auf der CD gefunden, unter Treiber-Win7-Software Treiber-DII.
Wenn ich Upsampling ausschalte zeigt mir die Xonar unter Bit-perfect 44.1 khz an. Ob das jetzt perfect ist weiß ich auch nicht. Was mich stört ist, das ich die Lautstärke über den Windows-Mixer regeln kann, was doch nicht sein sollte?

Wie ich bereits geschrieben habe, wird noch ein entsprechendes Plug-in für den Player benötigt. Habe ich bei Foobar und Winamp installiert. Die Anzeige 44.1kHz bedeutet, dass er aktuell vom Rechner den Audiostream mit 44.1 khz Samplerate angeliefert bekommen. Für Bit-Perfect gibt es eine zweite LED. Steht aber alles in der Anleitung. Nur wenn die Bit-Perfect LED aktiv ist, läuft die Xonar One im Asynchron-Modus und stellt sicher, dass alle Audidaten in ihrem Originalformat verarbeitet werden. Der Lautstärkenregler und Mixer von Windows ist dann auch inaktiv.

Slati
cr
Moderator
#23 erstellt: 06. Mai 2014, 09:49

Ein funktionierender Lautstärkeregler signalisiert noch lange nicht, dass der Mixer aktiv ist.


Ein funktionierender Lautstärkeregler ist schlimm genug, weil man dauernd schauen muss, ob er auf 100% steht (und selbst dann ist die Frage, ob das Signal unverändert durchkommt)
TomGroove
Inventar
#24 erstellt: 06. Mai 2014, 10:46
Warum dies ? Rauschabstand ?
cr
Moderator
#25 erstellt: 06. Mai 2014, 11:57
Prinzipiell.
Dass der Lautstärkeregler noch funktioniert, wird daran liegen, dass eben nicht der exklusive Modus gewählt wurde (oder sich nicht wählen läßt, da müsste man die Ursache finden)
http://en.wikipedia.org/wiki/WASAPI#Audio_stack_architecture
Slatibartfass
Inventar
#26 erstellt: 06. Mai 2014, 13:39
Warum ignoriert hier eigendlich jeder, dass ich schon 2 mal beschrieben habe, wie die Xonar One im ASIO-Modus (oder auch Exklusiv Modus) zu betreiben ist? Bei dieser Konfiguration ist dann auch der Mixer und die Lautstärkernreglung unter Windows 7 inaktiv und die Xonar One wählt automatisch die passenden Einstellungen für Bitbreite und Samplefrequenz der zugespielten Audidaten bei asynchroner Steuerung des PC.

Slati
TomGroove
Inventar
#27 erstellt: 06. Mai 2014, 13:55
bei mir ist der windows mixer auch nicht aktiv...war aber trotzdem interessiert bzgl. des 100% Pegels...
nenkars
Hat sich gelöscht
#28 erstellt: 06. Mai 2014, 14:59

cr (Beitrag #23) schrieb:
Ein funktionierender Lautstärkeregler ist schlimm genug, weil man dauernd schauen muss, ob er auf 100% steht (und selbst dann ist die Frage, ob das Signal unverändert durchkommt)

Warum muss man "dauernd schauen" ob der sich verstellt hat? Einfach aufdrehen und aufgedreht lassen. Ich renne ja auch nicht dauernd zu meinem Verstärker und prüfe mit der Lupe nach, ob ein Windhauch die Regler verdreht haben könnte... Also das kann ich echt nicht nachvollziehen.

Das Signal kommt unverändert durch, sofern die Windows 7 Staandard Einstellungen nicht verändert wurden, der Audio Interface Treiber nicht ein anderes Verhalten erzwingt, und man parallel nicht ein weiteres Programm Sound wiedergeben lässt. Ja, so einfach ist das.
cr
Moderator
#29 erstellt: 06. Mai 2014, 14:59
Ich habe ja auch schon geschrieben, wenn das Interface einen Asiotreiber dabei hat, soll man den verwenden. Warum Wasapi dann im konkreten Fall nicht funktioniert, wäre dann ja egal.
audiophilanthrop
Inventar
#30 erstellt: 06. Mai 2014, 15:53
Mein Eindruck ist übrigens, daß bei nicht ganz wenigen Soundkarten die "nativen" ASIO-Treiber intern auch nur auf Kernel-Streaming aufsetzen... und dabei mitunter weniger gut funktionieren als ASIO4All. Warum sollte man auch das Rad neu erfinden, wenn es ein schnöder ASIO-KS-Wrapper genauso tut...

An der festen Lautstärke bei Betrieb der Xonars mit ASIO sieht man übrigens sehr schön, daß deren Pegelsteller komplett in Software realisiert wird, die Hardware selbst hat keinen PGA. Deswegen kommt man auch relativ leicht auf angebertaugliche Meßwerte.
Slatibartfass
Inventar
#31 erstellt: 06. Mai 2014, 16:32
Was soll das für ein Pegelsteller sein. Die Daten werden im Bit-Perfect-Modus ohne jede Skallierung an die Xonar One geleitet. Es wird eben jede Pegelveränderung auf dem digitalen Signalweg umgangen (insofern feste Lautstärke, besser unveränderte Lautstärke). Lautstärkenunterschiede durch unterschiedliche Abmischungen der Quelldaten sind somit natürlich hörbar.
Die Lautstärke ist dann einzig auf der analogen Seite über die 2 Potis der Xonar One getrennt für die Line-Ausgänge und den Ausgang des KHV regelbar.

Slati


[Beitrag von Slatibartfass am 06. Mai 2014, 16:32 bearbeitet]
cr
Moderator
#32 erstellt: 06. Mai 2014, 16:49

Mein Eindruck ist übrigens, daß bei nicht ganz wenigen Soundkarten die "nativen" ASIO-Treiber intern auch nur auf Kernel-Streaming aufsetzen... und dabei mitunter weniger gut funktionieren als ASIO4All. Warum sollte man auch das Rad neu erfinden, wenn es ein schnöder ASIO-KS-Wrapper genauso tut...


Das würde mich bei den Soundkarten von Herstellern aus dem Profibereich eher wundern, bei meiner liest man:

Dies ist der UA-1EX Treiber für Microsoft® Windows® 8/8.1.
Dieser Treiber unterstützt auch ASIO(Steinberg Audio Stream I/O Interface) 2.0.
ASIO ist eine eingetragene Marke und Software der Steinberg Media Technologies GmbH.
8Quibhirfd8
Stammgast
#33 erstellt: 06. Mai 2014, 20:45
cr:


Ein funktionierender Lautstärkeregler ist schlimm genug, weil man dauernd schauen muss, ob er auf 100% steht (und selbst dann ist die Frage, ob das Signal unverändert durchkommt)




Da muss ich cr vollkommen Recht geben. Ich hätte nicht gedacht das ich nochmal mit dieser ASIO Sch...anfangen muss...und möchte auch nicht nochmal mit Foobar2000 oder Winamp anfangen. Ein Player bitte für alles, und das war für mich der Zoom Player, auch vom Klang her, insbesondere auch bei Videoclips.

Notfalls baue ich mein System wieder komplett um.
nenkars
Hat sich gelöscht
#34 erstellt: 07. Mai 2014, 01:12
8Quibhirfd8, ich weiß nicht, wie du deine Musik organisiert hast, aber vielleicht wäre XBMC was für dich, wenn du eine Komplettlösung auch für Videos willst. Nur als Anregung, fallst du noch eine Alternative zum Zoom ausprobieren möchtest.

Das habe ich nur selbst mal am TV auf einem älteren Rechner laufen gehabt, um eben Filme und Serien zu schauen. Dafür ist es wirklich hervorragend. Die Verwaltung der Musik ist aber relativ spartanisch. Wenn man zum Beispiel viel Klassik hört, wird man damit garantiert nicht glücklich.

Bitte keine Klangdiskussion zu verschiedenen Playern starten...
Slatibartfass
Inventar
#35 erstellt: 07. Mai 2014, 10:09

8Quibhirfd8 (Beitrag #33) schrieb:

Ich hätte nicht gedacht das ich nochmal mit dieser ASIO Sch...anfangen muss...und möchte auch nicht nochmal mit Foobar2000 oder Winamp anfangen. Ein Player bitte für alles, und das war für mich der Zoom Player, auch vom Klang her, insbesondere auch bei Videoclips.

Die Entscheidung, ob einem Bequemlichkeit oder maximale Klangqualität wichtiger ist, kann natürlich nur jeder für sich selber treffen. Bei mir war die ASIO Sch... 2 Stunden nach Auspacken des Xonar One auch bei den Playern erledigt. Seit dem höre ich meine Musik in der besten Qualität die die die Xonar One eben im Bit-Perfect-Modus zu bieten hat.

Ohne entsprechende Maßnahmen wie ASIO etc. macht ein Player keinen Klang, sondern schiebt die Daten nur zur Audio-Hardware. Auch nicht der ZoomPlayer, dessen ursprüngliche Zielsetzung sowieso die Video-Wiedergabe mit freien Zoom-Möglichkeiten ist und die Audio-Wiedergabe für die Entwickler ledigleich ein leicht zu implementierendes Add-on war.

Slati
Dennis50300
Stammgast
#36 erstellt: 12. Mai 2014, 16:42
Also wenn man da während FooBar Musik abspielt noch Windowsounds bekommt, dann ist der Soundkartenausgang einfach nicht mit WASAPI gewählt wurden un FooBar. (Für Asio muss da auch erst ein PlugIn installiert werden)

Das ein Asiotreiber extra Speicher zieht ist ebenfalls quatsch, entweder unterstützt der Treiber für's Sounddevice Asio oder eben nicht, das wird sich aber auf die Grösse des was der Treiber an Platz braucht nur sehr wenig auswirken.

Um nochmal zum Windows-Mixer zurückzukommen, also bei mir ist der immer aktiv, vorallem läuft dann alles darüber wenn nicht gerade Winamp/FooBar läuft zum Musik hören oder der Cyberlink PowerDVD 10 (mit BluRay unterstützung)

Das was WASAPI ausmacht, ist zum einen das windowsmixer umgehen und direkte Ausgabe über den Treiber (am standard gewählten Ausgang), zum anderen das das bitgenaue ausmacht, wenn die Quelle 44100 hat auch 44100 ausgegeben wird.
Ich kann das auch an meinem Yamaha RX-V663 sehen was der für ein Signal bekommt, und wenn die Quelle nunmal 48kHz hat oder mehr muss/soll der das nunmal auch bekommen.

Der windowsmixer kann immer nur eine Samplerate, entweder 44100 (standardeinstellung CD-Qualität) oder man muss alles einstellen was die Soundkarte hergibt, dann wird aber wohl das meiste wenn nicht sogar alles hochgesampelt, also eben nicht bitgenau ausgegeben.

Wenn ich ohne WASAPI arbeite kann ich z.B. konstant 96kHz bekommen obwohl die quellen nur 44100 haben oder 48kHZ, soviel zum ollen Windowsmixer.
Es ist ein Zeichen das wenn eigentlich eine WASAPI-Ausgabe (bitgenaue, auch andere wie ASIO/ASIO4ALL) stattfindet b.z.w. stattfinden sollte, und Windows trotzdem "Ding-Dong" macht eben doch kein WASAPI (oder ASIO/ASIO4ALL) läuft.


Gruss Dennis50300


[Beitrag von Dennis50300 am 12. Mai 2014, 16:54 bearbeitet]
8Quibhirfd8
Stammgast
#37 erstellt: 16. Mai 2014, 00:39
Das mit diesen Ding Dongs hat sich irgendwann erledigt, ist auch nicht so ganz das Problem.

Mit dem Windows-Mixer aber werde ich wohl leben müssen, der ist nicht weg zu bekommen, sofern man nicht foobar/Winamp, mit ASIO installiert hat, dann kann man aber auch nur diese zwei Player für eine "bitgenaue" (Hauptsache ohne Windows-Mixer) Wiedergabe verwenden.

Es liegt an dem Soundchip der in dem Notebook eingebaut ist, der hat Vorrang vor den über USB angeschlossenen Wandlern. Da hast du zwar einen High-End Wandler, wird aber von diesem blöden Windows-Mixer vorrangig beschnitten, das ist echt sch...

Über diesen "Mixer" lässt sich sogar die Balance regeln...Ist mir zwar willkommen, aber nicht auf der Softwareebene.

Was den klanglichen Unterschied zum Vorgängersystem ausmacht, könnte jetzt auch ein anderer Kopfhörer sein, den ich jetzt habe, denn nur da lassen sich Klangdifferenzen ausmachen. Es ist einer der KH, die bei ebay Höchstwerte erzielen, auch wenn sie es nicht wert sind. Da haben andere KH, die leider ein Nischendasein haben, einen oftmals höheren Stellenwert.

Ein kompletter Systemwechsel wie ich es gemacht habe, kann man machen, kann aber auch mit Nachteilen verbunden sein. Von meinem neuen Acer-Notebook kann ich ein Lied davon singen.
nenkars
Hat sich gelöscht
#38 erstellt: 16. Mai 2014, 23:44

8Quibhirfd8 (Beitrag #37) schrieb:
Mit dem Windows-Mixer aber werde ich wohl leben müssen, der ist nicht weg zu bekommen, sofern man nicht foobar/Winamp, mit ASIO installiert hat, dann kann man aber auch nur diese zwei Player für eine "bitgenaue" (Hauptsache ohne Windows-Mixer) Wiedergabe verwenden.

Du hast nicht viel von dem verstanden, was hier im Thread geschrieben wurde.

Der Windows Mixer ist Teil des Sound Systems von Windows. Genauso wie der Kernel Teil des Betriebssystems ist. Oder die Transistoren teil deines Audio Interfaces. Ja, damit kann man sogar die Balance regeln, wenn man möchte, muss man aber nicht. Wo genau ist das Problem?

Nimm irgend einen halbwegs nicht-beschissenen Player, von mir aus iTunes. Drücke auf Play und BÄM, du hast mit an Sicherheit grenzender Wahrscheinlichkeit bitgenaue Wiedergabe. Du brauchst weder einen besonderen Player für bitgenaue Wiedergabe, noch bist du gezwungen ASIO zu verwenden, und schon gar nicht musst du zwanghaft versuchen elementare Bestandteile des Betriebssystems außer Kraft zu setzen, nur weil dich jemand mit genug Paranoia beimpft hat, um zu glauben anders ginge es nicht.

Am besten machst du dir nen Tee und liest den Thread nochmal in Ruhe durch, denn eigentlich sind all deine Fragen beantwortet worden und du solltest völlig andere Schlüsse daraus ziehen als die, die du im letzten Post geäußert hast.
8Quibhirfd8
Stammgast
#39 erstellt: 17. Mai 2014, 16:24
Keine Panik, mittlerweile habe ich mir die Mühe gemacht foobar zu installieren, dann ASIO4All, und das ASIO fobbar Plugin. Ist alles so konfiguriert das ich bei Wiedergabe unten in der Taskleiste den grünen Pfeil habe und der Windows-MIXER außer Funktion ist. Und der Klang erinnert mich wieder an mein altes System.
Ich möchte nochmal betonen das mir da der WM nicht dazwischengefunkt hat. In den Soundeigenschaften habe ich damals den V-DAC als Standardgerät konfiguriert, und alle anderen eingebauten Soundchips deaktiviert, und gut wars.
Da hatte ich auch mit dem Zoom-Player eine excellente Wiedergabe, den ich besonders ach für die Musikvideos genommen habe, weil der eine Einstellung hat ständig auf 16:9 zu bleiben. Andere Player machen bei Trackwechsel zum Teil Schwierigkeiten.
Für die Videos nehme ich im Moment wieder den ollen WMP. Scheint mir das der besser mit dem Windows-Mixer zurecht kommt und jetzt besser als der ZP klingt, (auch ohne ASIO). Für die Wave-Dateien natürlich foobar mit ASIO.
Ich mach mir auch die Mühe genau hin zu hören und ich höre über Kopfhörer Unterschiede, da braucht man allerdings auch die passende Musik dazu. Alles klar?
Dennis50300
Stammgast
#40 erstellt: 17. Mai 2014, 19:22
@8Quibhirfd8:

Du die Asio-Geschichte mit ASIO4ALL ist aber lange nicht so gut wie wenn du das WASAPI PlugIn einfach verwendest.

AFAIK jedenfalls bei winamp war es so, unterstützt das keinen gapless, also sind "CD's" abspielen wo zwischen den Tracks keine Pausen sind dann nun doch Pausen drin.

Asio ist allenfalls für Aufnahme noch nötig aber zum HiFi abspielen ist es einfach nur Schrott von gestern, den man auf XP und oder mit passender Hardware auch heute wohl noch per Kernel Streaming umgeht/ersetzt.




"event" sollte man probieren wenn "push" nicht geht, normalerweise sollte "push" aber laufen ausser bei "problematischen" USB-Sounddevices


Gruss Dennis50300
j!more
Inventar
#41 erstellt: 18. Mai 2014, 10:12
asio4all packt Kernel-Streaming in einen asio-Wrapper. Der bessere weil direkte Weg wäre also direkt KS einzusetzen, wenn das eigentlich zu favorisierende WASAPI nicht will.
Dennis50300
Stammgast
#42 erstellt: 18. Mai 2014, 18:55

j!more (Beitrag #41) schrieb:
asio4all packt Kernel-Streaming in einen asio-Wrapper. Der bessere weil direkte Weg wäre also direkt KS einzusetzen, wenn das eigentlich zu favorisierende WASAPI nicht will.


Tja ist nur ziemlich bescheiden wenn das ganze kein gapless playback unterstützt ne'

Kernel Streaming ist übrigens etwas völlig anderes als Kernel Streaming, KS wird nicht von jeder Hardware unterstützt nur soviel mal dazu.


Gruss Dennis50300
j!more
Inventar
#43 erstellt: 19. Mai 2014, 05:25
Dann halt einen vernünftigen Player nehmen. Gibt ja genug davon. Wem das nicht etwas Mühe (foobar) oder 40 Euro (jriver) wert ist, dem ist wirklich nicht zu helfen.


[Beitrag von j!more am 19. Mai 2014, 05:30 bearbeitet]
Dennis50300
Stammgast
#44 erstellt: 19. Mai 2014, 14:36

j!more (Beitrag #43) schrieb:
Dann halt einen vernünftigen Player nehmen. Gibt ja genug davon. Wem das nicht etwas Mühe (foobar) oder 40 Euro (jriver) wert ist, dem ist wirklich nicht zu helfen.


Jo also Geld ausgeben will/würde ich dafür nur sehr ungerne, man hat doch schon für die Hardware bezahlt die es können müsste.

Naja zum Glück gibt es ja FooBar2000 und Winamp.
Für Filme gucken hab ich hier PowerDVD10, das kann und gab es zu meinem LG BD-RE BH10LS38 mal eben so mit dazu, bis vor kurzem und ich schätze auch weiterhin, krieg ich da noch Updates. spielte bisher auch alles einwandfrei ab und bei DVD's ist die lineare Streckung auch echt ne' feine Sache.

Ich denk das würde kein teurer Blu-Ray Player oder ne' olle Glotze so gut hinbekommen wie mein Asus 7870 Direct CUII (HD7870-DC2-2GD5-V2)

Das einzige was immer ärglich ist, das sowas wie Browser (mitunter Adobe Flash/Shockwave) z.B. irgendwie kein WASAPI können, desöfteren ist ja auf YouTube auch mal gute Qualität anzutreffen und da wäre das schon genial.
Hab mich da schon totgegoogelt, aber leider keine Lösung bisher gefunden.

Mit Games ist das ja auch nicht so einfach, mir ist bislang noch nichts untergekommen was sowas könnte, z.B. NFS - Hot Pursuit (von 2010, also ein schon aktuelleres Spiel), mehr als Stereo bekomme ich damit nicht auf die Reihe leider...
Dabei könnt ich mit Kopfhörern (AKG K550) auch auch sogar mit meinen GLE 470.1 im Stereo auf "Movie"-> "Adventure" DSP soviel tolles Sounderlebnis haben.
Entweder halt "virtual" oder halt "silent cinema", letzteres dürfte ja auch "virtual" sein, ist ja denk ich mal so oder so nur linear 3D Sound möglich mit Kopfhörern. (mit linear meine ich das vorne von hinten nicht wirklich gut zu unterscheiden ist)


Gruss Dennis50300
nenkars
Hat sich gelöscht
#45 erstellt: 19. Mai 2014, 20:01

Dennis50300 (Beitrag #44) schrieb:
Jo also Geld ausgeben will/würde ich dafür nur sehr ungerne, man hat doch schon für die Hardware bezahlt die es können müsste.

Und wie viel Geld kommt beim Software Entwickler von dem an, was du für deine Hardware ausgegeben hast?

WASAPI für Browser oder Flash? Um Himmels Willen, wozu denn? Du glaubst doch nicht ernsthaft, dass sich dadurch der Klang von YouTube Videos irgendwie zum besseren verändern würde?
Dennis50300
Stammgast
#46 erstellt: 20. Mai 2014, 04:08

nenkars (Beitrag #45) schrieb:

Dennis50300 (Beitrag #44) schrieb:
Jo also Geld ausgeben will/würde ich dafür nur sehr ungerne, man hat doch schon für die Hardware bezahlt die es können müsste.

Und wie viel Geld kommt beim Software Entwickler von dem an, was du für deine Hardware ausgegeben hast?

WASAPI für Browser oder Flash? Um Himmels Willen, wozu denn? Du glaubst doch nicht ernsthaft, dass sich dadurch der Klang von YouTube Videos irgendwie zum besseren verändern würde?


Das ist die eine Sache, aber es gibt ja schon längst Software für narda, bei Winamp war ich auch ausserdem noch einer der "Spender" für die Pro Version als das noch möglich war.

Nuja, wo die Qualität dann doch mal fruchtet und ich das als FLAC herunterlade ->convert2mp3.net, klingt so manches dorch deutlich besser über FooBar2000/Winamp als über den ollen Browser/Flash der da durch den Windows-Mixer jagt.

Wird wohl einfach an der bitgenauen Übertragung von WASAPI liegen, slebst der Going Quantum Podcast klingt viel besser.
Das ganze Verzerrwesen klingt einfach etwas flexibler und dadurch besser, ist mal wieder bescheiden zu beschreiben, probiers mal aus.

Da lässt sich dummerweise nun auch nicht grundlegend jede EP oder ein altes "Tape" einfach mal so empfehlen, das ist halt Geschmackssache obs gefällt oder nicht was man da hört.
Aber eines der letzen Multi Genre dürfte was sein, notfalls mit spulen...

Gruss Dennis50300
nenkars
Hat sich gelöscht
#47 erstellt: 20. Mai 2014, 18:42
Ach so, das Verzerrwesen!
8Quibhirfd8
Stammgast
#48 erstellt: 20. Mai 2014, 19:02
Vor dem Zoom Player hatte ich den VLC-Player der mir jetzt wieder eingefallen ist. Den hatte ich lange Zeit auch für Wave-Dateien genommen. Der machte aber bei einer Neunstallation von Windows immer Zicken und spielte die Videodateien nur zur Hälfte ab, und kam dann inst stocken. Die Mpeg-Dateien musste ich allesamt über PVA-Strumento laufen lassen, dann ging es wieder. Warum das so ist weiß ich nicht.

Und nachdem ich mit dem Zoom Player beim neuen System nicht zufrieden bin, nehme ich jetzt wieder den VLC-Player. Nur muss ich jetzt wieder sämtliche Videodateien über PVA-Strumento laufen lassen. Ist eine Arbeit von einem ganzen Abend.


[Beitrag von 8Quibhirfd8 am 20. Mai 2014, 19:02 bearbeitet]
nenkars
Hat sich gelöscht
#49 erstellt: 20. Mai 2014, 20:35
Daran könnte die aktivierte Hardwarebeschleunigung bei veraltetem oder nicht unterstützten Grafiktreiber verantwortlich sein. Ich würde mal sämtliche Treiber und DirectX auf den neuesten Stand bringen. Falls das nicht hilft, könnte man auch versuchen die Hardwarebeschleunigung in VLC komplett zu deaktivieren.

Alternativ noch einen anderen Video Player benutzen, ich würde unter Windows MPC-HC VLC in jedem Fall vorziehen. Ob der aus der Kiste die PVR Transportformate besser verarbeitet, weiß ich nicht, aber es lassen sich im Gegensatz zu VLC die passenden Codecs über DirectShow usw. nachrüsten, falls gewünscht.

Wenn mehrere Player Probleme mit der Wiedergabe dieser Dateien haben, liegt es vielleicht auch schlicht an einem inkompatiblen Format. Man kann mit ähnlichen Tools Audio/Video normalerweise in andere Container exportieren, die weitaus weniger Probleme machen (MKV oder MP4 z.B.).

Das hat aber schon längst nichts mehr mit dem Thema zu tun...
Dennis50300
Stammgast
#50 erstellt: 21. Mai 2014, 15:03
VLC ist ja auch ziemlicher Müll

Der ist zwar ressourcenschonend und unterstützt von Haus aus alles mögliche was einem da auf die Kiste kommen kann/könnte, aber ich hab da schon einiges gelesen... WASAPI hab ich damit im übrigen bislang auch noch nicht wirklich hinbekommen AFAIK.

Das ding soll soviel ich hier auch schon gelesen habe vom Player aus obwohl man da einiges versucht hat an Einstellung zu ändern immernoch den Frequenzgang versauen.

Für Videodateien hab ich von Cyberlink den PowerDVD 10, der macht zwar anscheinend kein WASAPI bei sowas wie AVI oder sowas, aber wenn man sowas da hat, dient auch sowas nur als "Sample" sag ich mal.
Da ist das Bild meist totaler Murks und naja vom Ton wollen wir garnicht anfangen.

Ich hab meine Filme auch 1:1 DVD/Blu-Ray auf die Platte mit dem tollen Programm von Slysoft als Image, mit Menü und allem drum und dran, nix kaputtkonvertiert also.
Mein DT Pro Advanced übers virtuelle Laufwerk und denn läuft das auch sahne, mit dem WASAPI, tolles Bild und guter Ton.

Gruss Dennis50300
nenkars
Hat sich gelöscht
#51 erstellt: 21. Mai 2014, 16:04
VLC ist plattformübergreifend ein Quasi-Standard, der auf den meisten Systemen hervorragend funktioniert. "Totaler Müll" sieht anders aus.

Den Frequenzgang verändert der Player übrigens auch kein bisschen, wenn man ihn nicht kaputt konfiguriert.

Wozu WASAPI in dem Zusammenhang gut sein soll, müsstest du mal genauer erläutern. Bitstreaming von AC3, DTS usw. funktioniert auch so tadellos, besser wird es nicht.

Wer sich mit überfrachteten Suiten wie PowerDVD und Images zum Abspielen auf dem Rechner herumschlagen will, bittesehr. Für perfektes Video braucht man das jedenfalls nicht. Aber jedem das Seine.
Suche:
Gehe zu Seite: Erste Letzte |nächste|
Das könnte Dich auch interessieren:
Unterschied Win XP zu Win7
KLM-U am 23.07.2010  –  Letzte Antwort am 24.07.2010  –  2 Beiträge
AVR Einstellungen und Win7
Bensen1983 am 30.07.2013  –  Letzte Antwort am 30.07.2013  –  2 Beiträge
Lautstärke von USB-DAC einstellen? [Win7]
HuoYuanjia am 07.08.2010  –  Letzte Antwort am 07.08.2010  –  6 Beiträge
Problem Asus STX + Win7 Pro = kein Sound
Vince23 am 15.03.2010  –  Letzte Antwort am 15.03.2010  –  3 Beiträge
RealtekHD unter Win7: Wie SPDIF in entsperren?
Bremer am 03.11.2009  –  Letzte Antwort am 05.11.2009  –  3 Beiträge
EAC & Win7
MOKEL am 22.06.2010  –  Letzte Antwort am 05.07.2010  –  4 Beiträge
Review Asus Xonar Essence ONE (DAC und KHV)
haudegen am 06.02.2013  –  Letzte Antwort am 26.01.2015  –  7 Beiträge
Ton Probleme mit X-Fi , Kopfhörer , Win7 und AC3-Filter
Stylos am 30.12.2009  –  Letzte Antwort am 30.12.2009  –  4 Beiträge
Asio, Kernel-Streaming, Wasapi: Nix geht
michl8888 am 30.10.2009  –  Letzte Antwort am 31.10.2009  –  7 Beiträge
Denon AVR-Win7 Soundeinstellungen
teufelsbursch am 22.03.2012  –  Letzte Antwort am 24.04.2012  –  9 Beiträge
Foren Archiv
2014

Anzeige

Aktuelle Aktion

Hersteller in diesem Thread Widget schließen

  • Canton
  • AKG
  • Yamaha
  • Pioneer
  • Aricona

Forumsstatistik Widget schließen

  • Registrierte Mitglieder807.269 ( Heute: 40 )
  • Neuestes Mitgliedeli36489
  • Gesamtzahl an Themen1.345.387
  • Gesamtzahl an Beiträgen17.664.500