Gehe zu Seite: Erste 2 3 4 5 6 . 10 . 20 . Letzte |nächste|

Der Sure DSP Thread

+A -A
Autor
Beitrag
bierman
Inventar
#1 erstellt: 12. Aug 2016, 18:36
Moin, liebe Gesinnungsgenossen

Wer von euch kennt sich mit dem Sure DSP aus?
Wer hat ihn bereits erhalten?
Ich habe meinen bereits vor drei Wochen bestellt und bezahlt, bisher gab es nicht mal eine Versandbenachrichtigung...
Da ich das Teil nächstes Wochenende dringend brauche und mir - wenn er nicht morgen da ist - die Zeit fehlt ihn vorher zu testen, werde ich langsam unruhig :/

Hätte da ein paar Fragen die es mir einfacher machen würden das Projekt soweit fertig zu stellen dass ich praktisch nur noch die DSP-Platine einsetzen muss.
Erfahrungen mit dem Hobbyhifiladen würden mich auch interessieren.

EDIT:
Das Wiki zum Sure DSP ist unter https://suredsp.ratz-it.de/ erreichbar.


[Beitrag von _ES_ am 27. Nov 2017, 18:07 bearbeitet]
DjDump
Inventar
#2 erstellt: 12. Aug 2016, 22:34
Für alle die nicht wissen um was es geht:
Das Sure DSP ist eine digitale Aktivweiche mit einem ADAU1701 Chip. Der gleiche ist auch im MiniDsp oder dem Free Dsp. Man kann sie am PC mit dem Programm Sigma Studio komplett frei programmieren. Es stehen 2 Audio Eingänge und 4 Audio Ausgänge zu Verfügung. Damit kann man dann zwei 2-Zegler steuern, oder einen Vierwegler, oder ein 2.1/2.2 System. Oder noch viele andere Sachen..
Damit kann man eine ganz normale Lautsprecherweiche konstruieren, aber auch Spielerein wie Bassboost, Loudness, Subsonic und Laufzeitkorrektur verwenden. Zusätzlich verfügt das DSP über 12 frei programmierbare GPIO. Damit lassen sich Informationen von Schalter abfragen, oder man kann damit eine Lampe ein und aus schalten. Auf dem Board sind vier Potis zum manuellen nachregeln von Parametern, damit man nicht immer den PC anschließen muss.
Zum Programmieren braucht man allerdings ein Programmier Kit. Das wird (momentan) nicht von Sure selbst hergestellt, sondern von dem Chiphersteller (Analog Devices). Das DSP kostet 20$, das Programmierkit gibts für unter 100$.
Das DSP hat im Auslieferungszustand eine einfache 2.1 System Schaltung. Die ist allerdings kaum besser als normale 2.1 Verstärker, deshalb ist mMn das DSP nur mit Programmierkit sinnvoll.


Sure DSP bei Sure Electronics
und im Hobbyhifi-Laden.
Datenblatt des ADAU1701

Auf der Seite vom Hobbyhifi Laden wird als Programmierkit das ADZS-USBI2EZB (oder kompatibel). Das habe ich für 50€ bei Mouser Electronics bestellt. Das ist aber auf jeden fall das falsche, bzw nicht ausreichend. Das ist nämlich nur eine (sehr sehr teure) Adapterplatine. Bis auf 5 Widerstände und eine LED sind auf der Platine keinerlei elektronischen Bauteile. Es hat auf der einen Seite den 20Pol Wannenstecker, auf der anderen eine 10Pol Stiftreihe die zu dem folgenden Produkt passen sollte. MMn ist das ADZS-USBI2EZB aber nicht unbedingt erforderlich, bzw durch 2min Löten ersetzt.


Sure empfiehlt das EVAL-ADUSB2Z, das mMn auch zumindest die richtigen Anschlüsse hat. Davon gibt es aber auch mehrere Versionen mit ziemlich ähnlichen Namen. Die Datenblätter zu den einzelnen Modulen sind in der Hinsicht auch meistens relativ aussagelos. Deshalb habe ich momentan ein bisschen Angst schon wieder das falsche zu bestellen.

edit: Der Chip selbst spricht einige gängige Protokolle z.B. I²C. Wenn man da tiefer einsteigt, sollte es möglich sein das DSP deutlich günstiger zu programmieren (z.B. mit einem Arduino Nano für 3€). Man kann auch von einem externen EEPROM Speicher booten, der ist auf jeden Fall relativ einfach zu programmieren. Allerdings verstehe ich davon lange nicht genug um selbst herauszufinden, wie es geht.




Mein DSP kommt voraussichtlich nächsten Dienstag an. Eine Versandbenachrichtigung gab es schon vor ein paar Tagen, war aber auch Express.

Mit dem Hobbyhifi Laden habe ich bis jetzt nur gute Erfahrungen gemacht. Wenns dann da lieferbar ist, würde ich niemandem empfehlen bei Sure direkt zu bestellen.


[Beitrag von DjDump am 12. Aug 2016, 22:50 bearbeitet]
Zalerion
Inventar
#3 erstellt: 13. Aug 2016, 01:50
Hallo zusammen,

bin ich auch schon drüber gestolpert und war versucht zu bestellen. Habe mich aber gewundert, dass es weder Diskussion noch konkrete Infos gab und das mit dem Programmieren über gesonderten Adapter....den man woanders bestellen soll/muss..... hat mich bisher abgehlaten.

Dennoch, schönes Teil und ich hoffe, dass das was ist.
Die Software sieht ganz ok aus. Etwas abschreckend für jemanden, der wenig mit Informatik zu tun hat und bei weitem nicht so selbsterklärend, wie z.B. MiniDSP, aber sehr vielseitig und die Möglichkeiten scheinen sehr groß zu sein. Man muss sich eben etwas reinarbeiten und darf keine Angst vor Logikschaltungen haben.

Freue mich auch über erste Praxisberichte!
peak-lsv
Ist häufiger hier
#4 erstellt: 14. Aug 2016, 00:45

Auf der Seite vom Hobbyhifi Laden wird als Programmierkit das ADZS-USBI2EZB (oder kompatibel) empfohlen. Das habe ich für 50€ bei Mouser Electronics bestellt.


Beschissener geht es ja wohl kaum. Ich habe die DSPs zwar inzwischen bekommen, warte aber auch noch auf das Programmierkit, welches ich auch bei Mouser bestellt habe. Wie kann man schreiben dass man dieses Kit braucht, wenn es dann gar nicht brauchbar ist ... sprich man damit immer noch nicht programmieren kann. Also mal eben 50 Euro in die Tonne gekloppt.

Im übrigen habe ich auf mehrere Emails keine Antwort vom Hobbyhifiladen bekommen. Also technische Hilfe eher null.

Also wenn jemand etwas raus bekommt was man wirklich zum programmieren braucht und links hat ... immer her damir. Wenn ich etwas raus finde, poste ich natürlich auch gerne. Prinzipiell ist die Platine sehr schön kompakt.
DjDump
Inventar
#5 erstellt: 14. Aug 2016, 07:31
Der Hobby Hifi Laden ist gerade im Urlaub
ropf
Stammgast
#6 erstellt: 14. Aug 2016, 08:34
Zum Programmieren geht auch der freeUSBi Adapter aus dem freeDSP Projekt. Der wird als Bausatz uA. auf ebay-Kleinanzeigen angeboten:
https://www.ebay-kle...p/430951705-172-3846

Das Interface-Board für den Sure-DSP führt imho nur 3 der 4 Analogausgänge heraus. Kann man ihn eigentlich auch ohne Interface-Board bestellen? Weil - in dem meisten Fällen wird man wohl eh was eigenes machen (Eingangsstufe, Stromversorgung, ...)

/ropf
Ymf
Stammgast
#7 erstellt: 14. Aug 2016, 14:44
Ich habe meinen SureDSP bereits seit zwei Tagen. Entsprechend konnte ich nicht widerstehen die Sache zu testen.

Dokumentation gibt es dazu eigentlich gar keine, so wie es aussieht. Ich habe das Board beim Hobbyhifiladen ohne das Anschlussboard bestellt und auch so erhalten.

Hier nochmals die Bilder. Habe diese zwar schon in meinem Umbau, aber was solls.

SureDSP und FreeUSBi

So sieht der Lieferumfang aus und die nächsten Bilder sind vom DSP selbst.

SureDSP und FreeUSBi SureDSP und FreeUSBi

So sahen meine ersten Gehversuche aus. Einmal mit der vorgefertigten Konfig und auf dem zweiten Bild dann online vom PC aus.

SureDSP und FreeUSBi SureDSP und FreeUSBi

Zum Programmieren nutze ich ein FreeUSBi. Im I2C Modus läuft die Abstimmung im Betrieb, man hört also direkt die Änderungen. Allerdings habe ich gerade festgestellt, dass das Flashen des EEPROMs irgendwie nicht funktioniert. Jetzt muss ich das Teil wohl nochmal ausbauen, um das zu checken...
ropf
Stammgast
#8 erstellt: 14. Aug 2016, 15:55
Beim freedsp gibt es einen write-protect-Jumper für das eeprom ...

Lustig geflochtene Strippe übrigens - passt der Flachbandanschluss nicht für den Sure-DSP?

Gruß, ropf


[Beitrag von ropf am 14. Aug 2016, 15:59 bearbeitet]
Ymf
Stammgast
#9 erstellt: 14. Aug 2016, 16:35
Problem gelöst. Der Schalter vorne, der mit SW1 betitelt ist, ist der WriteProtect-Schalter. Den muss man zum Flashen umstellen und danach wieder zurück, sonst startet was Teil nicht von selbst. Muss den vielleicht mal an einen zugänglichen Platz verlegen.

Also, bei mir läuft das Teil jetzt. Einsatzgebiet ist im Autoradio drin.


Wenn ich schon dabei bin gleich alle Punkte, die ich mir mühsam erarbeitet habe:

1) Kabel für den FreeUSBi
Kabel vom FreeUSBi hat eine andere Belegung und einen anderen Stecker. FreeUSBi 2x5 Pol und SureDSP komischer 1x6 Pol - deswegen auch der Zopf. Für den I2C-Mode muss man die Kontakte von GND, SCL, SDA und RST zwischen den Platinen verbinden. Außerdem muss man den SBOOT-Pin vom DSP mit GND verbinden.

2) Flashen des EEPROM
Zum Flashen des EEPROM muss man wie oben beschrieben den kleinen Schalter SW1 umlegen. Nach dem Flaschen wieder zurück, sonst startet der DSP beim nächsten Mal nicht.

3) Ein-/Ausgang-Kabel
Für die Masse der Signalwege zum ADC bzw. vom DAC ist SGND und nicht das normale GND zu nutzen!


Was es noch herauszufinden gibt: Welche Adressen sind die Potis und wie erstelle und verknüpfe ich diese im SigmaStudio? Nutzen werde ich sie voraussichtlich aber gar nicht, da sie in meinem Fall nicht zugänglich sind.


[Beitrag von Ymf am 14. Aug 2016, 17:07 bearbeitet]
ropf
Stammgast
#10 erstellt: 14. Aug 2016, 19:42
Sure verspricht:


Transparent to design resources

For sake of saving the development investment, we've also attached the schematics, demostra-
tion project resources and datasheet for the reference. All the files can be downloaded from our
website store www.sure-electronics.com. If you have further OEM requiremet or application
questions, please contact our technical support.


Würd einfach mal den Support anmailen, dass sie dir das Projektfile für Sigmastudio zuschicken.
Zalerion
Inventar
#11 erstellt: 15. Aug 2016, 13:36
@ymf:

Super interessant, und verständliche Anleitung.

Nur eine Frage hätte ich noch:
Dieses freeDSP Board, was genau muss man da wo bestellen? Auf deren Seite finde ich nur ein Link zur Reichelt-Liste und da fehlt z.B. die Platine, die man bei dir sehen kann. Und nach meinem Verständnis (bin allerdings nicht gut auf dem Gebiet) fehlt da auch mindestens ein Kondensator.

Dieses andere Board (CY7C68013A-56) muss man sich wohl über Ebay bestellen?



Da es anscheinend bisher noch keine vollständige Anleitung gab, wäre es natürlich super, wenn hier im Forum die Infos auf einem Haufen zusammentragen werden könnten



Edith:
Habe gerade den Link von ropf gesehen, war so klein, hatte ich überlesen^.
Da scheint jemand das alles mehr oder weniger als komplettes Set anzubieten?


[Beitrag von Zalerion am 15. Aug 2016, 13:42 bearbeitet]
DjDump
Inventar
#12 erstellt: 15. Aug 2016, 14:49
Ja, bei den Kleinanzeigen bietet das jemand zum quasi Selbstkostenpreis an. Gerade sind die Bausätze aus, aber nächste Woche sollen sie wieder rein kommen.
Ymf
Stammgast
#13 erstellt: 15. Aug 2016, 16:31

Zalerion (Beitrag #11) schrieb:
Dieses freeDSP Board, was genau muss man da wo bestellen? [...]

Habe gerade den Link von ropf gesehen, war so klein, hatte ich überlesen.
Da scheint jemand das alles mehr oder weniger als komplettes Set anzubieten?


Soweit ich das verstanden habe, ist Ludwig die treibende Kraft der Seite freedsp.cc und des gesamten Projekts des FreeDSP. Meinen FreeUSBi habe ich auch bei ihm über Kleinanzeigen geholt. Ein sehr freundlicher Kontakt und der Versand ist super schnell.


Gleich noch ein kleiner Hinweis dazu:
In der Anleitung zum FreeUSBi steht, dass man das Board mit zwei Brücken modifizieren muss, indem man zwei Pins entfernt. Das war bei meinem Bausatz netterweise bereits erledigt.


[Beitrag von Ymf am 15. Aug 2016, 16:34 bearbeitet]
ropf
Stammgast
#14 erstellt: 15. Aug 2016, 18:48

Ymf (Beitrag #9) schrieb:
Was es noch herauszufinden gibt: Welche Adressen sind die Potis und wie erstelle und verknüpfe ich diese im SigmaStudio?

Die Aux-ADCs für die Potis findest du im Schematic-Tab unter Inputs - wie gewohnt einfach auf die Arbeitsfläche ziehen.

Was die Hardwareseite angeht bin ich nicht ganz sicher - glaub, das lief über die GPIO-Pins. Müsstest durchkingeln, an welchen GPIOs die Potis hängen und diese entsprechend conditionieren.

PS: Hier stehts genauer drin: Application Note AN-951


[Beitrag von ropf am 15. Aug 2016, 23:36 bearbeitet]
Kyumps
Inventar
#15 erstellt: 16. Aug 2016, 11:50
Zumindest kann ich sagen dass der Hobbyhifiladen aus dem Urlaub zurück ist,
die haben sich nämlich gestern bei mir gemeldet weil ich einen Tamp 1600 bestellt hatte und der nicht mehr lieferbar war, dafür gabs ohne Aufpreis den Tamp 1800 zugeschickt.

Probleme mit dem E-Mail Verkehr zw. mir und dem HH Laden gab es auch schon mehrfach, da meine Anfrage bei denen im Spam Ordner gelandet sind und eine Rückmeldung erst Wochen später geschah.
Seitdem ich das weiß ruf ich kurz an dass ich eine Mail geschrieben habe und dann bekomme ich schnell Antwort.

Was ich bisher so zu dem sure DSP lesen konnte bringt mir das Ding nichts da ich keine Vorprogrammierkenntnisse habe und eine Eingabemaske wie im MiniDSP benötige.
bierman
Inventar
#16 erstellt: 16. Aug 2016, 12:43
Ich habe mein DSP inzwischen auch bekommen. Leider zu spät - ich werd es vor dem Wochenende wohl zeitlich nicht mehr auf die Kette kriegen mich damit eingehender zu befassen.

Mein Ziel ist, vorerst möglichst viel hiervon umzusetzen:

- System-Hochpass (25-80 Hz regelbar wäre toll)
- Trennung Sub-Top mit einstellbarer Trennfrequenz 80-200 Hz
- Limiter als Schutz vor zu hohem Eingangssignal

Ein paar Pfostenstecker (IDE-Kabel und dergleichen) sind schon mal vorhanden, die Programmierung stell ich mir nicht zu kompliziert vor. Irgendwas zum EEPROM-Flashen liegt auch noch hier rum ob das passt k.A.
Bevor ich für weitgehend passive Hardware 50 EUR ausgebe löte ich mir sowas dann doch lieber selbst.
Ymf
Stammgast
#17 erstellt: 16. Aug 2016, 12:49
Naja, Programmierkenntnisse braucht man eigentlich nicht. Für die Basics in SigmaStudio ist die Anleitung des FreeDSP sehr hilfreich. Danach ist es eigentlich kein Aufwand einfache Sachen wie EQ, Laufzeitkorrektur und Pegelkontrolle einzustellen (mit der Regelung über die Potis habe ich mich, wie gesagt, noch nicht auseinandergesetzt). SigmaStudio ist etwas allgemeiner gehalten, als die normalen Programmiermasken, aber ich hatte nach wenigen Stunden die Basics raus. Da hätte es, denke ich, bei jeder Maske ähnlich lang gebraucht, um den Aufbau nachvollziehen zu können.

Da wird das Löten für Leute, die noch keinen Lötkolben in der Hand hatten ein größeres Hindernis. Sollte aber auch niemanden abschrecken!


[Beitrag von Ymf am 16. Aug 2016, 12:51 bearbeitet]
Horns4ever
Ist häufiger hier
#18 erstellt: 16. Aug 2016, 18:48
Hat schon jemand das RCA Interface dazu bestellt?
peak-lsv
Ist häufiger hier
#19 erstellt: 16. Aug 2016, 19:26
Ja, ich.

Hast du eine bestimmte Frage?
Horns4ever
Ist häufiger hier
#20 erstellt: 17. Aug 2016, 12:32
Ja, ich frage mich ob ich das denn brauche
- ich brauche kein cinch weil ich das intern verkabeln will
- ich brauche auch keinen KHV
- ich hab jetzt nirgends gefunden (oder übersehen) für was die 2 IC und restlichen Bauteile auf der Platine sind

nur Kopfhörerverstärker ?
Puffer OPV?
Filter? also ich meine die output Filter für die DAC aktiv oder passiv die lt. ADAU 1701 Datenblatt S 21 nötig sind
oder sind die schon mit auf dem DSP Board?

Ist da bei der Lieferung etwas dazu beschrieben?

Grüße
Ralf
Agetommy
Ist häufiger hier
#21 erstellt: 17. Aug 2016, 15:45
Die AD und DA Wandler im ADAU 1701 sind in meinen Augen die "Problemzone", wenn ich pingelige Ohren habe
Die Lösung ist in meinen Augen den ADAU 1701 nur seiner DSP Tätigkeit nachgehen zu lassen und bei allem wo es analog wird, ihm das abzunehmen.
Also:

  • Als Eingang: SPDIF zu I2S Wandler.
  • Als Ausgang: Hochwertigere DACs mit I2S Input, wie z.B. die ES9018K2M wie sie im asiatischen DIY-Shop oder bei Ebay (für schmales Geld) angeboten werden.


Ich bin eben durch das Datenblatt des ADAU 1701 geflogen... Stichwort ist "Serial-Mode". Die MPIO Pins, sind dann jeweils I2S Ein- bzw. Ausgänge.
Den globalen Hauptschalter (Register-Wert) um den Seriellen-Mode einzuschalten, habe ich auf die schnelle nicht gefunden.
Hat jemand Erfahrung mit dem Serialmode des ADAU 1701?
Piljack
Stammgast
#22 erstellt: 17. Aug 2016, 22:50
Sind noch im Urlaub bis nächsten Montag, laut Homepage.
Hab den DSP mit RCA Extension seit letzter Woche am laufen, bin schwer beeindruckt von den Möglichkeiten. Vom Einfluss auf den Klang kann ich nur positives berichten, Raumabbildung, Stabilität wie ohne den DSP, auch kein Vorhang vor den Lautsprechern, passt alles. Die Liveabhöre ist extrem klasse, man dreht den Regler in der Software und hört direkt die Auswirkungen, quasi WYSIWYG für Audio. Das Manko seh ich momentan noch an der Programmier- Schnittstelle, dazu wird leider noch nichts eigenes angeboten.

Für September ist eine Hörsession beim HHL angekündigt. Accuton 3-Wege mit Cell Vollaktiv mit dem DSP und andere, wie Fostex BB und Home-PA. Die meisten Endstufen können wohl auch alle Probe gehört werden, wie der Gremlin und Godzilla. Ein DSP How-To findet ebenfalls statt. Eigene Elektronik kann zwecks Vergleich auch gerne mitgeschleppt werden. Ich bin so frei und poste mal den Link zu der Veranstaltung: http://www.hobbyhifi...on-im-september-2016
DjDump
Inventar
#23 erstellt: 27. Aug 2016, 17:38
Ich scheitere gerade an der Installation von den FreeUsbi Treibern. Die Dokumentation gibt für mein Wissen einfach nicht genügend Information her. Es fängt mit dem Runterladen der Treiber an. Da wird man zu einer Github Seite geleitet, aber es gibt keinen Download Button. Nur wenn man aufs unterste Level geht kann man Dateien einzeln runterladen. Eine Datei kann man gar nicht runterladen (bei Win10 64bit die Datei "cyusb3.inf")
Da habe ich dann den angegebenen Inhalt der Datei in eine Textdatei gepackt und die in eine .inf umgewandelt.
Ist das soweit richtig?
Alle Dateien, zusammen mit der einen aus dem Sigma Studio Ordner habe ich in einen Ordner Names "Free Usbi Drivers" gepackt. Dann die Win10 Neustart Prozedur. Jetzt öffne ich den Gerätemanager, klicke auf das Gerät mit Ausrufezeichen und wähle "Treibersoftware aktualisieren". Da kann ich den Ordner mit den Treibern auswählen und bekomme folgenden Fehler:
Treiber Fehler

Hat jemand einen Rat? Und hat es schon jemand bei Win10 64bit am laufen? Ich habe das Gefühl, dass beim Treiberdownload was schiefgelaufen ist.
DjDump
Inventar
#24 erstellt: 27. Aug 2016, 18:57
Hallo,

Die Treiber sind jetzt korrekt installiert. Problem war wirklich der Download. Wenn man in den Hauptordner auf Github navigiert, kann man eine Zip Datei von allem Runterrladen. Davon braucht man dann nur einen Teil.

Aber Probleme gibts immernoch
Ich habe mir das Adapterkabel zusammengelötet, wie hier beschrieben:

1) Kabel für den FreeUSBi
Kabel vom FreeUSBi hat eine andere Belegung und einen anderen Stecker. FreeUSBi 2x5 Pol und SureDSP komischer 1x6 Pol - deswegen auch der Zopf. Für den I2C-Mode muss man die Kontakte von GND, SCL, SDA und RST zwischen den Platinen verbinden. Außerdem muss man den SBOOT-Pin vom DSP mit GND verbinden.

Sobald das Kabel im DSP steckt, kommt kein Ton mehr. Es muss nicht im FreeUSBi stecken. Das liegt anscheinend an der Verbindung von SBOOT und GND. Ist das soweit bei dir auch so?

Uploaden klappt auch nicht, vllt hängt da ja mit dem vorherigen Problem zusammen.

Wenn ich in Sigma Studio im Hardware Confuguration Tab ein USBiAudio Block reinziehe, ist der Orange. Das passt soweit, oder?

Kann mir jemand eine funktionierende Sigma Studio Datei zuschicken? Und welche Schritte muss man zum Uploaden machen?

Wenn das alles bei mir läuft stelle ich ein Tutorial auf Youtube und meine Webseite. Das ist momentan schon ein ziemlicher Krampf...

Leo
Ymf
Stammgast
#25 erstellt: 27. Aug 2016, 20:42
Hast du dir die Anleitung von FreeUSBi angeschaut und die Installationsreihenfolge befolgt?

Frei übersetzt:
0. SigmaStudio installieren.
1. Die Jumper (beide) vom Board abziehen und weglassen.
2. DenUSBi Datensatz mit den Treibern gesamt runterladen und entpacken.
3. Auf Laufwerk C: nach der Datei "ADI_USBi.spt" suchen und diese in den Treiberordner von deiner Win-Version kopieren.
4. Den FreeUSBi ohne DSP mit dem PC verbinden.
5. Treiber aus dem Ordner über den Gerätemanager zuweisen und Installation bestätigen.
6. FreeUSBi abstecken und wieder dranstecken.
7. In SigmaStudio nachsehen, dass der FreeUSBi erkannt wurde. (Bei mir wird das Feld hinter USB grün.)

Jetzt kann man den DSP an den FreeUSBi hängen. Dieser sollte verstummen, weil er Anweisungen von SigmaStudio erwartet. Hier mal die Basisdatei für den SureDSP, die ich mir erstellt habe. Dort sind alle Ein- und Ausgänge eingefügt und beschriftet.

Zum testen kannst du auch meine aktuelle Version fürs Auto nehmen. Diese Einstellung läuft so wie sie da steht aktuell in meiner Anwendung.


Edit 1: Ich habe übrigens nicht den USBi Audio, sondern den USBi Block verwendet! Aber nimm einfach eine der Dateien.

Edit 2: Zum Testen auf "Link Compile Download" gehen, dann sollte Ton aus dem DSP kommen.


[Beitrag von Ymf am 27. Aug 2016, 20:50 bearbeitet]
DjDump
Inventar
#26 erstellt: 28. Aug 2016, 18:46
Vielen Dank für deine Antwort, es läuft allerdings immer noch nicht, die Situation hat sich sogar noch verschlechtert.

Das FreeUSBi wurde in Sigma Studio erkannt, und war grün hinterlegt. Beim "Link Compile Download" gibt es allerdings eine Fehlermeldung. Meine Nachforschrungen haben dan ergeben, dass man das man nicht die USB Ports wechseln soll und immer USB2.0 verwenden. Da ich mir nicht sicher war, ob ich die mal gewechselt habe, habe ich die Treiber nochmal deinstalliert. Jetzt bekomme ich sie allerdings nicht mehr installert. Das FreeUSBi wird jetzt im Gerätemanager nicht mehr als "Unbekanntes Gerät" erkannt, sondern als "EZ-USB". So hieß es allerdings nicht, als die Treiber noch drauf waren. Das Ausrufezeichen vo dem Namen ist allerdings da. Wenn ich versuche die Treiber zu installieren, kommt sofort die Meldung:
Treiber nicht gefunden

Aber dieser Schritt ging ja schon ?!

Bei mir leuchten die LEDs "I2C" und "PWR". Ist das normal? Außerdem wird das Free USBi sowieso nur erkannt, wenn es nicht mit dem DSP verbunden ist. Es gibt ja die eine Kabelverbindung zwischen den beiden Platinen vom FreeUSBi. Daneben ist noch ein GND Anschluss, der keine Verbindung hat. Ist das richtig?
Momentan versuche ich es an meinem Win10 Laptop zum laufen zu bekommen. Bei meinem Win7 Computer geht es auch nicht, da bekomme ich aber auch andere Fehlermeldungen.
Ich verwende außerdem Sigma Studio 3.13, also die Beta. Jetzt werde ich mal die Vorgängerversion testen...


Edit: Spielt es eine Rolle, ob DSP und FreeUSBi von der gleichen Stromquelle (Computer) laufen? Muss beim live programmieren der Schlater am DSP links oder rechts sein?

Edit2: Sigma Studio 3.12 installiert und sofort wird das FreeUSBi erkannt. An den Treibern musste ich nichts ändern. Am DSP gibts ja den Kontakt "WP", der muss nicht verbunden sein?


[Beitrag von DjDump am 28. Aug 2016, 19:04 bearbeitet]
Ymf
Stammgast
#27 erstellt: 28. Aug 2016, 20:33
Scheint so als hättest du etwas Treibersalat fabriziert

Versuchs mal mit folgendem Vorgehen: Gerätemanager -> Treiber aktualisieren -> Auf dem Computer nach Treibern suchen -> Aus einer Liste von Gerätetreibern auswählen. Wenn hier ein AD USBi (programmed) angezeigt wird, diesen auswählen.

Dass die Power LED brennt ist normal, dann die I2C LED nach kurzer Zeit auch anfängt zu leuchten ist auch normal.

DSP und FreeUSBi müssen nicht die selbe Stromquelle haben. Bei mir wird der DSP aktuell übers Radio gespeist und der FreeUSBi über den PC. Das tut. Ich benutze das letzte SigmaStudio ohne Beta. An den Anschlüssen habe ich seit meiner Beschreibung nichts geändert.
bjrn
Neuling
#28 erstellt: 28. Aug 2016, 22:52
Hab auch ein Problem mit meinem Adapter. Der Treiber wurde installiert, jedoch nicht initialisiert. Auch Deinstallieren hilft nicht. Hatte jemand ein ähnliches Problem?

Bildschirmfoto 2016-08-28 um 22.49.29

Der freeUSBi wird demnach auch nicht in SigmaStudio erkannt. Hab noch nicht die Platine auf dem Adapter, aber das sollte ja keinen Unterschied machen. Dort werden ja nur die entsprechende Pins zum Stecker geführt.
DjDump
Inventar
#29 erstellt: 28. Aug 2016, 23:25
Den Fehler hatte ich zwischenzeitlich auch. Was ich geändert habe damits geht, weiß ich aber nicht.. Usb Ports tauschen und ganz viel Installieren und Deinstallieren hilft vielleicht.
Ymf
Stammgast
#30 erstellt: 30. Aug 2016, 20:29

bjrn (Beitrag #28) schrieb:
Hab noch nicht die Platine auf dem Adapter, aber das sollte ja keinen Unterschied machen. Dort werden ja nur die entsprechende Pins zum Stecker geführt.


In diesem Punkt bin ich mir nicht sicher, man könnte es über den Schaltplan herausfinden, aber einfacher wäre es doch kurz die Platine zu löten.
Falls es dann trotzdem die Fehlermeldung gibt, kurz rückmelden.
DjDump
Inventar
#31 erstellt: 03. Sep 2016, 19:11
Es geht
Ich habe einen ziemlich blöden Fehler gemacht und schäme mich auch ein bisschen dafür
Ich habe die Pinbelegung am FreeUSBi auf den Stecker bezogen, nicht auf die Buchse. Dadurch hatte ich das Kabel gespiegelt angeschlossen und nichts hat zusammengepasst.

Momentan läuft es an meinem Win10 Laptop. Am Win7 Rechner hab ich es noch nicht zum laufen gebracht.


Den Fehler hatte ich zwischenzeitlich auch. Was ich geändert habe damits geht, weiß ich aber nicht.. Usb Ports tauschen und ganz viel Installieren und Deinstallieren hilft vielleicht.

Die Aussage muss ich wiederrufen. Ich sehe gerade, dass das eine Win7 Fehlermeldung ist. Da wurde das USBi bei mir noch nie korrekt erkannt.

Unter Win10 ist es im Gerätemanager bei "USB-Controller" als "Analog Devices USBi (programmed)" aufgeführt.


Vielen Dank an alle die mir geholfen haben und besonderen Dank an Ymf.
Leo


[Beitrag von DjDump am 03. Sep 2016, 19:11 bearbeitet]
Ymf
Stammgast
#32 erstellt: 04. Sep 2016, 15:34

DjDump (Beitrag #31) schrieb:
Es geht


Das freut mich! Den Fehler die Kabel zu vertauschen habe ich auch gemacht, allerdings habe ich es gemerkt bevor ich den FreeUSBi das erste Mal angeschlossen hatte. Entsprechend kannte ich die Folgen nicht.

Was ist das Problem am Win7 Rechner? Bei mir läuft alles unter Win7 einwandfrei.
IPv6
Stammgast
#33 erstellt: 04. Sep 2016, 17:16
Hallo an Alle!

Ich habe eine Frage zu dem Board bzw. dessen Möglichkeiten und hoffe, dass das hier halbwegs passt.
Falls die Idee umsetzbar ist gibt das dann nochmal einen extra Thread damit es hier nicht zu speziell wird.

Ich bin schon länger am überlegen, einen "Bassprozessor" für unser Reggae-Soundsystem zu bauen. Das Ding soll einfach ein bisschen Spielerei mit den Basslines ermöglichen und im Prinzip bloß aus einem grafischen EQ mit 5 Bändern zwischen 30 Hz und 100 Hz sowie einem in der Frequenz variablen Hochpassfilter bestehen. Eventuell zusätzlich noch einen parametrischen EQ, aber das ist kein muss.
Jetzt habe ich lange Zeit über Analogschaltungen gegrübelt und damit lässt sich das Ganze natürlich umsetzen, es wird aber ein Bauteilgrab an Operationsverstärkern, Kondensatoren und Widerständen, was sich auch nicht ganz simpel auf einer Platine unterbringen lässt. Vor allem, wenn das Ganze noch in stereo aufgebaut werden soll.

Als ich über diesen Thread gestolpert bin kam mir die Idee, dass es im 21. Jahrhundert doch möglich sein sollte, das Stereosignal zu digitalisieren und die EQs bzw. Filter "einfach" als Einsen und Nullen berechnen zu lassen.
Klingt ja erstmal etwas unglaublich, bloß ein kleines DSP Board für 20€, dass das alles können sollte und dabei noch extrem flexibel ist was nachträgliche Veränderungen angeht (z.B. die Frequenzen und Güten der grafischen EQs).

Jetzt mein Problem:
Das Board scheint wohl mehr auf einmal einrichten und dann laufen lassen ausgelegt zu sein und weniger auf "Liveeinsatz" mit ständigen Veränderungen der Parameter.
Ich bräuchte den Zugriff auf die EQs natürlich per Poti an der Frontplatte im 19" Gehäuse, das scheint der Prozessor sogar zu unterstützen, allerdings nur mit bis zu 4 analogen Eingängen, was für mich nicht ausreicht. Diese vier Eingänge sollten sich aber für meinen Zweck verwenden lassen, im PDF sind als Beispiele immerhin Lautstärkeeinstellung, Bassanhebung und Trennfrequenzveränderung als Beispiel für die Potis aufgeführt.

Gäbe es eine Möglichkeit, die Stellung der Potis extern zu digitalisieren und über die anderen multipurpose pins mit Funktionen zu belegen? Ich habe zwar umfassendes elektrotechnisches Grundwissen aber bei AD Wandlung und digitaler Datenübertragung von Chip zu Chip fehlt mir das Wissen.
Eventuell per Arduino die ganzen Potis (ca. 7 Stück) einlesen und ihre Werte seriell an das DSP zu übertragen?
Oder gibt es digitale Signalprozessoren, die für meinen Zweck geeigneter sind?
Ich bin doch bestimmt nicht der erste, der auf so eine Idee kommt, das ganze wäre ja z.B. auch als Gitarreneffekt oder Ähnliches zu gebrauchen.

Viele Grüße!
Ymf
Stammgast
#34 erstellt: 06. Sep 2016, 10:29
Den EQ und die Weichen zu erstellen ist mit dem DSP kein Problem. Schwieriger scheint es für mich die Ansteuerung von außen zu bewerkstelligen. Eine spontane Idee wäre es über die digitalen Eingänge Schalter in das Programm zu integrieren und mit deren Hilfe die Funktionalität der Potis zu verändern. Damit könnte man theoretisch genügend Verstellmöglichkeiten erstellen. Ob das allerdings so klappt wie ich mir das gerade vorstelle gilt nachzuweisen.

Es funktioniert auf jeden Fall (mehr oder weniger gut) das Programm im Betrieb über den PC zu verändern. Falls das eine Möglichkeit ist, die dich zufriedenstellen würde.
DjDump
Inventar
#35 erstellt: 06. Sep 2016, 12:18
Tutorials für den Zusammenbau und die Treiberinstallation, sowie Sigma Studio findet ihr ab sofort auf meinen Youtube Kanal.

@ IPv6:
Vielleicht ist es am einfachsten, mehrere DSP Boards anzuschließen. Schon mit zwei hättest du ja deine gewünschten 8 Potis.
Ymf
Stammgast
#36 erstellt: 06. Sep 2016, 15:11
Schöne Anleitungen, danke dafür! Ich darf diese an anderer Stelle verlinken nehme ich an?

Kleine Anmerkungen:
- Stecker einfach auf dem FreeUSBi drauf bestücken, dann vertauscht man die Pinbelegung nicht.
- Ich habe eine mögliche Fehlerquelle bei deiner Treiberinstallation im Video gefunden: Du kopierst die Datei "ADI_USBi.spt" nicht, sondern verschiebst sie, so wie es aussieht. Neuinstallation von SigmaStudio bringt die Datei dann wieder an ihren Platz und es funktioniert. Evtl. langen die Probleme daran? Das mit dem Treiberzertifikat habe ich nicht gewusst, zum Glück habe ich Win7, das fragt ja nur statt die Installation zu blocken.
- Beim SigmaStudio Video habe ich die Laufzeitverzögerung vermisst. Die hat die Eigenart in Samples gerechnet zu werden, was bei 48kHz Samplerate etwa 0,02ms entspricht. Sonst alles sehr hilfreich erklärt!
IPv6
Stammgast
#37 erstellt: 06. Sep 2016, 21:39
Vielen Dank für euren Input!
Damit das Ganze hier übersichtlich bleibt habe ich ein eigenes Thema für das doch recht spezielle Problem erstellt.
Hier gehts weiter
bjrn
Neuling
#38 erstellt: 07. Sep 2016, 00:38
Habe auch noch etwas herum probiert und bei mir will es einfach nicht laufen. Vielleicht liegt es auch daran, dass Windows bei mir in einer virtuellen Maschine als 64 bit Version läuft oder der Adapter hat unter Umständen einen defekt. Wobei ich eher an ersteres glaube.

Vielleicht komme ich mal dazu das unter einem nativen Windows zu testen.
Ymf
Stammgast
#39 erstellt: 07. Sep 2016, 08:35
Welches Windows hast du denn laufen? Wenn es Win8 oder Win10 ist, hast du die Sache mit den Zertifikaten beachtet, die DjDump in seinem Video schildert?
DjDump
Inventar
#40 erstellt: 07. Sep 2016, 14:16
Bevor jemand den gleichen Fehler wie ich macht:
Die GPIO Pins geben nur maximal 2mA her. Das reicht noch nicht mal für die meisten LEDs.
Wenn man dennoch versucht eine stärkere LED anzuschließen, kann man nichts mehr hochladen (so zumindest bei mir). Zum Glück ist bei mir die finale Version schon drauf
Kc*Rage
Stammgast
#41 erstellt: 09. Sep 2016, 13:19
Ich bin gerade dabei mich in das Thema miniDSP einzulesen. Macht das DSP von Sure etwas besser als das 2x4 von Monacor? Ich mein Sure DSP, Anschlussintervace und Programmieradapter zusammen kosten ja unterm Strich genauso viel. Nur habe ich hier den Ärger mit dem Konfigurieren und das Monacor DSP ist ja quasi plug&play und hat noch nen Ausgang mehr...


[Beitrag von Kc*Rage am 09. Sep 2016, 13:19 bearbeitet]
DjDump
Inventar
#42 erstellt: 09. Sep 2016, 13:57
Ja, eine ganze Menge.
Preislich ist das schon viel weniger. Ich weiß net wie du da auf den gleichen Preis kommst.
Sure ADAU1701: 25€
Free USBi: 20€
Anschlussinterface (gekauft oder selbst gebaut): 15€

Macht zusammen 60€, wobei das FreeUSBi nach dem Programmieren ja immernoch frei ist. Wenn man sich einen Lautsprecher entwickelt, rechnet man das Messmikrofon auch nicht in den Preis ein.

Das Sure DSP hat auch 4 Ausgänge. Das Anschlussinterface hat nur 3 Buchsen drauf (da fragt man sich, wer sich sowas ausdenkt).
Außerdem hast du noch digitale Ausgänge, an die du externe DA Wandler anschließen kannst.

Außerdem hat man bei dem Sure DSP Zugang zu den GPIOs. Nicht jeder braucht das, aber damit kann man schon ne Menge anstellen.
Und die Software Sigma Studio gibt so viel mehr her als die Plugins vom MiniDSP (die man ja auch einzeln dazu kaufen muss).

Ich glaube das ist ein bisschen so wie mit Apple und Linux. Apple funktioniert einfach, aber wenn man gerne rumspielt und quasi unlimitierte Einstellmöglichkeiten sucht, ist man bei Linux besser aufgehoben.


[Beitrag von DjDump am 09. Sep 2016, 14:00 bearbeitet]
Ymf
Stammgast
#43 erstellt: 09. Sep 2016, 14:07
Ich hatte den MiniDSP noch nicht in der Hand, Hardwareseitig ist es scheinbar das selbe. Der Unterschied zwischen MiniDSP und SureDSP liegt wohl vor allem darin, dass man den SureDSP ohne Anschlussplatine kaufen und somit leichter in ein Gerät integrieren kann. Will man Cinch-Ausgänge zum Anschluss verwenden, wird der Unterschied nur minimal, vor allem weil die Anschlussplatine des SureDSP nachteilig ist.
Auch bieten sich Vorteile bei mehreren Geräten, da nur ein Programmer gebraucht wird und der zweite DSP nur noch einen Bruchteil des Aufwands kostet.

Die Software des MiniDSP scheint gegenüber den Möglichkeiten von SigmaStudio begrenzt. Ich habe oft das Stichwort FIR-Filter gelesen. Ob du diese breiteren Möglichkeiten brauchst und nutzen wirst, ist die andere Frage.
Kc*Rage
Stammgast
#44 erstellt: 09. Sep 2016, 14:15
Ok, ich bin von dem EVAL-ADUSB2EBZ USBi ausgegangen, wie es in der Produktbeschreibung bei Hobbyhifiladen seht. Das Teil kostet ja um die 80 Euro... mit dem FreeUSBi wärs ja tatsächlich gut die Hälfte billiger. Wo bekommt man den denn her? Oder muss man sich den selbst zusammenbauen?
Ymf
Stammgast
#45 erstellt: 09. Sep 2016, 14:22
Einen Bausatz mit allen benötigten Komponenten gibt es auf Kleinanzeigen. Löten darf man selbst.
Viper780
Inventar
#46 erstellt: 09. Sep 2016, 14:49
gibts auch um 10-15€ aus China
DjDump
Inventar
#47 erstellt: 09. Sep 2016, 17:21
Hast du einen Link parat?
Da_Alchemist
Stammgast
#48 erstellt: 09. Sep 2016, 21:39
Hat schonmal jemand den Sure DSP mit einem Raspi über I²C programmiert? Ich bin soweit , dass das EEprom erkannt wird, den Schreibversuch hab ich noch nicht durchgeführt...

Ich versteh leider nicht zuviel davon, eigentlich gar nichts. Mit dem SigmaStudio kann man ein HEXFile erstellen, das wird erstellt, wenn kein Programmiergerät angeschlossen ist (tatsächlich werden mehrere erstellt), aber wie geht es dann mit dem File Weiter?

Gruß
Ymf
Stammgast
#49 erstellt: 10. Sep 2016, 09:38
In der Anleitung zum FreeDSP gibt es eine Beschreibung wie man einen Arduino Nano zum Beschreiben des EEPROM nutzen kann. Vielleicht hilft dir diese weiter.
Viper780
Inventar
#50 erstellt: 10. Sep 2016, 18:30
http://www.ebay.de/s...&_sop=15&_mwBanner=1

ich hab die eBay suche aus dem diy forum welches einen recht guten Thread dazu hat
DjDump
Inventar
#51 erstellt: 10. Sep 2016, 18:40
Wobei damit laut Free USBi Anleitung keine Echtzeit Einstellung der Parameter möglich ist. Da hat man dann immer eine kurze Pause (1sec).
Suche:
Gehe zu Seite: Erste 2 3 4 5 6 . 10 . 20 . Letzte |nächste|
Das könnte Dich auch interessieren:
sure dsp brummt
spaceman-b am 19.05.2017  –  Letzte Antwort am 01.06.2017  –  9 Beiträge
Sure Dsp + Keystone Dab Radio i2s
creapetime am 31.10.2017  –  Letzte Antwort am 07.11.2017  –  4 Beiträge
Vorstellung AIDA DSP Projekt
IPv6 am 30.01.2018  –  Letzte Antwort am 31.01.2018  –  6 Beiträge
Sure Akku-Erweiterung
Spreader26 am 07.02.2017  –  Letzte Antwort am 19.02.2017  –  3 Beiträge
Erfahrung - Sure Electronics IRS2092
Piljack am 05.06.2015  –  Letzte Antwort am 27.01.2016  –  19 Beiträge
Belegungsfrage zur Sure-Amp
psychofaktory am 10.08.2017  –  Letzte Antwort am 29.09.2017  –  18 Beiträge
tda7492 SURE ELECTRONICS - CE Zulasdung?
Magnat^^ am 13.02.2014  –  Letzte Antwort am 01.08.2015  –  14 Beiträge
Vorverstärker zwischen DSP und Endstufe
Steff_Feel_It am 13.11.2010  –  Letzte Antwort am 14.11.2010  –  11 Beiträge
Sure DSP gibt einen grausamen Ton aus bei Übertragung der Daten?
Phil9292 am 05.09.2017  –  Letzte Antwort am 06.09.2017  –  5 Beiträge
Sure Verstärker mit Handy voll aussteuern
-Raphael am 08.05.2014  –  Letzte Antwort am 06.06.2016  –  15 Beiträge

Anzeige

Aktuelle Aktion

Partner Widget schließen

  • beyerdynamic Logo
  • DALI Logo
  • SAMSUNG Logo
  • TCL Logo

Forumsstatistik Widget schließen

  • Registrierte Mitglieder842.312 ( Heute: 38 )
  • Neuestes Mitgliedhecke5791
  • Gesamtzahl an Themen1.404.301
  • Gesamtzahl an Beiträgen18.743.105